Page 1 of 1

MX record

Posted: Wed May 15, 2019 9:57 pm
by WantedStarling
Hello, I am trying to install Zimbra following the steps from this page https://blog.zimbra.com/2016/05/install ... 14-04-lts/. I am using Ubuntu 14.04 and have set up a static IP. Now I am on the step where I configure the dnsmasq. I finished with the dns configuration and tried to do an mx record. The answer I get is: Image.
The answer in the picture on the guide is different. On the answer section at the end of the line it has the full server address while mine shows the static IP I have set. Also one more difference is that I don't get the Additional Section as shown also on the guide. Please tell me if I doing something wrong. I am not going to proceed with the installation until I figure out these two.

Thank you for your time

Re: MX record

Posted: Thu May 16, 2019 9:08 am
by phoenix
I don't use dnsmasq so I'm no expert in configuring it but if you're not getting the correct response then your configuration is incorrect. Take a look at the Split DNS wiki article and it should give you a good example on wht needs to be configured.

Re: MX record

Posted: Thu May 16, 2019 12:13 pm
by Klug
The MX should be (ie: it has to be) a FQDN.

So you have two mistakes here.
The first is you're using an IP address instead of a FQDN.
The second is you've added a dot at the end of the IP address (this is only to be used with FQDN).

Re: MX record

Posted: Thu May 16, 2019 2:01 pm
by WantedStarling
I actually managed to solve this but I now get an error during the installation about the MX again. Here are the new results: Image

Besides that I am now stuck on the step that says

DNS ERROR resolving MX for zimbra.wantestarling.com
It is suggested that the domain name has an MX record configured in DNS
Change domain name? [Yes]


I chose to change it and entered wantedstarling.com again. But it still doesn't find this domain.

Re: MX record

Posted: Thu May 16, 2019 5:11 pm
by Klug
It means the DNS resolver the zimbra server is using is not aware of the MX record you've set up.

You might want to check the SplitDNS wiki page.

Re: MX record

Posted: Thu May 16, 2019 6:14 pm
by Rony
If it is your real domain wantedstarling.com, it cannot be found.
Try using this tool to search for all your DNS settings:
https://www.whatsmydns.net