Problemas al recibir correos desde gmail

Yehiner
Posts: 5
Joined: Fri Feb 20, 2015 10:15 am

Problemas al recibir correos desde gmail

Postby Yehiner » Fri Feb 20, 2015 10:31 am

Envío correos desde gmail a mi servidor de correo zimbra 8.6.0 generando los siguientes mensajes en el archivo zimbra.log y no los entrega al buzón, no llega ningún mensaje de rebote a gmail.


postfix/smtpd[16557]: connect from mail-ob0-f179.google.com[209.85.214.179]
postfix/smtpd[16557]: SSL_accept error from mail-ob0-f179.google.com[209.85.214.179]: 0
postfix/smtpd[16557]: warning: TLS library problem: error:1409442E:SSL routines:SSL3_READ_BYTES:tlsv1 alert protocol version:s3_pkt.c
:1292:SSL alert number 70:
postfix/smtpd[16557]: lost connection after STARTTLS from mail-ob0-f179.google.com[209.85.214.179]
postfix/smtpd[16557]: disconnect from mail-ob0-f179.google.com[209.85.214.179]



Los demás correos llegan sin problema (hotmail, yahoo, empresas).



Gracias por su colaboración.



User avatar
jorgedlcruz
Zimbra Alumni
Zimbra Alumni
Posts: 2769
Joined: Thu May 22, 2014 4:47 pm

Problemas al recibir correos desde gmail

Postby jorgedlcruz » Mon Feb 23, 2015 9:57 am

Saludos Yehiner,


Prueba estos comandos:


zmprov mcf +zimbraMailboxdSSLProtocols SSLv2Hello
zmmailboxdctl restart


Un saludo

Jorge de la Cruz https://jorgedelacruz.es
Technical Marketing Manager at Zimbra/Synacor https://www.zimbra.com/
Yehiner
Posts: 5
Joined: Fri Feb 20, 2015 10:15 am

Problemas al recibir correos desde gmail

Postby Yehiner » Mon Feb 23, 2015 1:40 pm

Hola Jorge,

Gracias por tu respuesta.

Intenté adicionando el protocolo, pero continúa el problema.



$ zmprov gcf zimbraMailboxdSSLProtocols



zimbraMailboxdSSLProtocols: TLSv1

zimbraMailboxdSSLProtocols: TLSv1.1

zimbraMailboxdSSLProtocols: TLSv1.2

zimbraMailboxdSSLProtocols: SSLv2Hello



zimbra.log:

postfix/smtpd[7742]: connect from mail-ob0-f175.google.com[209.85.214.175]

postfix/smtpd[7742]: SSL_accept error from mail-ob0-f175.google.com[209.85.214.175]: 0

postfix/smtpd[7742]: warning: TLS library problem: error:1409442E:SSL routines:SSL3_READ_BYTES:tlsv1 alert protocol version:s3_pkt.

c:1292:SSL alert number 70:

postfix/smtpd[7742]: lost connection after STARTTLS from mail-ob0-f175.google.com[209.85.214.175]

postfix/smtpd[7742]: disconnect from mail-ob0-f175.google.com[209.85.214.175]
User avatar
jorgedlcruz
Zimbra Alumni
Zimbra Alumni
Posts: 2769
Joined: Thu May 22, 2014 4:47 pm

Problemas al recibir correos desde gmail

Postby jorgedlcruz » Mon Feb 23, 2015 7:01 pm

Saludos,

Solo se me ocurre que el certificado de tu servidor este dañado de alguna manera, he estado mirando opciones en otros foros y encuentro que puede estar ahí el problema.



¿Es vuestro certificado Comercial o Auto Firmado?



Un saludo
Jorge de la Cruz https://jorgedelacruz.es
Technical Marketing Manager at Zimbra/Synacor https://www.zimbra.com/
AndresTarallo
Advanced member
Advanced member
Posts: 56
Joined: Fri Sep 12, 2014 11:53 pm
Location: Montevideo, Uruguay
Contact:

Problemas al recibir correos desde gmail

Postby AndresTarallo » Wed Feb 25, 2015 11:48 am

Hola:


Tengo exactamente el mismo problema en ZCS 8.0.7. No tengo la solucion aun, en otros foros de Zimbra (en Ingles) y en la WEB he visto que desactivan en Postfix SSLV2 y SSLV3:


postconf -e smtpd_tls_protocols='!SSLv2,!SSLv3'
postconf -e smtpd_tls_mandatory_protocols='!SSLv2,!SSLv3'


Hice eso y reincie el postfix, pero sigo teniendo el problema. La solucion que plante a jorge no me parece que funcione. Son parámetros del servidor de las casillas, no del MTA (postfix).

AndresTarallo
Advanced member
Advanced member
Posts: 56
Joined: Fri Sep 12, 2014 11:53 pm
Location: Montevideo, Uruguay
Contact:

Problemas al recibir correos desde gmail

Postby AndresTarallo » Wed Feb 25, 2015 12:10 pm

Para depurar este problema aumente la verbosidad del log TLS:


zmlocalconfig -e  postfix_smtpd_tls_loglevel=2



Aqui tengo la salida:


Feb 25 15:59:28 srv-correo postfix/smtpd[1212]: connect from mail-ob0-f173.google.com[209.85.214.173]
Feb 25 15:59:28 srv-correo postfix/smtpd[1212]: setting up TLS connection from mail-ob0-f173.google.com[209.85.214.173]
Feb 25 15:59:28 srv-correo postfix/smtpd[1212]: mail-ob0-f173.google.com[209.85.214.173]: TLS cipher list "aNULL:-aNULL:ALL:+RC4:@STRENGTH:!aNULL:!MD5:!DES"
Feb 25 15:59:28 srv-correo postfix/smtpd[1212]: SSL_accept:before/accept initialization
Feb 25 15:59:28 srv-correo postfix/smtpd[1212]: SSL_accept:SSLv3 read client hello A
Feb 25 15:59:28 srv-correo postfix/smtpd[1212]: SSL_accept:SSLv3 write server hello A
Feb 25 15:59:28 srv-correo postfix/smtpd[1212]: SSL_accept:SSLv3 write certificate A
Feb 25 15:59:28 srv-correo postfix/smtpd[1212]: SSL_accept:SSLv3 write key exchange A
Feb 25 15:59:28 srv-correo postfix/smtpd[1212]: SSL_accept:SSLv3 write server done A
Feb 25 15:59:28 srv-correo postfix/smtpd[1212]: SSL_accept:SSLv3 flush data
Feb 25 15:59:29 srv-correo postfix/smtpd[1212]: SSL3 alert read:fatal:protocol version
Feb 25 15:59:29 srv-correo postfix/smtpd[1212]: SSL_accept:failed in SSLv3 read client certificate A
Feb 25 15:59:29 srv-correo postfix/smtpd[1212]: SSL_accept error from mail-ob0-f173.google.com[209.85.214.173]: 0
Feb 25 15:59:29 srv-correo postfix/smtpd[1212]: warning: TLS library problem: 1212:error:1409442E:SSL routines:SSL3_READ_BYTES:tlsv1 alert protocol version:s3_pkt.c:125
6:SSL alert number 70:
Feb 25 15:59:29 srv-correo postfix/smtpd[1212]: lost connection after STARTTLS from mail-ob0-f173.google.com[209.85.214.173]
Feb 25 15:59:29 srv-correo postfix/smtpd[1212]: disconnect from mail-ob0-f173.google.com[209.85.214.173]


Espero sea de utilidad, si resuelvo el problema lo publico aqui.

Yehiner
Posts: 5
Joined: Fri Feb 20, 2015 10:15 am

Problemas al recibir correos desde gmail

Postby Yehiner » Wed Feb 25, 2015 2:06 pm

Hola Jorge,



Ya había recreado el certificado con documentación que encontré donde indicaban en el upgrade de 8.5.1 a 8.6 había que generar el certificado nuevamente:



/opt/zimbra/bin/zmcertmgr createca -new

/opt/zimbra/bin/zmcertmgr createcrt -new -days 365

/opt/zimbra/bin/zmcertmgr deploycrt self

/opt/zimbra/bin/zmcertmgr deployca

/opt/zimbra/bin/zmcertmgr viewdeployedcrt



Pero no solucionó el problema.
AndresTarallo
Advanced member
Advanced member
Posts: 56
Joined: Fri Sep 12, 2014 11:53 pm
Location: Montevideo, Uruguay
Contact:

Problemas al recibir correos desde gmail

Postby AndresTarallo » Thu Feb 26, 2015 7:29 am

Eso tambien lo hice. Estoy evaluando deshabiltar "starttls" al Posfix del MTA de Zimbra.



Me llama mucho la atencion no ver más gente con este problema.
AndresTarallo
Advanced member
Advanced member
Posts: 56
Joined: Fri Sep 12, 2014 11:53 pm
Location: Montevideo, Uruguay
Contact:

Problemas al recibir correos desde gmail

Postby AndresTarallo » Thu Feb 26, 2015 2:48 pm

Finalmente encontré una solucion, en realidad un paliativo. Forcé a mi servidor a utilizar solo TLSv1 o TLSv1.1.


Para los que corremos Zimbra 8.0.ALGO, esto es lo que ejecute como el usuario zimbra:


postconf -e smtpd_tls_mandatory_protocols='!SSLv2,!SSLv3,!TLSv1.2'


postconf -e smtpd_tls_protocols='!SSLv2,!SSLv3,!TLSv1.2'


Si actualizamos nuestra instalacion estas configuraciones pueden perderse.



Los que ejecutan Zimbra 8.5 o posterior pueden ejecutar:


zmprov mcf zimbraMtaSmtpdTlsProtocols '!SSLv2,!SSLv3,!TLSv1.2'


Esto ultimo lo saque de aqui: http://wiki.zimbra.com/wiki/How_to_disable_SSLv3#ZCS_8.5.x_2

La solucion la obtuve por ensayo y error, inspirado en esta pagina: http://serverfault.com/questions/653664/cant-receive-mails-from-gmail






Yehiner
Posts: 5
Joined: Fri Feb 20, 2015 10:15 am

Problemas al recibir correos desde gmail

Postby Yehiner » Fri Feb 27, 2015 8:42 am

Hola Andres,



Efectivamente, ya realice el cambio en la versión 8.6.0 y funcionó. Empezaron a llegar los correos desde gmail sin problema.



Gracias.

Return to “Spanish”

Who is online

Users browsing this forum: No registered users and 3 guests