Problemas al recibir correos desde gmail

User avatar
jorgedlcruz
Zimbra Alumni
Zimbra Alumni
Posts: 2769
Joined: Thu May 22, 2014 4:47 pm

Problemas al recibir correos desde gmail

Postby jorgedlcruz » Fri Feb 27, 2015 11:50 am

Saludos, por favor pegarme el resultado de postconf |grep tls_security_level para asegurarnos una cosa.



Un saludo


Jorge de la Cruz https://jorgedelacruz.es
Technical Marketing Manager at Zimbra/Synacor https://www.zimbra.com/
Yehiner
Posts: 5
Joined: Fri Feb 20, 2015 10:15 am

Problemas al recibir correos desde gmail

Postby Yehiner » Fri Feb 27, 2015 12:56 pm

Hola Jorge,



El siguiente es el resultado:



lmtp_tls_security_level = may

postscreen_tls_security_level = $smtpd_tls_security_level

smtp_tls_security_level = may

smtpd_tls_security_level = may

tlsproxy_tls_security_level = $smtpd_tls_security_level



Saludos,
User avatar
jorgedlcruz
Zimbra Alumni
Zimbra Alumni
Posts: 2769
Joined: Thu May 22, 2014 4:47 pm

Problemas al recibir correos desde gmail

Postby jorgedlcruz » Fri Feb 27, 2015 1:18 pm

Saludos Yehiner,

Prueba a quitar el !TLSv1.2 simplemente deja '!SSLv2,!SSLv3' que es como viene Zimbra por defecto, lo tengo asi y me funciona perfecto.



Desactivar TLSv1.2 como se hace en los pasos que mencionais, no deberia de afectar o solucionar el error. Ademas que nunca sabes que va a tener el otro servidor si TLSv1.1 o 1.2, o cuando se configura Thunderbird, puede ser que no podais configurar la cuenta con TLS con esto desactivado, yo no lo desactivaria, puede dar problemas en el futuro.



Prueba esto y dime si envias y recibes bien desde gmail:

Zimbra 8.0.x

postconf -e smtpd_tls_mandatory_protocols='!SSLv2,!SSLv3'

postconf -e smtpd_tls_protocols='!SSLv2,!SSLv3'





Zimbra 8.5 o 8.6

zmprov mcf zimbraMtaSmtpdTlsProtocols '!SSLv2,!SSLv3'



Espero vuestro feedback
Jorge de la Cruz https://jorgedelacruz.es
Technical Marketing Manager at Zimbra/Synacor https://www.zimbra.com/
AndresTarallo
Advanced member
Advanced member
Posts: 56
Joined: Fri Sep 12, 2014 11:53 pm
Location: Montevideo, Uruguay
Contact:

Problemas al recibir correos desde gmail

Postby AndresTarallo » Sat Feb 28, 2015 8:53 am

Comenté todo en el foro "administrators", aqui esta el post: http://community.zimbra.com/collaboration/f/1886/t/1138311

Si no excluimos TLSv1.2 sigo sin recibir correos desde GMAIL. Seria util tener llegada con los administradores de gmail, pero al menos para mi eso es prácticamente imposible. Yo llene un formulario y envie porciones relevantes de log. No recibi respuesta, ni fui contactado.

User avatar
jorgedlcruz
Zimbra Alumni
Zimbra Alumni
Posts: 2769
Joined: Thu May 22, 2014 4:47 pm

Problemas al recibir correos desde gmail

Postby jorgedlcruz » Sat Feb 28, 2015 9:52 am

Prueba a dejarlo sin el TLSv1.2 de nuevo y ejecuta en tu server lo siguiente:

/opt/zimbra/bin/zmcertmgr createcrt -new -days 365 -keysize 4096

/opt/zimbra/bin/zmcertmgr deploycrt self

zmcontrol restart



y dinos si ya puedes recibir de GMaiL
Jorge de la Cruz https://jorgedelacruz.es
Technical Marketing Manager at Zimbra/Synacor https://www.zimbra.com/
AndresTarallo
Advanced member
Advanced member
Posts: 56
Joined: Fri Sep 12, 2014 11:53 pm
Location: Montevideo, Uruguay
Contact:

Problemas al recibir correos desde gmail

Postby AndresTarallo » Mon Mar 02, 2015 11:42 am

Hola, como comente en un mensaje previo generar los certificados nuevamente fue una de las primeras acciones que hice. Sin resultados positivos.



Andrés
User avatar
jorgedlcruz
Zimbra Alumni
Zimbra Alumni
Posts: 2769
Joined: Thu May 22, 2014 4:47 pm

Problemas al recibir correos desde gmail

Postby jorgedlcruz » Mon Mar 02, 2015 12:18 pm

Saludos Andres,

Zimbra 8.0.7 genera certificados que ya no son considerados "seguros" por muchas partes, porque no son en 2048 o mas, por eso si pudieras probar otra vez pero con

/opt/zimbra/bin/zmcertmgr createcrt -new -days 365 -keysize 4096



Si tienes tiempo de probar seria magnifico.



Un saludo
Jorge de la Cruz https://jorgedelacruz.es
Technical Marketing Manager at Zimbra/Synacor https://www.zimbra.com/
AndresTarallo
Advanced member
Advanced member
Posts: 56
Joined: Fri Sep 12, 2014 11:53 pm
Location: Montevideo, Uruguay
Contact:

Problemas al recibir correos desde gmail

Postby AndresTarallo » Mon Mar 02, 2015 3:05 pm

Hola:


Como me solicitaste genere el certificado,  habilite nuevamente TLSv1.2 y envie un correo desde gmail.  El correo fue rechazado, va el log:


Mar  2 18:55:44 srv-correo postfix/smtpd[22829]: connect from mail-we0-f182.google.com[74.125.82.182]


Mar  2 18:55:44 srv-correo postfix/smtpd[22829]: setting up TLS connection from mail-we0-f182.google.com[74.125.82.182]


Mar  2 18:55:44 srv-correo postfix/smtpd[22829]: mail-we0-f182.google.com[74.125.82.182]: TLS cipher list "aNULL:-aNULL:ALL:+RC4:@STRENGTH:!aNULL:!MD5:!DES"


Mar  2 18:55:44 srv-correo postfix/smtpd[22829]: SSL_accept:before/accept initialization


Mar  2 18:55:45 srv-correo postfix/smtpd[22829]: SSL_accept:SSLv3 read client hello A


Mar  2 18:55:45 srv-correo postfix/smtpd[22829]: SSL_accept:SSLv3 write server hello A


Mar  2 18:55:45 srv-correo postfix/smtpd[22829]: SSL_accept:SSLv3 write certificate A


Mar  2 18:55:45 srv-correo postfix/smtpd[22829]: SSL_accept:SSLv3 write key exchange A


Mar  2 18:55:45 srv-correo postfix/smtpd[22829]: SSL_accept:SSLv3 write server done A


Mar  2 18:55:45 srv-correo postfix/smtpd[22829]: SSL_accept:SSLv3 flush data


Mar  2 18:55:45 srv-correo postfix/smtpd[22829]: SSL3 alert read:fatal:protocol version


Mar  2 18:55:45 srv-correo postfix/smtpd[22829]: SSL_accept:failed in SSLv3 read client certificate A


Mar  2 18:55:45 srv-correo postfix/smtpd[22829]: SSL_accept error from mail-we0-f182.google.com[74.125.82.182]: 0


Mar  2 18:55:45 srv-correo postfix/smtpd[22829]: warning: TLS library problem: 22829:error:1409442E:SSL routines:SSL3_READ_BYTES:tlsv1 alert protocol version:s3_pkt.c:1


256:SSL alert number 70:


Mar  2 18:55:45 srv-correo postfix/smtpd[22829]: lost connection after STARTTLS from mail-we0-f182.google.com[74.125.82.182]


Mar  2 18:55:45 srv-correo postfix/smtpd[22829]: disconnect from mail-we0-f182.google.com[74.125.82.182]


El error se mantiene. Un detalle: este problema también se da en zimbra 8.6, quien inicio este hilo tiene esa version.

User avatar
jorgedlcruz
Zimbra Alumni
Zimbra Alumni
Posts: 2769
Joined: Thu May 22, 2014 4:47 pm

Problemas al recibir correos desde gmail

Postby jorgedlcruz » Mon Mar 02, 2015 3:32 pm

Me comenta Quanah lo siguiente:

[quanah@edge01 ~]$ grep TLS /var/log/zimbra.log



Generally I see things like:

Mar 2 02:19:15 edge01 postfix/smtpd[6821]: Anonymous TLS connection

established from mail-oi0-f68.google.com[209.85.218.68]: TLSv1.2 with

cipher ECDHE-RSA-AES128-GCM-SHA256 (128/128 bits)



Como ves en el ejemplo, desde google se recibe sin problemas por TLSv1.2, me gustaría que diéramos con el problema real, si no es mucho molestar.



Un saludo
Jorge de la Cruz https://jorgedelacruz.es
Technical Marketing Manager at Zimbra/Synacor https://www.zimbra.com/
AndresTarallo
Advanced member
Advanced member
Posts: 56
Joined: Fri Sep 12, 2014 11:53 pm
Location: Montevideo, Uruguay
Contact:

Problemas al recibir correos desde gmail

Postby AndresTarallo » Tue Mar 03, 2015 6:35 am

Jorge:


Entiendo lo que me dices tu y Quanah. Yo veo que si no excluyo TLSv1.2 los correos que me mandan desde gmail (y dominios alojados allí) no llegan a mi servidor. Como puedes ver en las porciones de logs que he publicado.



Como tu, estoy interesado en encontrar una solución real al problema, no solo un parche que funciona bien. Veo que el problema trasciende a la versión especifica de zimbra que utilizo yo (8.0.7), quien inicio este hilo tiene zimbra 8.6.0.



Aqui te posteo porciones de logs de correos aceptados:


Mar  2 14:38:50 srv-correo postfix/smtpd[11974]: Anonymous TLS connection established from mail-qa0-f53.google.com[209.85.216.53]: TLSv1 with cipher AES128-SHA (128/128 bits)
Mar  2 15:34:58 srv-correo postfix/smtpd[3242]: Anonymous TLS connection established from mail-qa0-f44.google.com[209.85.216.44]: TLSv1.1 with cipher ECDHE-RSA-RC4-SHA (128/128 bits)


Si te fijas un servidor se conecta en TLSv1, el otro en TLSv1.1.


Como dije estoy interesado en encontrar una solucion real, no solo un parche. Como este servidor es de producción no puedo dejar de recibir correos de gmail (o dominios alojados alli). Si quieres contactarme por privado para hacer pruebas mas fluidas hazlo. Y si quieres involucrar a alguien más bienvenido, no tengo problemas de escribir en ingles.



Return to “Spanish”

Who is online

Users browsing this forum: No registered users and 2 guests