Zimbra mobile sync to email suddently not working.

Take your Zimbra with you!
alextsa
Posts: 15
Joined: Fri Sep 12, 2014 10:41 pm

Zimbra mobile sync to email suddently not working.

Postby alextsa » Thu Oct 25, 2007 1:49 pm

Dear all
I am using testing Zimbra 4.5.7 and the mobile sync of email suddently not working but Contacts and Calendar is working fine. I found that old email can be sync and new email after 23 Oct cannot be sync and the error code is 0x80810005. I have try both soft reset and hard reset to the device, but it get same result, so is there any expertise met this error before and how to trouble shooting this problem? Many thanks for your help


jholder
Zimbra Employee
Zimbra Employee
Posts: 4686
Joined: Fri Sep 12, 2014 10:00 pm

Zimbra mobile sync to email suddently not working.

Postby jholder » Thu Oct 25, 2007 1:50 pm

Let's take a look at /opt/zimbra/log/sync.log
alextsa
Posts: 15
Joined: Fri Sep 12, 2014 10:41 pm

Zimbra mobile sync to email suddently not working.

Postby alextsa » Fri Oct 26, 2007 10:00 pm

I have upgraded the system to 4.5.9, but the problem is not fixed, then I try to hard reset my PDA and then I reconfigure my ActiveSync to isolate the problem is related to server or PDA itself. But I cannot sync even the contacts and calendar now. And the error code is 0X80004005 and I find there is a message in sync.log -"2007-10-27 10:36:43,766 INFO [http-80-Processor97] [] sync - HTTP/1.1 401 Unauthorized". Is it related to this error? It's seems to be related my password is incorrect, right? But I have reinput the password and try many accounts and it got same result. The attached are the log during I perform sync. Many thanks for your help.

0x80004005 - syn.log.txt

jholder
Zimbra Employee
Zimbra Employee
Posts: 4686
Joined: Fri Sep 12, 2014 10:00 pm

Zimbra mobile sync to email suddently not working.

Postby jholder » Fri Oct 26, 2007 10:19 pm

[quote][name=alex;mid=5;DeviceId=32792C0F9CC3921EC37F1C39D6A77064;SyncCmd=GetHierarchy;DeviceType=PocketPC;][/quote]

Looks like you're not using a valid login name. Try:

alex@domain.com
alextsa
Posts: 15
Joined: Fri Sep 12, 2014 10:41 pm

Zimbra mobile sync to email suddently not working.

Postby alextsa » Fri Oct 26, 2007 11:29 pm

My username login to the webmail client is alex@technergy.com.hk and I follow the instruction in Wiki of mobile device setup, I configure username as alex and the domain technergy.com.hk in the domain field in my PDA. And this is what I used to configure my PDA, is this correct?
jjzhuang
Elite member
Elite member
Posts: 1687
Joined: Fri Sep 12, 2014 10:24 pm

Zimbra mobile sync to email suddently not working.

Postby jjzhuang » Fri Oct 26, 2007 11:49 pm

The log looks fine. The 401 is standard authentication process. What kind of PDA do you have? Are you sure it has the latest firmware installed? The the log it seems that the PDA doesn't like what the server returned. But the server just returned a list of folders and I can't see anything wrong in there. Thanks!
alextsa
Posts: 15
Joined: Fri Sep 12, 2014 10:41 pm

Zimbra mobile sync to email suddently not working.

Postby alextsa » Fri Nov 02, 2007 5:23 am

I have try other accounts and create a new account, those are working properly and it can be sync successfully. But only my account is not working. I have tried using different service provider and different WM. But it got same result, it seems to be only my account problem. Have any one try this before? Any method to say reset the account?
alextsa
Posts: 15
Joined: Fri Sep 12, 2014 10:41 pm

Zimbra mobile sync to email suddently not working.

Postby alextsa » Thu Nov 15, 2007 11:33 am

I have just hardware reset my HP rw6828 to test the activesync again, and I have try two different GPRS provider and wireless lan also, it got the same result. There are two accounts are not working in the same environment, but other are working. And I discover that if the activesync is not working, the sync will stop after the first 100 email show in the activesync program and only one to two email can sync to the inbox and the error code is 0x80810005. After the Activesync stop, it will start over from the begining, but it will also stop in the same place. But when I try to sync with the normal account with the same provider and same machine, the counter in the activesync can show greater than 100. Anyone try this before?
alextsa
Posts: 15
Joined: Fri Sep 12, 2014 10:41 pm

Zimbra mobile sync to email suddently not working.

Postby alextsa » Sun Nov 18, 2007 10:19 am

I discover that when the account cannot perfrom active sync will have the following error, anyone know them? After this error, the sync process restart, that's why the sync restart after the first 100 messages processed.
2007-11-18 23:43:39,739 ERROR [http-80-Processor97] [name=alex;mid=5;folder=2;DeviceId=32792C0F9CC3921EC37F1C39D6A77064;class=Email;SyncCmd=Sync;DeviceType=PocketPC;] sync - Unexpected exception

ClientAbortException: java.net.SocketException: Connection reset

at org.apache.catalina.connector.OutputBuffer.realWriteBytes(OutputBuffer.java:366)

at org.apache.tomcat.util.buf.ByteChunk.flushBuffer(ByteChunk.java:433)

at org.apache.tomcat.util.buf.ByteChunk.append(ByteChunk.java:348)

at org.apache.catalina.connector.OutputBuffer.writeBytes(OutputBuffer.java:392)

at org.apache.catalina.connector.OutputBuffer.write(OutputBuffer.java:381)

at org.apache.catalina.connector.CoyoteOutputStream.write(CoyoteOutputStream.java:88)

at org.apache.catalina.connector.CoyoteOutputStream.write(CoyoteOutputStream.java:82)

at com.zimbra.zimbrasync.ZimbraSyncServlet.processPostRequest(ZimbraSyncServlet.java:339)

at com.zimbra.zimbrasync.ZimbraSyncServlet.doPost(ZimbraSyncServlet.java:227)

at com.zimbra.zimbrasync.ZimbraSync$HttpHandler.doPost(ZimbraSync.java:31)

at com.zimbra.cs.extension.ExtensionDispatcherServlet.service(ExtensionDispatcherServlet.java:97)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)

at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:252)

at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)

at org.apache.catalina.core.ApplicationDispatcher.invoke(ApplicationDispatcher.java:672)

at org.apache.catalina.core.ApplicationDispatcher.processRequest(ApplicationDispatcher.java:463)

at org.apache.catalina.core.ApplicationDispatcher.doForward(ApplicationDispatcher.java:398)

at org.apache.catalina.core.ApplicationDispatcher.forward(ApplicationDispatcher.java:301)

at com.zimbra.webClient.filters.SetHeaderFilter.doFilter(SetHeaderFilter.java:259)

at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:202)

at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)

at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:213)

at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:178)

at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:126)

at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105)

at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:107)

at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:541)

at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148)

at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:869)

at org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processConnection(Http11BaseProtocol.java:667)

at org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:527)

at org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWorkerThread.java:80)

at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:684)

at java.lang.Thread.run(Thread.java:619)

Caused by: java.net.SocketException: Connection reset

at java.net.SocketOutputStream.socketWrite(SocketOutputStream.java:96)

at java.net.SocketOutputStream.write(SocketOutputStream.java:136)

at org.apache.coyote.http11.InternalOutputBuffer.realWriteBytes(InternalOutputBuffer.java:746)

at org.apache.tomcat.util.buf.ByteChunk.append(ByteChunk.java:353)

at org.apache.coyote.http11.InternalOutputBuffer$OutputStreamOutputBuffer.doWrite(InternalOutputBuffer.java:769)

at org.apache.coyote.http11.filters.IdentityOutputFilter.doWrite(IdentityOutputFilter.java:117)

at org.apache.coyote.http11.InternalOutputBuffer.doWrite(InternalOutputBuffer.java:579)

at org.apache.coyote.Response.doWrite(Response.java:555)

at org.apache.catalina.connector.OutputBuffer.realWriteBytes(OutputBuffer.java:361)

... 33 more
jjzhuang
Elite member
Elite member
Posts: 1687
Joined: Fri Sep 12, 2014 10:24 pm

Zimbra mobile sync to email suddently not working.

Postby jjzhuang » Sun Nov 18, 2007 11:02 pm

What version of software is this? WM5? Please first make sure you have the latest firmware installed. For this kind of specific failure issues, please open a support ticket and provide the complete sync.log. Thanks!

Return to “Mobility”

Who is online

Users browsing this forum: No registered users and 2 guests