Cannot set activesync settings via mobileconfig file

Take your Zimbra with you!
12237Dirk
Outstanding Member
Outstanding Member
Posts: 902
Joined: Fri Sep 12, 2014 10:10 pm

Cannot set activesync settings via mobileconfig file

Postby 12237Dirk » Mon Jul 21, 2008 2:35 am

I've created an xml file using Apple's iPhone Configuration Web Utility. The idea of this is the file can be sent be email or hosted on a webpage and the iphone can pick up the file and the users keys in their email password and the sync is then configured - the user does not need to key in the server address or anything.
I've tested this on multiple devices, with multiple config files and I'm getting sure that there's a problem. I dont have access to a real exchange server to test against though.
When the file is opened and imported, the password prompt appears, and then once keyed in, an error is shown:
"Passcode cannot be set. The Server for account "zimbra" is not responding. This account cannot receive new data until a new passcode is set."
Two options are available, Cancel and Ignore. Cancel takes you back a stage and Ignore crashed the phone completely. Nice.
I have tried this with and without a passcode set on the device. I have tried with and without a passcode being sent in the config file too.
The documentation seems to imply that the passcode for the device will be set by the security settings of the exchange server, so is it possible that the phone is looking for a paramater to be sent to it that the Zimbra server is unaware of?


jjzhuang
Elite member
Elite member
Posts: 1687
Joined: Fri Sep 12, 2014 10:24 pm

Cannot set activesync settings via mobileconfig file

Postby jjzhuang » Mon Jul 21, 2008 3:00 pm

please file a bug. thanks!
12237Dirk
Outstanding Member
Outstanding Member
Posts: 902
Joined: Fri Sep 12, 2014 10:10 pm

Cannot set activesync settings via mobileconfig file

Postby 12237Dirk » Tue Jul 22, 2008 3:49 am

Bug logged at Bug 30146 - Cannot provision activesync 'exchange' account.
This is rather important for those brave souls trying to use iPhone and Zimbra in the enterprise; I trully hope it's an easy fix and wont delay the release of 5.0.9 too much :)
tarunmann
Posts: 2
Joined: Fri Sep 12, 2014 11:39 pm

Cannot set activesync settings via mobileconfig file

Postby tarunmann » Tue Jul 22, 2008 4:30 pm

I came across the same issue today as well. Does getting to this point mean at least my certificate verifications went through ok and its bugged somewhere else?
If I click Ignore it also freezes my phone which forces me to restart.
jjzhuang
Elite member
Elite member
Posts: 1687
Joined: Fri Sep 12, 2014 10:24 pm

Cannot set activesync settings via mobileconfig file

Postby jjzhuang » Tue Jul 22, 2008 4:55 pm

no. we just don't yet support this feature.
tarunmann
Posts: 2
Joined: Fri Sep 12, 2014 11:39 pm

Cannot set activesync settings via mobileconfig file

Postby tarunmann » Tue Jul 22, 2008 5:38 pm

thanks jjzhuang
can you provide any version and/or date information of when this will be supported? if this was stated before i will search the forums. thanks.
12237Dirk
Outstanding Member
Outstanding Member
Posts: 902
Joined: Fri Sep 12, 2014 10:10 pm

Cannot set activesync settings via mobileconfig file

Postby 12237Dirk » Wed Jul 23, 2008 3:03 am

The only think I've seen is that iphones are beta in 5.0.8 and GA in 5.0.9.

There's no way of knowing if this function/fix will be included in .9 though.
klinet
Posts: 19
Joined: Fri Sep 12, 2014 10:38 pm

Cannot set activesync settings via mobileconfig file

Postby klinet » Wed Jan 21, 2009 10:47 am

I am still seeing this behavior in 5.0.11 the sync.log is below.

2009-01-21 10:32:06,264 INFO [btpool0-5918] [] sync - OPTIONS Microsoft-Server-ActiveSync?null

2009-01-21 10:32:06,266 INFO [btpool0-5918] [] sync - HTTP/1.1 200 OK

2009-01-21 10:32:11,983 INFO [btpool0-5914] [] sync - POST Microsoft-Server-ActiveSync?User=klinet&DeviceId=Applxxxxxxxx&DeviceType=iPhone&Cmd=Provision

2009-01-21 10:32:11,985 INFO [btpool0-5914] [name=klinet;mid=7;DeviceId=Applxxxxxxxx;DeviceType=iPhone;SyncCmd=Provision;] sync - Invalid or unsupported command Provision

com.zimbra.zimbrasync.UnsupportedCommandException: Provision

at com.zimbra.zimbrasync.ZimbraSyncServlet.processCommand(ZimbraSyncServlet.java:396)

at com.zimbra.zimbrasync.ZimbraSyncServlet.processPostRequest(ZimbraSyncServlet.java:339)

at com.zimbra.zimbrasync.ZimbraSyncServlet.doPost(ZimbraSyncServlet.java:241)

at com.zimbra.zimbrasync.ZimbraSync$HttpHandler.doPost(ZimbraSync.java:33)

at com.zimbra.cs.extension.ExtensionDispatcherServlet.service(ExtensionDispatcherServlet.java:101)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)

at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:487)

at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1093)

at org.mortbay.servlet.UserAgentFilter.doFilter(UserAgentFilter.java:81)

at org.mortbay.servlet.GzipFilter.doFilter(GzipFilter.java:132)

at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1084)

at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:360)

at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHandler.java:216)

at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:181)

at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:716)

at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.java:406)

at org.mortbay.jetty.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:211)

at org.mortbay.jetty.handler.HandlerCollection.handle(HandlerCollection.java:114)

at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:139)

at org.mortbay.jetty.handler.rewrite.RewriteHandler.handle(RewriteHandler.java:350)

at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:139)

at org.mortbay.jetty.Server.handle(Server.java:313)

at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:506)

at org.mortbay.jetty.HttpConnection$RequestHandler.content(HttpConnection.java:844)

at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:644)

at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:205)

at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:381)

at org.mortbay.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:396)

at org.mortbay.thread.BoundedThreadPool$PoolThread.run(BoundedThreadPool.java:442)

2009-01-21 10:32:11,985 INFO [btpool0-5914] [name=klinet;mid=7;DeviceId=Applxxxxxxxx;DeviceType=iPhone;SyncCmd=Provision;] sync - HTTP/1.1 400 Invalid ZimbraSync command
12237Dirk
Outstanding Member
Outstanding Member
Posts: 902
Joined: Fri Sep 12, 2014 10:10 pm

Cannot set activesync settings via mobileconfig file

Postby 12237Dirk » Thu Jan 22, 2009 4:07 am

As far as I know it's not operational yet and is expected in the next major release (6.0).

Return to “Mobility”

Who is online

Users browsing this forum: No registered users and 2 guests