Google Android and Zimbra

Take your Zimbra with you!
lithorus
Advanced member
Advanced member
Posts: 99
Joined: Fri Sep 12, 2014 11:38 pm

Google Android and Zimbra

Postby lithorus » Tue Sep 15, 2009 7:37 am

[quote user="pmx"]I cant speak for Lithorus, and don't know what rom version he is running, but I can confirm my HTC Hero (nordic ver) mostly works with Zimbra via the ActiveSync profile. When I say mostly I mean everything including address book, calendar and push mail is working -- apart from actually sending mail, which is kindof sucks. The mail get stuck in what seems to be a local folder called "Out" and never gets sent. On the server in sync.log it throws java.io.IOException: Unknown encoding: utf-8

I've tested against both zcs 5.0.18 and 6.0.0[/QUOTE]

You're right. I never got to sending emails on the phone (also nordic version btw.) but stuff like invitations works though, so I assumed that sending email would also.


pmx
Posts: 5
Joined: Fri Sep 12, 2014 11:14 pm

Google Android and Zimbra

Postby pmx » Tue Sep 15, 2009 9:01 pm

Ok, guess we are in the same båt, so to speak.
FYI, the 6.0.1 upgrade did not fix this issue but their support promised us: "Support for the HTC Magic and onwards which use activesync software by HTC is only planned from ZCS 6.0.2."
... let's hope 6.0.1 is not too long-lived :D
While I'm waiting I've setup a second mail profile configured as IMAP (against the same zimbra acc) -- then I just have to remember changing outgoing profile when replying/sending mail. Not pretty, but works..
lithorus
Advanced member
Advanced member
Posts: 99
Joined: Fri Sep 12, 2014 11:38 pm

Google Android and Zimbra

Postby lithorus » Thu Sep 17, 2009 7:23 am

The bug report got resolved with "WORKSFORME"

Bug 38854 – Support for HTC Magic (Running Android OS with ActiveSync support)
Just tested it with the new Hero (Nordic) firmware and still not able to send email.
ylz
Posts: 22
Joined: Fri Sep 12, 2014 11:46 pm

Google Android and Zimbra

Postby ylz » Sat Sep 19, 2009 9:58 am

[quote user="lithorus"]The bug report got resolved with "WORKSFORME"

Bug 38854 – Support for HTC Magic (Running Android OS with ActiveSync support)
Just tested it with the new Hero (Nordic) firmware and still not able to send email.[/QUOTE]
Please be careful. On HTC Magic there was a Firmware Bug, which - according to a friend of mine - had been solved at Firmeware 2.17.401.2. Anyone using a HTC Magic, do the upgrade. Bug 38854 is solved!
On HTC Hero, Activesync worked out of the box, but sending mails fails. pmx, I think you should file a new bug for this issue, since you seem to have the most details about this and according to you, this is not a firmware bug by HTC.
lithorus
Advanced member
Advanced member
Posts: 99
Joined: Fri Sep 12, 2014 11:38 pm

Google Android and Zimbra

Postby lithorus » Sat Sep 19, 2009 10:02 am

[quote user="ylz"]Please be careful. On HTC Magic there was a Firmware Bug, which - according to a friend of mine - had been solved at Firmeware 2.17.401.2. Anyone using a HTC Magic, do the upgrade. Bug 38854 is solved!
On HTC Hero, Activesync worked out of the box, but sending mails fails. pmx, I think you should file a new bug for this issue, since you seem to have the most details about this and according to you, this is not a firmware bug by HTC.[/QUOTE]
You're right. It does seem to be different from the bug already filed. Will see if I can collect logs and file a new one.
Edit:

Submitted now : Bug 41145 – Support for HTC Hero (Running Android OS with ActiveSync support)
ylz
Posts: 22
Joined: Fri Sep 12, 2014 11:46 pm

Google Android and Zimbra

Postby ylz » Sat Sep 19, 2009 1:48 pm

Thank you for filing the bug. I will add more details later on and vote for it. I got the same effect ;)
lithorus
Advanced member
Advanced member
Posts: 99
Joined: Fri Sep 12, 2014 11:38 pm

Google Android and Zimbra

Postby lithorus » Sat Sep 19, 2009 1:54 pm

Seems to be a bug in HTC's mail client. (or just "standard" MS stuff)
utf-8 doesn't seem to be a valid Content-Transfer-Encoding parameter according to the standard.
5. The Content-Transfer-Encoding Header Field
ylz
Posts: 22
Joined: Fri Sep 12, 2014 11:46 pm

Google Android and Zimbra

Postby ylz » Mon Sep 21, 2009 2:19 am

There is another unlucky typo:

[quote]Content-Type: text/plain;

charset= utf-8[/quote]

You realise the space after the equal sign?
But you are right, this bug report belongs to HTC not to Zimbra.
lithorus
Advanced member
Advanced member
Posts: 99
Joined: Fri Sep 12, 2014 11:38 pm

Google Android and Zimbra

Postby lithorus » Mon Sep 21, 2009 2:21 am

However I think it's better that Zimbra contacts HTC. Otherwise they will just say "it works with exchange".
Or make it work with buggy clients.
ylz
Posts: 22
Joined: Fri Sep 12, 2014 11:46 pm

Google Android and Zimbra

Postby ylz » Mon Sep 21, 2009 2:33 am

It really works with egg-changers? I do not have one handy to test.

Return to “Mobility”

Who is online

Users browsing this forum: No registered users and 3 guests