Z-Push Zimbra Backend (Push Email, Contacts, Appointments & Tasks)

Take your Zimbra with you!
liverpoolfcfan
Outstanding Member
Outstanding Member
Posts: 932
Joined: Sat Sep 13, 2014 12:47 am

Z-Push Zimbra Backend (Push Email, Contacts, Appointments & Tasks)

Postby liverpoolfcfan » Mon May 16, 2011 4:07 pm

[quote user="Felipe Nolasco"]Hi,

I'm having a problem to configure the Samsung Galaxy (Android 2.2) using E-mail for Exchange.

Configure the ip address of z-push server, in the logs of apache only show ip address of samsung network.[/QUOTE]
I have used Android 2.2, 2.2.1, and 2.3.3 on a Galaxy S so you should have no problems as far as I am aware.
What email application are you using ? Samsung stock application - or other ?
What did you answer to each question ?
If you are using zimbra self-signed certificates you will need to make sure you check both the options for "Use secure connection (SSL)" AND "Accept all SSL certificates"


swhitman
Posts: 18
Joined: Fri Sep 12, 2014 11:37 pm

Z-Push Zimbra Backend (Push Email, Contacts, Appointments & Tasks)

Postby swhitman » Mon May 16, 2011 6:41 pm

[quote user="liverpoolfcfan"]Not sure what you managed to do - but there are no significant changes for Contacts/Calendar in Release 49 - so just updating to that version should not have caused your problem. [/QUOTE]
I'm not sure, I really wish I turned off google sync only.
[QUOTE]Did you enable SmartFolders at the same time by any chance ? The Release Notes warn very clearly about stopping all sync and resyncing every device if you enable this new option - as folder Id's change under the covers, and every synced item is linked to a containing folder id.[/QUOTE]
I saw the warning. I have not enabled SmartFolders. I find setting up user.xml files works just fine.
[QUOTE]We do recommend (as do z-push for that matter) that you fully re-sync all devices in conjunction with any upgrade. Best practice would always be to stop devices syncing - do the upgrade then - then start devices syncing again.
I have noticed that android does not handle any hierarchy changes as well as WM and Nokia do. It seems to me the only safe way to upgrade android devices is to remove the account from them first. Then add it back after the z-push/backend update.[/QUOTE]
There are 7 users now and thought that it would be a nightmare coordinating. I chose to do the upgrade at 1:00 in the morning, in an attempt to avoid any conflicts. No one else is reporting any trouble yet.
[QUOTE]I am also not sure if it is safe to sync contacts with zimbra and gmail at the same time - maybe someone else knows for sure ??[/QUOTE]
I could not delete the google account, when I tried I was told I would have to reset the device to factory defaults. I have turned off all syncing from google.
[QUOTE]However, all that won't help your current state.
Have you got duplicates on the device only - or on both the device and the server ?[/QUOTE]
The server is fine, it is only the device. Actually only this android device. I can delete and re-enter the account on my Apple iPod and it works fine.
[QUOTE]If your duplicates are only on the phone - then you will likely need to remove your zimbra account from the phone which should drop all zimbra-synced appointments/contacts, then manually clear the remaining ones from the phone, and finally add back the zimbra account.[/QUOTE]
Yep this is what I have been trying. When I remove the account my Contacts and Calendar are empty. Whenever I add the account I get multiple entries in Contacts and Calendar. I have seen up to 10 duplicates and then I just delete the account.
Is there a way to delete only the state information for all devices associated with my account without affecting the other 6 users?
Thanks for all of your help.
P.S. This morning (5/17) someone using AstraSync on a Blackberry reported that the Calendar (only Calendar) is doing something similar.
cafe99
Posts: 3
Joined: Fri Sep 12, 2014 10:31 pm

Z-Push Zimbra Backend (Push Email, Contacts, Appointments & Tasks)

Postby cafe99 » Wed May 18, 2011 2:02 am

Hi,
I having the similar problem with my android mobile phone.
My Setup is very similar to yours, the differenece is z-push is running on Ubuntu 10.04 LTS. Will like to know how you solve the issue.
Thanks for taking the time to read this email and hope you can point out some sugestion to me.
Regards,
Choong Leng from Singapore.
[quote user="lytledd"]Hey guys,
I guess it's my turn to ask for help. But first, my setup:
Phone: Sprint EVO (Android version 2.2)

Zimbra version 7.0 OSE
Ubuntu 8.04LTS 64Bit running under VirtuaBox. The VM has 4GB of memory and 2 CPUs.
My Z-Push/Apache VM is running under Mandriva 2010.2
Z-Push is 1.51 (517)

Zimbrabackend version 48
My z-push.conf looks like:
Alias /Microsoft-Server-ActiveSync /var/www/html/z-push/index.php
My alias file is located in /etc/httpd/conf.d/z-push.conf
My web root is /var/www/html/z-push
Browsing to the active sync link, and typing my username and password, I do get the:
Z-Push - Open Source ActiveSync

Version 1.5.1 (517)

GET not supported
When browing from my phone, I get the same.
My config.php gleaned from this thread is:
define('ZIMBRA_URL', 'https://10.10.10.250');

define('ZIMBRA_USER_DIR', 'zimbra_user');

define('ZIMBRA_SYNC_CONTACT_PICTURES', true);

define('ZIMBRA_VIRTUAL_CONTACTS',true);

define('ZIMBRA_VIRTUAL_APPOINTMENTS',true);

define('ZIMBRA_VIRTUAL_TASKS',true);

define('ZIMBRA_IGNORE_EMAILED_CONTACTS',true);

define('ZIMBRA_HTML',false);

define('ZIMBRA_ENFORCE_VALID_EMAIL',true);
//=== Optional Zimbra Specific Debug Information ===

define('ZIMBRA_DEBUG',true);
All the files are owned by apache.
I'm using HTTPS for z-push and have a port forward on the firewall that send that port over to the z-push VM. Both the Zimbra and z-push VMs are on the same network in the DMZ with no firewall enabled on either
Everything syncs but mail. I've created a test profile, test@pf01.com, when adding to the calendar or contacts, things show up on my EVO, when sending a test message from another account (In Seamonkey), and while viewing the debug.txt, it sees the new mail, but seem to just get into a loop, the phone sits there with the syncing animation, until I tell it to stop. I can send mail from my EVO and everything works, but if I browse to the sent folder, the loop in the debug.txt starts all over again.
I see no errors in the debug.txt,
If I delete the mail from the web portal, things settle down.
Can someone point me in the correct direction?
Thanks![/QUOTE]
swhitman
Posts: 18
Joined: Fri Sep 12, 2014 11:37 pm

Z-Push Zimbra Backend (Push Email, Contacts, Appointments & Tasks)

Postby swhitman » Wed May 18, 2011 9:08 am

[quote user="liverpoolfcfan"]Not sure what you managed to do - but there are no significant changes for Contacts/Calendar in Release 49 - so just updating to that version should not have caused your problem. [/QUOTE]
I figured out what I did wrong. The permissions on the state directory changed so that the apache user could no longer write to the directory. When the z-push distribution is extracted using the tar command the files are owned by userid 33. Not liking this I changed it to root. Of course I totally forgot about the state directory.
liverpoolfcfan
Outstanding Member
Outstanding Member
Posts: 932
Joined: Sat Sep 13, 2014 12:47 am

Z-Push Zimbra Backend (Push Email, Contacts, Appointments & Tasks)

Postby liverpoolfcfan » Wed May 18, 2011 9:10 am

[quote user="swhitman"]I figured out what I did wrong. The permissions on the state directory changed so that the apache user could no longer write to the directory. When the z-push distribution is extracted using the tar command the files are owned by userid 33. Not liking this I changed it to root. Of course I totally forgot about the state directory.[/QUOTE]
Thanks for posting back. It might help someone else in the future.
1739miguel
Advanced member
Advanced member
Posts: 103
Joined: Fri Sep 12, 2014 10:11 pm

Z-Push Zimbra Backend (Push Email, Contacts, Appointments & Tasks)

Postby 1739miguel » Mon May 23, 2011 8:12 am

Hello,
Can you send details on how to get "HTML email when used with a patched install of the as12 branch of z-push" :)
Thanks
liverpoolfcfan
Outstanding Member
Outstanding Member
Posts: 932
Joined: Sat Sep 13, 2014 12:47 am

Z-Push Zimbra Backend (Push Email, Contacts, Appointments & Tasks)

Postby liverpoolfcfan » Tue May 24, 2011 3:02 am

[quote user="1739miguel"]Hello,
Can you send details on how to get "HTML email when used with a patched install of the as12 branch of z-push" :)
Thanks[/QUOTE]
Please send me a pm with details of your setup and the type of phones you use.
liverpoolfcfan
Outstanding Member
Outstanding Member
Posts: 932
Joined: Sat Sep 13, 2014 12:47 am

Z-Push Zimbra Backend (Push Email, Contacts, Appointments & Tasks)

Postby liverpoolfcfan » Tue May 24, 2011 3:07 am

[quote user="cafe99"]Hi,
I having the similar problem with my android mobile phone.
My Setup is very similar to yours, the differenece is z-push is running on Ubuntu 10.04 LTS. Will like to know how you solve the issue.
Thanks for taking the time to read this email and hope you can point out some sugestion to me.
Regards,
Choong Leng from Singapore.[/QUOTE]
Did you see the solution to the original poster's problem - just 3 posts after the one you quoted ?
He gave up on Mandriva and installed CentOS on his z-push install, and everything just worked. I have no idea what the issue was with Mandriva - but it appears to have a more limited (possibly memory limited) httpd/php install.
Having said that - you should also look to see if you have any obvious errors in your debug.txt file or in your httpd log files.
sbourdette
Posts: 5
Joined: Sat Sep 13, 2014 1:56 am

Z-Push Zimbra Backend (Push Email, Contacts, Appointments & Tasks)

Postby sbourdette » Tue May 24, 2011 6:38 am

Hi,
I'm trying to configure z-push and zimbrabackend for 3 days and I don't find any solution.
A little help would be appreciated !
z-push version : 1.5.2

ZimbraBackend version : 49

OS : UBUNTU 8 (Hardy)

Zimbra Version : Release 7.0.0_GA_3077.UBUNTU10_64 UBUNTU10_64 FOSS edition.

Device : IPAD 1
Extract from my config.php :

define('PROVISIONING', false);
// *********************************

// BackendIMAP settings pour zimbra

// *********************************
define('ZIMBRA_URL', 'http://zimbra.mydomain.com');

define('ZIMBRA_USER_DIR', 'zimbra');

define('ZIMBRA_SYNC_CONTACT_PICTURES', true);

define('ZIMBRA_VIRTUAL_CONTACTS',true);

define('ZIMBRA_VIRTUAL_APPOINTMENTS',true);

define('ZIMBRA_VIRTUAL_TASKS',true);

define('ZIMBRA_IGNORE_EMAILED_CONTACTS',true);

define('ZIMBRA_HTML',false);

define('ZIMBRA_DEBUG',true);

define('ZIMBRA_ENFORCE_VALID_EMAIL',true);

Sync begin and find the folders but when syncing each folders, A new Session Id Seems to be created :
05/24/11 13:03:41 [9881] [test@mydomain.com] Session Id changed - OLD [1247] -> NEW []
Find in attachment the debug.txt
Please help me !
Regards

debug.txt

liverpoolfcfan
Outstanding Member
Outstanding Member
Posts: 932
Joined: Sat Sep 13, 2014 12:47 am

Z-Push Zimbra Backend (Push Email, Contacts, Appointments & Tasks)

Postby liverpoolfcfan » Tue May 24, 2011 6:51 am

[quote user="sbourdette"]Hi,
I'm trying to configure z-push and zimbrabackend for 3 days and I don't find any solution.
[/QUOTE]
There is nothing incorrect in that session ID changed line. it is normal for the Logoff command to close the session. There must be more going on ?
Have you correctly configured the 'state' folder

define('STATE_DIR', 'state');

and is it writeable by the web server ?
Have you added the 4 configuration settings to your php.ini or .htaccess file ?
Is there any error message in your web server log file (ssl_error_log by default on apache) ?

Return to “Mobility”

Who is online

Users browsing this forum: No registered users and 1 guest