Z-Push Zimbra Backend (Push Email, Contacts, Appointments & Tasks)

Take your Zimbra with you!
liverpoolfcfan
Outstanding Member
Outstanding Member
Posts: 925
Joined: Sat Sep 13, 2014 12:47 am

Z-Push Zimbra Backend (Push Email, Contacts, Appointments & Tasks)

Postby liverpoolfcfan » Fri Jun 29, 2012 5:34 am

[quote user="marco.davi"]Hi,
I am working with Zimbra, Release 7.1.3_GA_3346.RHEL6_64_20110928134428 CentOSUNKNOWN_64 FOSS edition (from zmcontrol -v), and I am trying to Sync.

I have followed this guide Z-Push (v1 with HTML ActiveSync) for Zimbra FOSS | vBlog but when I try to test if the configuration in working instead of the expected “GET not supported” page I get this page:
...

What should I do to have my z-push working? any advice? thanks in advance![/QUOTE]
I have identified the problem - but do not have time to figure out the correct fix for it right now. Andreas has changed his latest version of file z_RTF.php in the include folder, and it is trying to load a new dependency file ./rtfclass/rtfclass.php. I am not sure if this will work as-is if you just download the dependencies.
A quick fix for the moment is to pull the old version of z_RTF.php from the SVN - it was revision 587 prior to the change that is causing this problem. Here is the link to display it - WebSVN - z-push - Rev 587 - /branches/as12.1/include/z_RTF.php You can either copy/paste the PHP code from this page - or use your favourite SVN tool to pull that revision of the file from the repository.


10424bofh
Outstanding Member
Outstanding Member
Posts: 286
Joined: Sat Sep 13, 2014 1:15 am

Z-Push Zimbra Backend (Push Email, Contacts, Appointments & Tasks)

Postby 10424bofh » Fri Jun 29, 2012 12:26 pm

well i didnt planned to switch to 2.0 soon. iam aware what happens when you rewrite a project :)
anyway doesnt really answer my question about migration but i got goood news

z-push.net • View topic - Trouble with Samsung Galaxy S2 (Android 4.0.3)
last post means migration will be possible without any interaction with the phone FINALLY

jepee
valles
Posts: 8
Joined: Sat Sep 13, 2014 2:39 am

Z-Push Zimbra Backend (Push Email, Contacts, Appointments & Tasks)

Postby valles » Fri Jun 29, 2012 1:03 pm

I have put together a z-push 2.0 (released 2.0-1346) server from scratch under Ubuntu 10.04.4 using a hybrid of zimbra backend rel 53 files, with
zimbra.php rev134,

utils.php rev 119, and

z_RTF.php rev 119
from zimbra backend z-push 2 beta repository. Made a small modification to mime.php for the encodeHeader function as suggested by liverpoolfcfan to the PEAR team. All complete with SSL using commercial cert. So far everything seems working well. Nothing in the z-push error log. Only warnings I have are:
[WARN] /usr/share/z-push/backend/zimbra/utils.php:385 Use of undefined constant MBSTRING_OVERLOAD - assumed 'MBSTRING_OVERLOAD' (8)
and lots of:
[WARN] SyncObject->Check(): object from type SyncMail: parameter 'cc' contains an invalid email address ''. Address is removed.

[WARN] SyncObject->Check(): object from type SyncMail: parameter 'reply_to' contains an invalid email address ''. Address is removed.
I am pretty novice about this. Can the experts comment and help? Thanks.
MadJawa
Posts: 1
Joined: Sat Sep 13, 2014 2:40 am

Z-Push Zimbra Backend (Push Email, Contacts, Appointments & Tasks)

Postby MadJawa » Sat Jun 30, 2012 9:19 am

I'm using too z-push 2.0-1346 and the latest revision of Zimbra Backend beta repository (rev 136) and everything seems to be working well. Except sending mail. I get this in z-push-error.log when I try to send an email:
[QUOTE][FATAL] WBXMLException: Internal Server Error - code: 0

[FATAL] Request could not be processed correctly due to a WBXMLException. Please report this.[/QUOTE]
I tried to change the logging level but I can't get a more detailed error in both log unfortunately.
Is this a known issue?
valles
Posts: 8
Joined: Sat Sep 13, 2014 2:39 am

Z-Push Zimbra Backend (Push Email, Contacts, Appointments & Tasks)

Postby valles » Sat Jun 30, 2012 7:54 pm

I think I was having similar issues until I put in the mime.php and mimePart.php files from release 53.
[quote user="MadJawa"]I'm using too z-push 2.0-1346 and the latest revision of Zimbra Backend beta repository (rev 136) and everything seems to be working well. Except sending mail. I get this in z-push-error.log when I try to send an email:

I tried to change the logging level but I can't get a more detailed error in both log unfortunately.
Is this a known issue?[/QUOTE]
acidrop
Posts: 3
Joined: Sat Sep 13, 2014 2:17 am

Z-Push Zimbra Backend (Push Email, Contacts, Appointments & Tasks)

Postby acidrop » Sat Jul 07, 2012 4:45 am

hello!
I have Zimbra Release 6.0.14_GA_2928.UBUNTU8 UBUNTU8 FOSS edition.

I am trying to setup Z-Push following this guide.

Everything seems to work correctly without errors but when i try to open http://zpush.domain.local/Microsoft-Server-ActiveSync[/url] it prompts me for user/pass and after entering

them I get the following message:

[QUOTE]# Update the following existing config lines date_default_timezone_set("Europe/Athens"); # Or use whatever Unix style time-zone that's appropriate for you define('PROVISIONING', false); $BACKEND_PROVIDER = "BackendZimbra"; # Add the following config lines define('ZIMBRA_DEBUG',true); define('ZIMBRA_URL', 'https://mail.jsmcomputers.biz'); # Update with you Zimbra server hostname define('ZIMBRA_USER_DIR', 'zimbra'); define('ZIMBRA_SYNC_CONTACT_PICTURES', true); define('ZIMBRA_VIRTUAL_CONTACTS',true); define('ZIMBRA_VIRTUAL_APPOINTMENTS',true); define('ZIMBRA_VIRTUAL_TASKS',true); define('ZIMBRA_IGNORE_EMAILED_CONTACTS',true); define('ZIMBRA_HTML',true);

Fatal error: Class name must be a valid object or a string in /var/www/z-push/index.php on line 250[/QUOTE]
Any ideas what's going wrong?
thank you
seruff
Posts: 1
Joined: Sat Sep 13, 2014 2:36 am

Z-Push Zimbra Backend (Push Email, Contacts, Appointments & Tasks)

Postby seruff » Tue Jul 10, 2012 8:38 am

HI!

I have Release 7.2.0_GA_2669.RHEL6_64_20120410002025 CentOS6_64 FOSS edition.

Z-Push version: 1.5.11-1362

Z-Push Zimbra Backend - Release 53
in my iphone does not display messages in inbox folder.
in debug.txt:

START GetMessage { fid = f2; id = 5263; truncsize = 512; bodypreference = ; mimesupport = 0 }

07/10/12 15:37:05 [11112] [test] MEMORY - REAL Now (9,175,040) Peak [9,175,040] - ALLOCATED Now (8,281,432) Peak [8,841,272] - GetMessage START

07/10/12 15:37:05 [11112] [test] START Date4ActiveSync { date = 1341920988000; tz = UTC; adjust4Utc = ; allDay = }

07/10/12 15:37:05 [11112] [test] END Date4ActiveSync { ts = 1341920988 }

07/10/12 15:37:05 [11112] [test] MB_DETECT_ENCODING UNAVAILABLE : SourceEncoding not set in headers - assume UTF-8

07/10/12 15:37:05 [11112] [test] No body preference

07/10/12 15:37:05 [11112] [test] END GetMessage
le_gache
Posts: 10
Joined: Sat Sep 13, 2014 1:18 am

Z-Push Zimbra Backend (Push Email, Contacts, Appointments & Tasks)

Postby le_gache » Wed Jul 11, 2012 3:06 am

Hi,
I have the same issue as seruff with iphones and ZCS 7.2, z-push on CentOS does not push mails to iphones (it works well with android pones) !?
So, i install z-push 1.5.11-1362 and zimbra backend 53 on an ubuntu server 12.04 LTS 64 and my problem is that on iphones the smart folders don't work for calendars. Whereas i create the folders *SyncConfig* and the subfolder appointment&active=true&virtual=false&primary=Calendar, all my calendars shared and owned are synced wiht my iPhone. The problem is that i am notified for each event in each calendar.
Is anyone encountered the same problem ?
Thank you for helping.
Jeremie.
le_gache
Posts: 10
Joined: Sat Sep 13, 2014 1:18 am

Z-Push Zimbra Backend (Push Email, Contacts, Appointments & Tasks)

Postby le_gache » Thu Jul 12, 2012 10:58 am

Hi,
With an acer iconia tab a700 (android 4.0.4), it is impossible to connect via active sync SSL whereas it is possible to connect to the z-push server via
Is">https.
Is
anyone encountered the same problem ?
Thank you for helping.
Jeremie.
liverpoolfcfan
Outstanding Member
Outstanding Member
Posts: 925
Joined: Sat Sep 13, 2014 12:47 am

Z-Push Zimbra Backend (Push Email, Contacts, Appointments & Tasks)

Postby liverpoolfcfan » Sat Jul 14, 2012 2:07 pm

[quote user="seruff"]07/10/12 15:37:05 [11112] [test] MB_DETECT_ENCODING UNAVAILABLE : SourceEncoding not set in headers - assume UTF-8

[/QUOTE]
First suggestion would be to install multibyte String support - you need the php extension php-mbstring
If that fails, then open a support request on the SourceForge site and I will try to help

Return to “Mobility”

Who is online

Users browsing this forum: No registered users and 4 guests