General questions to Zimbra and Z-Push

Take your Zimbra with you!
pauLee
Posts: 12
Joined: Sat Sep 13, 2014 2:28 am

General questions to Zimbra and Z-Push

Postby pauLee » Fri Mar 02, 2012 3:27 pm

Hello,
first of all I want to say that I´am very new to Zimbra and Z-Push.
I run now a Zimbra OS 7 on a Ubuntu 10.04 LTS. Ubuntu was a clean install with DNS and SSH server - nothing more.
I want to install Z-Push for Active Sync. So I found the following guide: Z-Push with Zimbra and HTML Support - vWiki


My problem now: I can´t find any /var/www folder or the apache ... :confused:
What wrong there, did I miss something? I´am really confused about the Zimbra installation regarding the Apache.


phoenix
Ambassador
Ambassador
Posts: 26417
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

General questions to Zimbra and Z-Push

Postby phoenix » Sat Mar 03, 2012 1:31 am

[quote user="pauLee"]My problem now: I can´t find any /var/www folder or the apache ... :confused:
What wrong there, did I miss something? I´am really confused about the Zimbra installation regarding the Apache.[/QUOTE]The 'missing' directory is nothing to do with your Zimbra installation, you are installing additional software and you need to follow the instructions in that wiki article - if you don't already have it then you need Apache or some other web server installed.
Regards

Bill

Rspamd: A high performance spamassassin replacement

If you'd like to see this implemented in a future version of ZCS then please vote on Bugzilla entries 97706 & 108168
pauLee
Posts: 12
Joined: Sat Sep 13, 2014 2:28 am

General questions to Zimbra and Z-Push

Postby pauLee » Sat Mar 03, 2012 2:56 am

Ok, thank you. I didn´t know that I need an additional Apache, so I will install it also.
pauLee
Posts: 12
Joined: Sat Sep 13, 2014 2:28 am

General questions to Zimbra and Z-Push

Postby pauLee » Sat Mar 03, 2012 3:08 am

Ok, Apache is installed but can not start because Zimbra runs on port 80 ... I need to investigate a bit more.
phoenix
Ambassador
Ambassador
Posts: 26417
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

General questions to Zimbra and Z-Push

Postby phoenix » Sat Mar 03, 2012 4:19 am

[quote user="pauLee"]Ok, Apache is installed but can not start because Zimbra runs on port 80 ... I need to investigate a bit more.[/QUOTE]Then change ZCS to use https, see zmtlsctl in the forum and wiki.
Regards

Bill

Rspamd: A high performance spamassassin replacement

If you'd like to see this implemented in a future version of ZCS then please vote on Bugzilla entries 97706 & 108168
liverpoolfcfan
Outstanding Member
Outstanding Member
Posts: 925
Joined: Sat Sep 13, 2014 12:47 am

General questions to Zimbra and Z-Push

Postby liverpoolfcfan » Sun Mar 04, 2012 4:06 am

[quote user="pauLee"]Ok, Apache is installed but can not start because Zimbra runs on port 80 ... I need to investigate a bit more.[/QUOTE]
That's one of the main reasons we typically suggest you run z-push on a separate server.
Running it on a separate server also avoids any issues when performing zimbra upgrades. The z-push instance on it's own server will be left untouched.
aldennis
Advanced member
Advanced member
Posts: 66
Joined: Sat Sep 13, 2014 12:07 am

General questions to Zimbra and Z-Push

Postby aldennis » Tue Aug 07, 2012 10:05 pm

Hi Bill,
Sorry if this is a bit off the topic but the thread says general questions.
Just want to ask does the Z-Push server save all of the user's email and PIM information in its own storage? Because I've created a z-push server on a virtual machine with just 20GB of space and after using it for 2-3 weeks with 7 users it gets full and then it stops working.
We are using Funambol before but it only acts as a mediator between the mobile phone and Zimbra and no messages are kept in its server.
liverpoolfcfan
Outstanding Member
Outstanding Member
Posts: 925
Joined: Sat Sep 13, 2014 12:47 am

General questions to Zimbra and Z-Push

Postby liverpoolfcfan » Wed Aug 08, 2012 2:14 am

Do you have debug logging turned on? There is no log rotation/trimming built in to z-push, so you could be running out of space due to logging. Look for debug.txt in the z-push root folder. Delete the file, and if it gets recreated, change the permissions on it to be read only.
Apart from that, it stores state information locally which should not take up too much space.
aldennis
Advanced member
Advanced member
Posts: 66
Joined: Sat Sep 13, 2014 12:07 am

General questions to Zimbra and Z-Push

Postby aldennis » Wed Aug 22, 2012 12:31 am

[quote user="liverpoolfcfan"]Do you have debug logging turned on? There is no log rotation/trimming built in to z-push, so you could be running out of space due to logging. Look for debug.txt in the z-push root folder. Delete the file, and if it gets recreated, change the permissions on it to be read only.
Apart from that, it stores state information locally which should not take up too much space.[/QUOTE]
Thanks for this, I haven't put attention yet to my offline Z-Push since I've been busy this week. I shall rebuild again my server.
aldennis
Advanced member
Advanced member
Posts: 66
Joined: Sat Sep 13, 2014 12:07 am

General questions to Zimbra and Z-Push

Postby aldennis » Wed Aug 22, 2012 2:20 am

I'm doing the re installation of my z-push but it seems that this link svn://svn.berlios.de/z-push/branches/as12.1 is now dead. I'm using this guide for my installation: Z-Push with Zimbra and HTML Support - vWiki.
Any ideas where to get the as12.1? Thanks

Return to “Mobility”

Who is online

Users browsing this forum: No registered users and 3 guests