Active Sync Problem

Take your Zimbra with you!
tlgsupport
Posts: 2
Joined: Mon May 30, 2016 7:54 am

Active Sync Problem

Postby tlgsupport » Wed Jun 01, 2016 9:22 am

Hi,

I have Zimbra version: Release 8.6.0_GA_1153.RHEL6_64_20141215151258 RHEL6_64 NETWORK edition,
after removing my Iphone 6s and my IPAD from the mobile device list from GUI interface, I cannot reconnect them anymore via ActiveSync.
I get this log:

2016-05-31 14:07:30,029 INFO [qtpXXXXXXXXX-XXXXXX:https://XXX.XXX.XXX.XXX:8443/Microsoft-Server-ActiveSync?User=xx@xxxx.xx&DeviceId=XXXXXXXXXXXXXXXXXXXXXXXXXX&DeviceType=iPhone&Cmd=FolderSync] [name=xx@xxx.xx;mid=29;ip=xxx.xxx.xxx.xxx;DeviceID=XXXXXXXXXXXXXXXXXXXXXXXXXX;Cmd=FolderSync;Version=12.1;] sync - Sync suspended for this device
2016-05-31 14:07:30,029 INFO [qtpXXXXXXXXX-XXXXXX:https://XXX.XXX.XXX.XXX:8443/Microsoft-Server-ActiveSync?User=xx@xxxx.xx&DeviceId=XXXXXXXXXXXXXXXXXXXXXXXXXX&DeviceType=iPhone&Cmd=FolderSync] [name=xx@xxx.xx;mid=29;ip=xxx.xxx.xxx.xxx;DeviceID=XXXXXXXXXXXXXXXXXXXXXXXXXX;Cmd=FolderSync;Version=12.1;] sync - HTTP/1.1 403 Device forbidden

How can I reactivate the Sync? The Sync Button from GUI does not work.

Thanx in advance
Mauro


sandesh.satam
Zimbra Employee
Zimbra Employee
Posts: 1
Joined: Wed Jun 01, 2016 10:08 am

Re: Active Sync Problem

Postby sandesh.satam » Wed Jun 01, 2016 10:13 am

Try this:-

su - zimbra

mysql zimbra

SELECT * FROM mobile_devices WHERE mailbox_id=<id> AND device_id="XXXXXXXXXXXXXXXXXXXXXXXXXX";

Please replace the <id> with actual id.

To get Mailbox Id:

zmprov getMailboxInfo user@domain.com

To fix this case only, please try running this,

update mobile_devices set status=1 where mailbox_id=<id> and device_id="XXXXXXXXXXXXXXXXXXXXXXXXXX";

Let me know if this helps.
tlgsupport
Posts: 2
Joined: Mon May 30, 2016 7:54 am

Re: Active Sync Problem

Postby tlgsupport » Wed Jun 08, 2016 3:34 pm

Hi Sandesh,

thanks for answering, I'll try these commands on Friday 10.
Have I to take some precautions before executing commands from you? it is a production machine.

Thank You
Mauro.
lhatchi971
Posts: 2
Joined: Fri Jul 28, 2017 6:50 pm

Re: Active Sync Problem

Postby lhatchi971 » Fri Jul 28, 2017 7:16 pm

HI ,
I would like to know if @sandesh.satam suggestion is OK.
I think i have the same problem right now.

Can you tell me , if it exists a way to solve that problem using the administrative console ?




lhatchi971,
Zimbra NE 8.6
lhatchi971
Posts: 2
Joined: Fri Jul 28, 2017 6:50 pm

Re: Active Sync Problem

Postby lhatchi971 » Tue Aug 08, 2017 4:26 pm

Hi , the problem was solved for me too , thanks for your instructions @sandesh.satam.
When you add a mobile device with the zimbra server , if one day you have to change your mobile device or use another one . you can delete it from the mobile paramaters in the web client.

On the other hand , If a day you have to add it again , you will have that error message " impossible to connect to server " because the mobile is blocked in the mysql database of zimbra.
So , you can delete it totaly with the command : delete from mobile_devices where='device_id';
you can have the list of device_id of the mailbox you want
with select device_id from mobile_devices where=' mailbox_id';

use the command given by @sandesh.satam to have th mailbox_id :
zmprov getMailboxInfo user@domain.com


lhatchi971
ZIMBRA NE 8.6

Return to “Mobility”

Who is online

Users browsing this forum: No registered users and 5 guests