Zimbrabackend and ZCS 8.7.0 Support

Take your Zimbra with you!
6125amartin
Advanced member
Advanced member
Posts: 57
Joined: Sat Sep 13, 2014 1:45 am

Re: Zimbrabackend and ZCS 8.7.0 Support

Postby 6125amartin » Wed Aug 31, 2016 8:49 pm

After setting zimbraReverseProxyUpstreamReadTimeout=3600s and zimbra_session_limit_soap=10 on my test server, we have not yet been able to reproduce the 502 error (although before hand we could only reproduce it intermittently). It seems like this might be the solution, but hard to say for sure. Is a full "zmcontrol restart" required to apply the change to zimbra_session_limit_soap?


liverpoolfcfan
Outstanding Member
Outstanding Member
Posts: 908
Joined: Sat Sep 13, 2014 12:47 am

Re: Zimbrabackend and ZCS 8.7.0 Support

Postby liverpoolfcfan » Thu Sep 01, 2016 9:24 am

Good news.

On the restart question - I am not sure.

In the bug report they show

Code: Select all

[zimbra@zqa-363 ~]$ zmlocalconfig -e zimbra_session_limit_soap=2
[zimbra@zqa-363 ~]$ zmconfigdctl reload
Stopping zmconfigdctl...success
Stopping zmconfigd...done.
Starting zmconfigd...done.
Starting zmconfigdctl...success


so perhaps you just need to do the zmconfigdctl reload for it to become active.
6125amartin
Advanced member
Advanced member
Posts: 57
Joined: Sat Sep 13, 2014 1:45 am

Re: Zimbrabackend and ZCS 8.7.0 Support

Postby 6125amartin » Thu Sep 01, 2016 3:24 pm

I saw that as well, but even after setting zimbra_session_limit_soap to something absurdly high like 50, I was still seeing occasional "Too many SOAP sessions" - maybe it's impossible to eliminate 100% of them (just reduce the frequency)?

I've been running for a few hours with zimbraReverseProxyUpstreamReadTimeout=3600s and zimbra_session_limit_soap=10 and no 502 errors so far :)
6125amartin
Advanced member
Advanced member
Posts: 57
Joined: Sat Sep 13, 2014 1:45 am

Re: Zimbrabackend and ZCS 8.7.0 Support

Postby 6125amartin » Thu Sep 01, 2016 5:29 pm

I still see some "Too many SOAP sessions" messages in mailbox.log - 5663 total in the last hour, 57 of which are from the WebUI (so most are from z-push). I haven't received any reports of this causing problems, so maybe this frequency of occurrences is not a problem? I could try increasing zimbra_session_limit_soap even more, but a zimbra employee said that more than 15 would be excessive and could hurt performance. Thoughts?
6125amartin
Advanced member
Advanced member
Posts: 57
Joined: Sat Sep 13, 2014 1:45 am

Re: Zimbrabackend and ZCS 8.7.0 Support

Postby 6125amartin » Thu Sep 01, 2016 5:51 pm

I just increased zimbra_sesssion_limit_soap to 50 and am still seeing just as many come in
liverpoolfcfan
Outstanding Member
Outstanding Member
Posts: 908
Joined: Sat Sep 13, 2014 12:47 am

Re: Zimbrabackend and ZCS 8.7.0 Support

Postby liverpoolfcfan » Fri Sep 02, 2016 7:23 am

Are your devices getting to a steady ping state or are they constantly syncing?

You never answered my question on z-push and backend versions. What are you using? And, have you recently upgraded them?

If you go from 2.2.x to 2.3.x you have to run a z-push-admin.php -a fixstates as the state data is incompatible and will cause rapid sync loops.
6125amartin
Advanced member
Advanced member
Posts: 57
Joined: Sat Sep 13, 2014 1:45 am

Re: Zimbrabackend and ZCS 8.7.0 Support

Postby 6125amartin » Tue Sep 06, 2016 1:11 pm

liverpoolfcfan wrote:Are your devices getting to a steady ping state or are they constantly syncing?

I do see a number of devices in the "Ping" state in z-push-top.php, nothing just sitting in a syncing state

You never answered my question on z-push and backend versions. What are you using? And, have you recently upgraded them?

If you go from 2.2.x to 2.3.x you have to run a z-push-admin.php -a fixstates as the state data is incompatible and will cause rapid sync loops.

I did on the previous page, but it probably got lost in all of the text:
Z-Push 2.2.9 and zimbrabackend 64


Good to know about the 2.2.x to 2.3.x upgrade. I see also that you released zimbrabackend 65 very recently. I tend to not upgrade unless I run into performance or stability problems, but if you think an upgrade to 2.3.x and 65 would help, I'll give it a shot
justmoi
Posts: 3
Joined: Tue Aug 09, 2016 8:26 am

Re: Zimbrabackend and ZCS 8.7.0 Support

Postby justmoi » Mon Dec 12, 2016 12:14 pm

FWIW, I encountered this bug (Zimbra->SoapRequest(): SOAP FAULT: HTML Error Returned - Error 429 Too Many Requests - Enable ZIMBRA_DEBUG for more details - returning { false }) with 2.3.3 / backend 46 (fresh install). I have default Zimbra settings IIRC.
Simply running fixstates resolved the issue without touching anything else.
Vincent03
Posts: 1
Joined: Fri Oct 20, 2017 1:57 pm

Re: Zimbrabackend and ZCS 8.7.0 Support

Postby Vincent03 » Fri Oct 20, 2017 2:00 pm

6125amartin wrote:Hello,

I recently upgraded to ZCS 8.7.0 on Ubuntu 14.04. After the upgrade, I'm seeing a lot of errors in /var/log/z-push/z-push-error.log of this format:

Code: Select all

29/08/2016 15:06:52 [ 2889] [ERROR] [user1] Zimbra->SoapRequest(): SOAP FAULT: Error Code Returned [mail.NO_SUCH_WAITSET]
29/08/2016 15:06:52 [ 2889] [ERROR] [user1] Zimbra->SoapRequest(): SOAP FAULT: Error Code Returned [service.PERM_DENIED]
29/08/2016 15:06:52 [ 4700] [ERROR] [user2] Zimbra->SoapRequest(): SOAP FAULT: Error Code Returned [admin.NO_SUCH_WAITSET]
29/08/2016 15:06:52 [ 2889] [ERROR] [user1] Zimbra->SoapRequest(): SOAP FAULT: Error Code Returned [admin.NO_SUCH_WAITSET]
29/08/2016 15:06:52 [ 4469] [ERROR] [user3] Zimbra->SoapRequest(): SOAP FAULT: Error Code Returned [mail.NO_SUCH_WAITSET]
29/08/2016 15:06:52 [ 4860] [ERROR] [user4] Zimbra->SoapRequest(): SOAP FAULT: HTML Error Returned - Error 504 Connection to Upstream is Time Out - Enable ZIMBRA_DEBUG for more details - returning { false }[url=http://www.rachat-de-credit-simulation.com/rachat-de-credit] crédit [/url]
29/08/2016 15:06:52 [ 2889] [ERROR] [user1] Zimbra->SoapRequest(): SOAP FAULT: HTML Error Returned - Error 502 Connection to Upstream is Refused - Enable ZIMBRA_DEBUG for more details - returning { false }
29/08/2016 15:06:52 [ 2889] [ERROR] [user1] Zimbra->SoapRequest(): SOAP FAULT: HTML Error Returned - Error 502 Connection to Upstream is Refused - Enable ZIMBRA_DEBUG for more details - returning { false }


Enabling ZIMBRA_DEBUG doesn't seem to produce any additional output in this log. Syncing mail with mobile clients appears to work fine, but I'm also seeing these 502 errors in the web client as well. Has anyone else tested z-push + zimbrabackend with ZCS 8.7.0?

Huum, it seems complicated :cry:

Return to “Mobility”

Who is online

Users browsing this forum: No registered users and 1 guest