Z-Push access denied

Take your Zimbra with you!
Kordian
Posts: 14
Joined: Wed Oct 24, 2018 5:04 pm

Z-Push access denied

Postby Kordian » Fri Mar 08, 2019 8:10 am

Hi!
I have z-push installed on separate machine.
Recently made some changes to the config in the network, but I do not think it is relevant. After few days all of the sudden z-push stopped working yesterday.
The z-push error log displays:

08/03/2019 06:29:55 [31124] [ERROR] [] Zimbra->Logon(): END Logon - Proxy Error { connected = false }
08/03/2019 06:29:55 [31124] [FATAL] [] Exception: (AuthenticationRequiredException) - Access denied. Proxy unable to initiate a session on user mailbox server

The z-push log:

08/03/2019 06:29:55 [31124] [ERROR] [] Zimbra->Logon(): END Logon - Proxy Error { connected = false }
08/03/2019 06:29:55 [31124] [ INFO] [] AuthenticationRequiredException: Access denied. Proxy unable to initiate a session on user mailbox server - code: 0 - file: /htdocs/z-push/backend/zimbra/zimbra.php:1202

Zimbra works fine when connected by www or desktop. Accounts are not disabled.
Thank you in advance for any help!


Kordian
Posts: 14
Joined: Wed Oct 24, 2018 5:04 pm

Re: Z-Push access denied

Postby Kordian » Fri Mar 08, 2019 9:15 am

Enabled debugging:

08/03/2019 10:00:17 [ 8641] [DEBUG] [user] Zimbra->SoapRequest(): SOAP Message: <soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope">
<soap:Header><context xmlns="urn:zimbra">
<session />
<authToken></authToken>
<notify seq="0" />
<format type="js" />
<userAgent name="Android-SAMSUNG-SM-J330F/101.80000(...86a108) devip=46.88.113.24 ZPZB" version="67" />
</context></soap:Header>
<soap:Body><NoOpRequest xmlns="urn:zimbraMail" /></soap:Body>
</soap:Envelope>
08/03/2019 10:00:17 [ 8641] [DEBUG] [user] Zimbra->SoapRequest(): SOAP response: <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>404 Not Found</title>
</head><body>
<h1>Not Found</h1>
<p>The requested URL /service/soap/ was not found on this server.</p>
<hr>
<address>Apache/2.4.10 (Debian) Server at mail.xxx.xx Port 443</address>
</body></html>

08/03/2019 10:00:17 [ 8641] [DEBUG] [user] NoOpResponse:
08/03/2019 10:00:17 [ 8641] [ERROR] [user] Zimbra->Logon(): END Logon - Proxy Error { connected = false }

Any clue???
Kordian
Posts: 14
Joined: Wed Oct 24, 2018 5:04 pm

Re: Z-Push access denied

Postby Kordian » Fri Mar 08, 2019 10:14 am

ok, solved it myself. Can be deleted.
phoenix
Ambassador
Ambassador
Posts: 26064
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

Re: Z-Push access denied

Postby phoenix » Fri Mar 08, 2019 10:21 am

Kordian wrote:ok, solved it myself. Can be deleted.
How about providing the solution for other forum members who may encounter this problem?
Regards

Bill

Rspamd: A high performance spamassassin replacement

If you'd like to see this implemented in a future version of ZCS then please vote on Bugzilla entries 97706 & 108168

Return to “Mobility”

Who is online

Users browsing this forum: No registered users and 1 guest