autodiscover exchange activesync

Take your Zimbra with you!
sheepei
Posts: 10
Joined: Thu May 04, 2017 9:07 am

autodiscover exchange activesync

Postby sheepei » Mon Apr 01, 2019 9:13 am

I'm trying to get AutoDiscovery working, but it failed to return the autodiscover.xml. I also enable the mobile sync in admin console, failed to sync mail, calendar and contact in phone.

Zimbra Version: Release 8.8.10_GA_3039.RHEL7_64_20180928094617 RHEL7_64 NETWORK edition, Patch 8.8.10_P5.

1. DNS configuration:
autodiscover IN CNAME mail.example.com
_autodiscover._tcp IN SRV 0 0 443 mail.example.com

2. edit /opt/zimbra/jetty/etc/jetty.xml.in

Code: Select all

<Call name="addRule"><Arg><New class="org.eclipse.jetty.rewrite.handler.MsieSslRule"/></Arg></Call>
        <!-- map convenience URLs to the webapp that handles them -->
        <Call name="addRule">
        <Arg>
        <New class="org.eclipse.jetty.rewrite.handler.RewritePatternRule">
            <Set name="pattern">/Microsoft-Server-ActiveSync/*</Set>
            <Set name="replacement">/service/extension/zimbrasync</Set>
        </New>
        </Arg>
        </Call>

<Call name="addRule">
     <Arg>
            <New class="org.eclipse.jetty.rewrite.handler.RewritePatternRule">
                <Set name="pattern">/autodiscover/*</Set>
                <Set name="replacement">/service/extension/autodiscover</Set>
            </New>
     </Arg>
</Call>
<Call name="addRule">
    <Arg>
        <New class="org.eclipse.jetty.rewrite.handler.RewritePatternRule">
            <Set name="pattern">/Autodiscover/*</Set>
            <Set name="replacement">/service/extension/autodiscover</Set>
        </New>
    </Arg>
</Call>
<Call name="addRule">
    <Arg>
        <New class="org.eclipse.jetty.rewrite.handler.RewritePatternRule">
            <Set name="pattern">/AutoDiscover/*</Set>
            <Set name="replacement">/service/extension/autodiscover</Set>
        </New>
    </Arg>
</Call>

        <Call name="addRule">
         <Arg>
           <New class="org.eclipse.jetty.rewrite.handler.RewriteRegexRule">
             <Set name="regex">(?i)/ews/Exchange.asmx/*</Set>
             <Set name="replacement">/service/extension/zimbraews</Set>
           </New>
         </Arg>
        </Call>


3. I used testconnectivity.microsoft.com . It failed to retrieve the XML file.

Code: Select all

The Microsoft Connectivity Analyzer is attempting to retrieve an XML Autodiscover response from URL https://autodiscover.domain.com:443/Autodiscover/Autodiscover.xml for user user5@domain.com
    The Microsoft Connectivity Analyzer failed to obtain an Autodiscover XML response.
   
   Additional Details
    
A Web exception occurred because an HTTP 404 - NotFound response was received from Unknown.
HTTP Response Headers:
Connection: keep-alive
Content-Length: 279
Cache-Control: must-revalidate,no-cache,no-store
Content-Type: text/html;charset=iso-8859-1
Date: Mon, 01 Apr 2019 00:34:49 GMT
Server: nginx
Elapsed Time: 160 ms.


The Microsoft Connectivity Analyzer is attempting to retrieve an XML Autodiscover response from URL https://mail.domain.com:443/Autodiscover/Autodiscover.xml for user user5@domain.com
    The Microsoft Connectivity Analyzer failed to obtain an Autodiscover XML response.
   
   Additional Details
    
A Web exception occurred because an HTTP 404 - NotFound response was received from Unknown.
HTTP Response Headers:
Connection: keep-alive
Content-Length: 279
Cache-Control: must-revalidate,no-cache,no-store
Content-Type: text/html;charset=iso-8859-1
Date: Mon, 01 Apr 2019 00:34:49 GMT
Server: nginx
Elapsed Time: 160 ms.


4. from mailbox.log

Code: Select all

2019-04-01 03:37:09,661 WARN  [qtp1286783232-91924:https:https://ip/Autodiscover/] [] extensions - unable to find handler for extension: system failure: Extension HTTP handler not found at /autodiscover/
2019-04-01 15:04:24,815 WARN  [qtp1286783232-96493:https:https://domain/ews/Exchange.asmx] [] extensions - unable to find handler for extension: system failure: Extension HTTP handler not found at /zimbraews


5. does the server info not required to be filled if autodiscover exchange sync is working? auto configuration for exchange active sync will work?


Return to “Mobility”

Who is online

Users browsing this forum: No registered users and 1 guest