Issue with Meeting unique links [BUG]

Working with Zimbra Talk? This is your Forum, drop here your questions with the Installation, Configuration, etc.
User avatar
edavrio
Posts: 3
Joined: Wed Nov 11, 2020 12:21 am
Location: Moldova
ZCS/ZD Version: 9.0
Contact:

Issue with Meeting unique links [BUG]

Postby edavrio » Wed Nov 11, 2020 12:30 am

We are running some tests with Zimbra 9 and we believe there is a bug related to Connect Meeting links.
Currently our setup is running behind a proxy and we are running HTTPS.
For some reason the Video meeting links generated have 8443 port something like

Code: Select all

https://domain.com:8443/zx/team/instant-meeting/GIZDGMBWHFSDKLJRMFSTELJUHA3GCLLBGU3GMLJWGBTGKNBVG42DQMTEMNAGS2DPON2C43LE


It works both with and without port 8443 but there is no way to change that, so basically you need to keep the port open in Firewall.
There is nothing covered in Wiki about this or in Documentation.
Could somebody make some light in this question?

The output for zmprov gs

Code: Select all

zimbraAdminPort: 7071
zimbraAdminProxyPort: 9071
zimbraImapBindPort: 7143
zimbraImapCleartextLoginEnabled: TRUE
zimbraImapProxyBindPort: 143
zimbraImapSSLBindPort: 7993
zimbraImapSSLProxyBindPort: 993
zimbraMailMode: https
zimbraMailPort: 8080
zimbraMailProxyPort: 80
zimbraMailReferMode: reverse-proxied
zimbraMailSSLPort: 8443
zimbraMailSSLProxyPort: 443
zimbraPop3BindPort: 7110
zimbraPop3CleartextLoginEnabled: TRUE
zimbraPop3ProxyBindPort: 110
zimbraPop3SSLBindPort: 7995
zimbraPop3SSLProxyBindPort: 995
zimbraReverseProxyAdminEnabled: FALSE
zimbraReverseProxyHttpEnabled: TRUE
zimbraReverseProxyLookupTarget: TRUE
zimbraReverseProxyMailEnabled: TRUE
zimbraReverseProxyMailMode: redirect
zimbraReverseProxySSLToUpstreamEnabled: TRUE


User avatar
L. Mark Stone
Elite member
Elite member
Posts: 2200
Joined: Wed Oct 09, 2013 11:35 am
Location: Portland, Maine, US
ZCS/ZD Version: 8.8.15 Network Edition
Contact:

Re: Issue with Meeting unique links [BUG]

Postby L. Mark Stone » Wed Nov 11, 2020 2:13 pm

Welcome to the Forums!

This is not a bug.

You'll just need to set the PublicService* variables on the domain, so that Zimbra's proxy rewrites the URLs to reference the Zimbra or end-user-facing proxy and not use the actual URL the mailbox server (or service, if you have a single unified server) uses.

For example:

Code: Select all

zimbra@mailbox8:~$ zmprov gd missioncriticalemail.com | grep -i publicservice
zimbraPublicServiceHostname: mail.missioncriticalemail.com
zimbraPublicServicePort: 443
zimbraPublicServiceProtocol: https
zimbra@mailbox8:~$


In the above case, I host on AWS and mail.missioncriticalemail.com is an AWS Layer 4 Network Load Balancer.

For background, 443 is the public-facing port the Zimbra proxy uses. 8443 is the port the proxy service uses to communicate with the mailbox service. If you don't set the PublicService* variables, Zimbra uses the actual URL to talk to the mailbox service directly. This is a vestige from the days when it was prohibited to install Zimbra Proxy on a single Zimbra server. In a multi-server environment, the mailbox servers are typically not reachable from the public Internet directly.

Hope that helps,
Mark
___________________________________
L. Mark Stone
Mission Critical Email - Zimbra VAR/BSP/Training Partner https://www.missioncriticalemail.com/
Zeta Alliance http://www.zetalliance.org/
User avatar
edavrio
Posts: 3
Joined: Wed Nov 11, 2020 12:21 am
Location: Moldova
ZCS/ZD Version: 9.0
Contact:

Re: Issue with Meeting unique links [BUG]

Postby edavrio » Tue Nov 17, 2020 12:54 am

Yep. That solved the issue.
Strange this is not covered in the documentation.
Thank you for clarification.

Return to “Zimbra Talk”

Who is online

Users browsing this forum: No registered users and 2 guests