No zimbra talk tab

Working with Zimbra Talk? This is your Forum, drop here your questions with the Installation, Configuration, etc.
mclain
Advanced member
Advanced member
Posts: 123
Joined: Fri Sep 12, 2014 10:41 pm

No zimbra talk tab

Postby mclain » Tue May 03, 2016 5:48 pm

The other post about this did not resolve my issue.

I see zimbra talk under zimlets but no tab.

When i open zimlet I see the following error in FF under developer mode


Handler function NRL_getSecurityInfo threw an exception: TypeError: this.transport is null
Stack: DSC_send@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/server/main.js:1347:5
NEA_addSecurityInfo@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/server/actors/webconsole.js:2029:5
NRL_getSecurityInfo@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/shared/webconsole/n ... r.js:263:5
makeInfallible/<@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/shared/DevToolsUtils.js:87:14
NRL_onStartRequest@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/shared/webconsole/n ... r.js:217:5
Line: 1347, column: 5 DevToolsUtils.js:63:0
TypeError: this.transport is null main.js:1347:5
ReferenceError: MiddlewareAPI is not defined
Zimlets-nodev_all.js.zgz:23940:1
ReferenceError: MiddlewareAPI is not defined
Zimlets-nodev_all.js.zgz:23940:1
ReferenceError: MiddlewareAPI is not defined
Zimlets-nodev_all.js.zgz:23940:1
ReferenceError: MiddlewareAPI is not defined
Zimlets-nodev_all.js.zgz:23940:1
ReferenceError: MiddlewareAPI is not defined
Zimlets-nodev_all.js.zgz:23940:1
ReferenceError: MiddlewareAPI is not defined
Zimlets-nodev_all.js.zgz:23940:1
ReferenceError: MiddlewareAPI is not defined
Zimlets-nodev_all.js.zgz:23940:1
ReferenceError: MiddlewareAPI is not defined

Installation went without issue and I'm not really sure where to look to possibly solve this.

Thanks
Tom


User avatar
Raun
Zimbra Employee
Zimbra Employee
Posts: 75
Joined: Thu Mar 24, 2016 1:22 pm

Re: No zimbra talk tab

Postby Raun » Wed May 04, 2016 5:30 pm

FF is not supported. can you try Chrome and share any errors you get
mclain
Advanced member
Advanced member
Posts: 123
Joined: Fri Sep 12, 2014 10:41 pm

Re: No zimbra talk tab

Postby mclain » Wed May 04, 2016 6:38 pm

Same errors in chrome. Still don't see tab and get same errors.
User avatar
sensor
Posts: 37
Joined: Tue Apr 12, 2016 7:52 am

Re: No zimbra talk tab

Postby sensor » Thu May 05, 2016 2:46 pm

Hi Tom,

"ReferenceError: MiddlewareAPI is not defined" usually means that your client was not able to load middleware_lib.js.

This is done using GET $ZIMBRAURL/service/proxy?target=https%3A%2F%2F$TALKSERVER%2Fmiddleware_lib.js

So - obvious reasons for not loading this libraray might be:
  • the URL to fetch this is generated using a JSP call and uses the settings done in admin UI. check your setting for zimbraZimletJspEnabled - it should be TRUE.
  • domain of your talk server is not added to zimbraProxyAllowedDomains for the COS of your user

In addition: are you running a single server setup? Or do you use several mailbox servers?
anousska
Posts: 11
Joined: Wed Jun 01, 2016 12:34 pm

Re: No zimbra talk tab

Postby anousska » Wed Jun 01, 2016 12:41 pm

Hi,

I have the same problem with Chrome. I see zimbra talk under zimlets but no tab. when I check the error with adm. console of chrome I can see this error:

GET https://mydomain/service/proxy?target=n ... 4782976633 ( 500 server error ).

zimbraZimletJspEnabled is set to true.
And mydoaim is added to zimbraproxyalloweddomains.

If I try to put that address into a web browser i get the same 500 internal server error.

I have a multi-server installation, with serveral mailbox server, one proxy server ( along server ).

If you could give me any help.. I am lost trying to get this Zimbra Talk runn..

thanks.
skflone
Posts: 19
Joined: Mon May 23, 2016 9:48 pm

Re: No zimbra talk tab

Postby skflone » Thu Jun 02, 2016 2:51 pm

Well i was reading into Zimbra that is not support Muli Server installation ,, and also multi domain .
User avatar
jorgedlcruz
Zimbra Alumni
Zimbra Alumni
Posts: 2782
Joined: Thu May 22, 2014 4:47 pm

Re: No zimbra talk tab

Postby jorgedlcruz » Thu Jun 02, 2016 2:57 pm

Hi anousska,
You can see on that URL a null address:

Code: Select all

https://mydomain/service/proxy?target=null%2Fmiddleware_lib.js&_=1464782976633


Which can be an error with the SSL certificate, how have you configured the SSL on Zimbra Talk server?

Best regards
Jorge de la Cruz https://jorgedelacruz.es
Systems Engineer at Veeam Software https://www.veeam.com/
User avatar
sensor
Posts: 37
Joined: Tue Apr 12, 2016 7:52 am

Re: No zimbra talk tab

Postby sensor » Sat Jun 04, 2016 10:02 am

Hi,

anousska wrote:GET https://mydomain/service/proxy?target=n ... 4782976633 ( 500 server error ).


the problem here is that the part "target=null" in your error.
The actual value is fetched before this using a JSP call - so when the value is empty as in your case, the JSP call was not able to return the correct values. Please check in Zimbra Admin UI that the talk configuration is correct (it was displayed at the end of the installation process).

If you put in that configuration, but encounter an error, zimbraZimletJspEnabled is probably not set to TRUE or zimbra was not restarted after adjusting that value).
anousska
Posts: 11
Joined: Wed Jun 01, 2016 12:34 pm

Re: No zimbra talk tab

Postby anousska » Thu Jun 09, 2016 10:02 am

Yes. the configuration of zimbra zimlet ( urls ) was not correct. I solved that, and now the URL is not null. but I get a 404 error. And Zimbra talk tab is not there.


172.18.147.250 - - [09/Jun/2016:08:27:55 +0000] "GET /service/proxy?target=https%3A%2F%2Fxmpp.oficina.euskaltel.com%2Fmiddleware_lib.js&_=1465460927950 HTTP/1.0" 404 297 "https://tablon.oopre.euskaltel.es/" "Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.112 Safari/537.36" 4

in mailbox.log

2016-06-09 11:27:58,053 INFO [qtp509886383-1480:http://172.18.167.37:8080/service/proxy?target=https%3A%2F%2Fxmpp.oopre.euskaltel.es%2Fmiddleware_lib.js&_=1465464530126] [] zimlet - exception while proxying https://xmpp.oopre.euskaltel.es/middleware_lib.js
org.apache.commons.httpclient.ProtocolException: The server xmpp.oopre.euskaltel.es failed to respond with a valid HTTP response
at org.apache.commons.httpclient.HttpMethodBase.readStatusLine(HttpMethodBase.java:1987)
at org.apache.commons.httpclient.HttpMethodBase.readResponse(HttpMethodBase.java:1735)
at org.apache.commons.httpclient.HttpMethodBase.execute(HttpMethodBase.java:1098)
at org.apache.commons.httpclient.ConnectMethod.execute(ConnectMethod.java:185)
at org.apache.commons.httpclient.HttpMethodDirector.executeConnect(HttpMethodDirector.java:496)
at org.apache.commons.httpclient.HttpMethodDirector.executeWithRetry(HttpMethodDirector.java:391)
at org.apache.commons.httpclient.HttpMethodDirector.executeMethod(HttpMethodDirector.java:171)
at org.apache.commons.httpclient.HttpClient.executeMethod(HttpClient.java:397)
at com.zimbra.common.httpclient.HttpClientUtil.executeMethod(HttpClientUtil.java:58)
at com.zimbra.common.httpclient.HttpClientUtil.executeMethod(HttpClientUtil.java:44)
at com.zimbra.cs.zimlet.ProxyServlet.doProxy(ProxyServlet.java:299)
at com.zimbra.cs.zimlet.ProxyServlet.doGet(ProxyServlet.java:161)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:687)
at com.zimbra.cs.servlet.ZimbraServlet.service(ZimbraServlet.java:206)


Zimbra can resolve that domain name ( xmpp.oopre.euskaltel.es ) and I can access with wget, pej:

[root@oo1mbspre webapps]# wget https://xmpp.oopre.euskaltel.es/middleware_lib.js
--2016-06-09 12:00:26-- https://xmpp.oopre.euskaltel.es/middleware_lib.js
Resolving xmpp.oopre.euskaltel.es... 172.18.167.8
Connecting to xmpp.oopre.euskaltel.es|172.18.167.8|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 21327 (21K) [application/javascript]
Saving to: “middleware_lib.js”

100%[==========================================================================================>] 21,327 --.-K/s in 0s

2016-06-09 12:00:26 (353 MB/s) - “middleware_lib.js” saved [21327/21327]



the only doubt reading the instllation document is weahter proxy should be installed in zimbra mailbox server ( we have proxy server in another machine, is a zimbra multi-server instllation ).

Return to “Zimbra Talk”

Who is online

Users browsing this forum: No registered users and 1 guest