Page 1 of 1

Zimbra Talk V2: How to debug WebRTC/TURN?

Posted: Wed Apr 04, 2018 3:34 pm
by msquadrat
Hi folks,

I put this here since I'm afraid that in the still existing Zimbra Talk forum nobody will see the post.

I finally made Zimbra Talk V2 work on two of our test installations. The video chat works fine with people on the same network but breaks as soon as there's some NAT in between.

The solution should be a TURN/STUN server; I installed and configured one (package coturn on Ubuntu) and added it to the ZTalk config as described here: ... URN_server

Unfortunately, people are still not able to communicate through a NAT.

It is definitely possible that I made an error somewhere. When I tried my standard ways of debugging issues like these (staring at log files, the browser's network console and wireshark) it looked to me like the TURN server wasn't used by my client at all but I'm not sure if I even looked at the correct things. So my question: Has anybody debugged videochat/WebRTC/TURN before and can point me into the right direction? Is there maybe a hidden debug mode?


Re: Zimbra Talk V2: How to debug WebRTC/TURN?

Posted: Wed Apr 04, 2018 7:33 pm
by msquadrat
Ok, using the stun command line client and the Trickle ICE testing service I was able to verify that at least my turn server was working as expected.

I use the following turnserver.conf:

Code: Select all


And added a user via

Code: Select all

turnadmin -a -u zimbra -r zimbra.example -p password

The lt-cred-mech option was essential to enable.

Now I'd still like to know how to debug the browser/Zimbra Talk part to make sure it actually uses the TURN server.

Re: Zimbra Talk V2: How to debug WebRTC/TURN?

Posted: Mon Apr 30, 2018 8:21 pm
by cuoz
I'm also trying to get a TURN server working with Talk v2. I also see video working when on the same network. When I test across NAT each party is able to initiate a session, we see our own webcam image, but the connection times out and the window disappears.

I've tried 3 different TURN servers on ubuntu, all the same result. I am currently also using coturn and I believe problem a similar setup to you.

Something on my network which I'm not sure how this affects things... My mailbox server runs in private IP space behind public facing proxy & mta servers. When I initiate a conference, I do see logs in the turn server, which I believe implies the clients are attempting to utilize it.

If you have had any luck since posting, I'd be interested to know what you did to get your environment up & running.


Re: Zimbra Talk V2: How to debug WebRTC/TURN?

Posted: Mon May 07, 2018 8:11 am
by msquadrat
I didn't have any success yet either and still have Case 00712698 on that issue open. I found a few ways of debugging this issue though (which like in your case all point into the direction that everything *should* work but doesn't). I'll update this post when I've got a spare minute.