Zimbra chat Shows Thai language as question marks

All around Zimbra Chat, give us your feedback, questions and ideas
thameera
Posts: 36
Joined: Sat Sep 13, 2014 3:21 am

Zimbra chat Shows Thai language as question marks

Postby thameera » Mon Jun 05, 2017 3:10 am

Hi All,

Recently upgrade the zimbra server to 8.7 with Zimbra Chat Zimlet. Our users use Thai Language to display name. When we add the user to chat it shows correctly. But when log out and login back to the system Users display as "????? ??????". Is there any setting to setup ? How can I make the user name display correctly?

OS: Ubuntu 12.04
Zimbra : 8.7.9
Chat Zimlet : 8.8.0


Thanks,
Thameera


thameera
Posts: 36
Joined: Sat Sep 13, 2014 3:21 am

Re: Zimbra chat Shows Thai language as question marks

Postby thameera » Tue Jun 06, 2017 6:50 am

Found the answer as per another tread in this forum. Issue with Chat DB Schema. Schema creates encoding as "latin1_swedish_ci" instead UTF8. I use below query as mentioned in "https://forums.zimbra.org/viewtopic.php?f=57&t=61767&p=276658#p276658" to change the encoding in the schema. But conversion didn't work for me. I had to remove the user and add again to the Chat. It solve the issue.

Check Default Encoding:-

SELECT DEFAULT_COLLATION_NAME
FROM information_schema.SCHEMATA
WHERE SCHEMA_NAME='chat';


Change Default Encoding :--

ALTER SCHEMA chat
DEFAULT CHARACTER SET 'utf8'
DEFAULT COLLATE 'utf8_general_ci';

Convert Current data to UTF8 :--

USE 'chat';

ALTER TABLE USER
CONVERT TO
CHARACTER SET 'utf8'
COLLATE 'utf8_general_ci';

ALTER TABLE RELATIONSHIP
CONVERT TO
CHARACTER SET 'utf8'
COLLATE 'utf8_general_ci';

ALTER TABLE EVENTMESSAGE
CONVERT TO
CHARACTER SET 'utf8'
COLLATE 'utf8_general_ci';

Return to “Zimbra Chat”

Who is online

Users browsing this forum: No registered users and 1 guest