Emoticons in email body

All around Zimbra Chat, give us your feedback, questions and ideas
7224jobe
Advanced member
Advanced member
Posts: 100
Joined: Sat Sep 13, 2014 1:55 am
ZCS/ZD Version: 8.6.0_GA_1153.RHEL6_64

Emoticons in email body

Postby 7224jobe » Tue Jul 04, 2017 12:36 pm

Hi, we are on Zimbra 8.7.10 with chat enabled,and a few user notified us that they see emoticons in the emails that they receive. Emoticon zimlet is disabled globally, so I examined the webmail with Firefox developer tools and found that those emoticons are from zx_open_chat...I assume that they come from the chat zimlet, that we currently use. In chat options I found that the "enable emoticons in email" is disabled, but they are still showed in the email body. Is there a way to globally disble emoticons for all users?


7224jobe
Advanced member
Advanced member
Posts: 100
Joined: Sat Sep 13, 2014 1:55 am
ZCS/ZD Version: 8.6.0_GA_1153.RHEL6_64

Re: Emoticons in email body

Postby 7224jobe » Tue Jul 04, 2017 3:38 pm

Also tested in a lab environment using the latest 8.7.11 and the problem persists. It looks like that "Display emoticons in all emails" option is ignored, it is always enabled even if the box is not checked.
7224jobe
Advanced member
Advanced member
Posts: 100
Joined: Sat Sep 13, 2014 1:55 am
ZCS/ZD Version: 8.6.0_GA_1153.RHEL6_64

Re: Emoticons in email body

Postby 7224jobe » Mon Jul 10, 2017 1:47 pm

Temporarily solved by editing com_zextras_chat_open zimlet code...

Edited /opt/zimbra/zimlets-deployed/com_zextras_chat_open/com_zextras_chat_open_bundle.js
Changed

Code: Select all

ZmObjectManager_1.ZmObjectManager.registerHandler(ObjectHandler_1.ObjectHandler, null, this._zimletContext.priority);

Into

Code: Select all

ZmObjectManager.registerHandler(this.mObjectHandler, null, this._zimletContext.priority);


Can anyone confirm / address this bug?
User avatar
bud
Posts: 16
Joined: Sat Sep 13, 2014 2:38 am
Location: ZeXtras
Contact:

Re: Emoticons in email body

Postby bud » Wed Jul 19, 2017 3:41 pm

Hello 7224jobe,

7224jobe wrote:Can anyone confirm / address this bug?

Yes I can confirm the existence of the bug, It should be solved in the next release of OpenChat Zimlet.
User avatar
bud
Posts: 16
Joined: Sat Sep 13, 2014 2:38 am
Location: ZeXtras
Contact:

Re: Emoticons in email body

Postby bud » Thu Jul 20, 2017 9:11 am

Hello 7224jobe,

I found the reference of the issue You are describing: https://github.com/ZeXtras/openchat-zim ... f22d53b778 ;)
7224jobe
Advanced member
Advanced member
Posts: 100
Joined: Sat Sep 13, 2014 1:55 am
ZCS/ZD Version: 8.6.0_GA_1153.RHEL6_64

Re: Emoticons in email body

Postby 7224jobe » Thu Jul 20, 2017 9:41 am

Thanks bud for the update. Yes, we solved the bug following that Github excerpt.
Waiting for the next release of the Zimlet ;)

Return to “Zimbra Chat”

Who is online

Users browsing this forum: No registered users and 1 guest