Page 1 of 1

Nextcloud plugin woes

Posted: Tue Apr 04, 2017 4:02 pm
by Gummikavalier
We have trouble with the brand new ZimbraDrive plugin for Nextcloud.
(We followed instructions here: https://wiki.zimbra.com/wiki/Zimbra_Dri ... mbra_Drive)

The plugin does not seem to be able to save its configuration. The configuration under Admin settings turn into blank again if you leave the page.

So I tried to get around the problem by typing the url directly into the PHP code responsible for generating the URL based on those values.

nextcloud/apps/zimbradrive/lib/Auth/OC_User_Zimbra.php:

```php
$this->url = sprintf("https://zebra.csc.fi:443/service/extension/ZimbraDrive_NcUserZimbraBackend");
// "http" . ($this->use_ssl ? "s" : ""),
// $this->zimbra_url,
// $this->zimbra_port
// );
```

This does get us further. However, still when I select 'Drive' tab in the Web client we get this in the Nextcloud logs:

`Error index Doctrine\DBAL\Exception\NotNullConstraintViolationException: An exception occurred while executing 'INSERT INTO `oc_zimbradrive_users` ( `uid`, `display_name` ) VALUES( ?, ? )' with params [null, null]: SQLSTATE[23000]: Integrity constraint violation: 1048 Column 'uid' cannot be null`

So no luck there. Latter one could depend on the first problem saving the settings in the first place. Anyone else in the same boat?

Re: Nextcloud plugin woes

Posted: Wed Apr 05, 2017 7:41 am
by ZS-Man
Hi,
same problem on NextCloud 11.0.2. Configuration is not saved.

Re: Nextcloud plugin woes

Posted: Fri May 12, 2017 5:05 pm
by juliano.morona
Hi, same problem on NextCloud 11.0.3

Re: Nextcloud plugin woes

Posted: Sun May 21, 2017 11:17 am
by justin_hearn
I'm having the same problem, and can't get the zimbra details saved in nextcloud. Has anyone been able to solve this?

Update: Values are in the database now

The file /var/www/nextcloud/apps/zimbradrive/lib/Settings/Admin.php shows these database values:
"zimbra_url" => $this->config->getAppValue('zimbradrive', 'zimbra_url'),
"zimbra_port" => $this->config->getAppValue('zimbradrive', 'zimbra_port'),
"use_ssl" => $this->config->getAppValue('zimbradrive', 'use_ssl', 'true') == 'true',
"trust_invalid_certs" => $this->config->getAppValue('zimbradrive', 'trust_invalid_certs', 'false') == 'true',
"preauth_key" => $this->config->getAppValue('zimbradrive', 'preauth_key'),


Using mysql/phpmyadmin to modify the owncloud\oc_appconfig table (I upgraded owncloud to nextcloud)

Code: Select all

UPDATE `owncloud`.`oc_appconfig` SET `configvalue` = 'localhost' WHERE `oc_appconfig`.`appid` = 'zimbradrive' AND `oc_appconfig`.`configkey` = 'zimbra_url';


Values are remaining in the database now. Previously when I clicked on Drive in Zimbra an error would occur. That doesn't happen now, although I have another problem as nothing happens / no files are displayed.

Re: Nextcloud plugin woes

Posted: Mon Jun 05, 2017 2:12 pm
by budy
I had the same issue on a Mac. Using Chrome did the trick for me.

Cheers,
budy

Re: Nextcloud plugin woes

Posted: Wed Jun 28, 2017 6:43 am
by senyapsudah
Hi Guys,


configure zimbra drive app using chrome solve the issue.

thanks.

Re: Nextcloud plugin woes

Posted: Thu Jul 06, 2017 4:39 pm
by juliano.morona
Solved, with Chrome/Chromium. Thanks.