ZD Extension Incorrect Internal URL Path

All about Zimbra Drive
User avatar
sqb
Posts: 17
Joined: Fri Sep 12, 2014 10:38 pm
Location: Australia
ZCS/ZD Version: ZCS 8.7.11.GA.1854.UBUNTU14.64

ZD Extension Incorrect Internal URL Path

Postby sqb » Mon Jan 22, 2018 2:05 am

We are experiencing the following situation:
ZD successfully navigates nextcloud content structure but fails to upload/download content from our nextcloud server - returning a 404 error.

Investigations show that the internal web client URL path to download extension fails. An example failed URL:

https://zimbra.server.org.au/zimbra/service/extension/ZimbraDrive_Download%2Ftesty%2Fbottlebrush.txt?errorcallback=ZmZimbraDrivePreviewView._errorCallback&previewcallback=ZmZimbraDrivePreviewView._previewCallback&viewonly=1

Note: Our zimbra web clients sessions run from URL https://zimbra.server.org.au/zimbra/ This is a production server and everything besides ZD is fine.

However, the following URL path (dropping the leading /zimbra) successfully finds the extensions and accesses content:

https://zimbra.server.org.au/service/extension/ZimbraDrive_Download%2Ftesty%2Fbottlebrush.txt?errorcallback=ZmZimbraDrivePreviewView._errorCallback&previewcallback=ZmZimbraDrivePreviewView._previewCallback&viewonly=1

Manually rewriting a web client session URL to run from https://zimbra.server.org.au/ (without the /zimbra) allows ZD to upload/download content.

So, my question is: How do I correct the internal ZD extension path URL?


User avatar
sqb
Posts: 17
Joined: Fri Sep 12, 2014 10:38 pm
Location: Australia
ZCS/ZD Version: ZCS 8.7.11.GA.1854.UBUNTU14.64

Re: ZD Extension Incorrect Internal URL Path

Postby sqb » Mon Jan 22, 2018 2:58 am

Remiss of me - versions:

NC: 12.0.4
NC: Zimbra Drive: 0.8.18

Zimbra zcs-8.7.11
zimbra-drive: 1.0.10+1504081761-1.u14
markwb
Posts: 1
Joined: Thu Jan 25, 2018 2:03 am

Re: ZD Extension Incorrect Internal URL Path

Postby markwb » Thu Jan 25, 2018 2:16 am

Hey!

I have a similar problem... but a little different. I have an Apache Reverse Proxy sitting in front of my Zimbra installation. This reverse proxy is the head-end to all of my http/https traffic. It directs traffic to individual servers internally based on the hostname in the URL.

So:

When I attempt to preview a file that is in my Zimbra Drive while the traffic is flowing through the Apache Reverse Proxy the URL is:
https://mail.domain/service/extension/Z ... viewonly=1

This fails to show anything in the preview window

Previewing a file without using the Apache Reverse Proxy works fine, the URL is:
https://mail.domain/service/extension/Z ... viewonly=1

Everything else with Zimbra appears to be working perfectly... I was thinking of writing a mod_rewrite rule to take care of it... but it would be better if the source of the problem could be fixed instead of putting a bandaid solution on it. I'm not sure what is causing the two URLs to be different.

Return to “Zimbra Drive”

Who is online

Users browsing this forum: No registered users and 2 guests