Page 1 of 2

Chrome + right click

Posted: Wed Oct 01, 2014 10:05 am
by mbert

Generally when searching forums I like to open relevant threads in new tabs as I go through them.  In the new forum, right clicking a subject using chrome causes the browser to load that page, forcing you to hit the back button to go back to the list of topics.


IE and Firefox work correctly.


Chrome + right click

Posted: Wed Oct 01, 2014 10:32 am
by rhoward
[mention:d15178534e2244b09b019ac502660ca1:e9ed411860ed4f2ba0265705b8793d05] I'm using Chrome too and do the same thing. When I'm here (http://community.zimbra.com/collaboration/f/1886) and I right-click on a thread and select "Open Link in new tab" I'm getting the expected behavior. Mind sharing more details on what you are seeing / expecting?

Chrome + right click

Posted: Wed Oct 01, 2014 10:47 am
by mbert
When I right click, the context menu appears as expected and I can select open in new tab, however the current page seems to treat the right click as a left click as well for some reason. I have tried on other sites, and they operate correctly....

Chrome + right click

Posted: Wed Oct 01, 2014 10:57 am
by mbert
I've tried it in icognito mode with all extensions disabled and still getting the incorrect behaviour. Chrome version is 37.0.2062.124 m

Chrome + right click

Posted: Wed Oct 01, 2014 11:00 am
by rhoward
Hmmm... ok, we're using the same version of Chrome. What OS are you using? I'm on OSX. Are you seeing the behavior on this page (just so I ensure we're working against the same set of links):

http://community.zimbra.com/collaboration/f/1886

Chrome + right click

Posted: Wed Oct 01, 2014 12:06 pm
by mbert
Yes, I was testing on the same page. Issue is appearing on my Windows 7 laptop. Just tried on my Windows 8 desktop and it is working correctly - same version of chrome. So seems to be something specific to my laptop configuration...

Chrome + right click

Posted: Wed Oct 01, 2014 1:20 pm
by rhoward
Ok, I've got a Windows 7 vm that I'll spin up and check this out too.

Chrome + right click

Posted: Wed Oct 01, 2014 3:44 pm
by rhoward
Hi [mention:d15178534e2244b09b019ac502660ca1:e9ed411860ed4f2ba0265705b8793d05],



I just used a Windows 7 VM with the latest version of Google Chrome and I could not replicate this.

Chrome + right click

Posted: Wed Oct 22, 2014 10:08 am
by cberg@createdigital.com
I'm getting this as well, on a clean Zimbra Community install, as well as your documentation site. Using Chrome 38.0.2125.104 m on Windows 7 professional x64.

Chrome + right click

Posted: Wed Oct 22, 2014 10:21 am
by afscrome
So this is being caused by a bug in Chrome which is causing it to incorrectly report certain Windows 7 configurations as touch devices - https://code.google.com/p/chromium/issues/detail?id=352942 . This has been fixed in the Chrome's canary builds, and should be included in the next version of Chrome.