How to force text/code formatting and turn off post autoformatting?

Whether you are a current user, former user, a Zimbra employee, or anyone with experience using any of our products, we welcome your feedback. Please include a specific product name and version when relevant.
User avatar
jorgedlcruz
Zimbra Alumni
Zimbra Alumni
Posts: 2769
Joined: Thu May 22, 2014 4:47 pm

How to force text/code formatting and turn off post autoformatting?

Postby jorgedlcruz » Thu Jan 22, 2015 8:58 am

Hi RogerTennet,

Are you using the Rich formatting? And if so, are you marking the code with the code tool in the TinyMCE, or using the HTML function in the TinyMCE if you want to write some extra HTML?



Please let us know how are you writing the post, and what is the problem after you posted.



Best regards


Jorge de la Cruz https://jorgedelacruz.es
Technical Marketing Manager at Zimbra/Synacor https://www.zimbra.com/
User avatar
Gren Elliot
Zimbra Employee
Zimbra Employee
Posts: 183
Joined: Tue Jun 10, 2014 4:45 am

How to force text/code formatting and turn off post autoformatting?

Postby Gren Elliot » Thu Jan 22, 2015 8:59 am

You may not like this answer very much but if you are happy writing raw HTML, I have taken to using the rich formatting "html" option for my posts. Seems to have worked for me so far. Mostly using "p" and "pre" elements - the latter being good for leaving stuff alone.
RogerTennet
Advanced member
Advanced member
Posts: 50
Joined: Mon Dec 01, 2014 9:16 am

How to force text/code formatting and turn off post autoformatting?

Postby RogerTennet » Thu Jan 22, 2015 9:17 am

Hi. I *did* wrap my message in <pre></pre> for exactly the reason you suggest. It's STILL munging what's inside the pre-tags.
RogerTennet
Advanced member
Advanced member
Posts: 50
Joined: Mon Dec 01, 2014 9:16 am

How to force text/code formatting and turn off post autoformatting?

Postby RogerTennet » Thu Jan 22, 2015 9:42 am

There is NO 'Rich formatting' option presented when you create a New post. Only if you REPLY to an existing post (like I am to you right now). In any case In the new post I add the <pre> & </pre> tags like I said above. If I do that It leaves SOME stuff alone and deletes other content. I am simply writing the post in a plain text editor on my desktop, with the tags, and copying and pasting the whole message into the Zimbra forum post. The 'problem after I post' is clearly shown at the link I provided, https://community.zimbra.com/collaboration/f/1886/t/1137609.
User avatar
jorgedlcruz
Zimbra Alumni
Zimbra Alumni
Posts: 2769
Joined: Thu May 22, 2014 4:47 pm

How to force text/code formatting and turn off post autoformatting?

Postby jorgedlcruz » Thu Jan 22, 2015 11:20 am

Hi RogerTennet,

Your feedback is always really welcome, let me ask you something, are you using the text area called Ask a question, or are you using the blue button called new, and the write your question?



Best regards
Jorge de la Cruz https://jorgedelacruz.es
Technical Marketing Manager at Zimbra/Synacor https://www.zimbra.com/
RogerTennet
Advanced member
Advanced member
Posts: 50
Joined: Mon Dec 01, 2014 9:16 am

How to force text/code formatting and turn off post autoformatting?

Postby RogerTennet » Thu Jan 22, 2015 11:39 am

I'm using 'New'. Here's the entry screen: http://snag.gy/KAGeO.jpg
User avatar
jorgedlcruz
Zimbra Alumni
Zimbra Alumni
Posts: 2769
Joined: Thu May 22, 2014 4:47 pm

How to force text/code formatting and turn off post autoformatting?

Postby jorgedlcruz » Thu Jan 22, 2015 11:46 am

Hi Roger,


Thank  you for your feedback, can you go to Settings and change to have the Enhanced Editor by default?




Then you new posts will contain the Enhanced editor, and you can write code, add some images, etc. Only if you want. Try and let us know.


Best regards

Jorge de la Cruz https://jorgedelacruz.es
Technical Marketing Manager at Zimbra/Synacor https://www.zimbra.com/

Return to “General Zimbra Feedback”

Who is online

Users browsing this forum: No registered users and 1 guest