Upgrade from 8.6 to 8.7 issues

Whether you are a current user, former user, a Zimbra employee, or anyone with experience using any of our products, we welcome your feedback. Please include a specific product name and version when relevant.
verticon
Posts: 16
Joined: Sat Sep 13, 2014 3:30 am
Location: Toronto

Upgrade from 8.6 to 8.7 issues

Postby verticon » Thu Oct 13, 2016 4:15 pm

The company I work for supports 4 Zimbra mail servers (1 open source and 3 network) and each one of them has been a painful upgrade to the 8.7 version. They are currently running Ubuntu 14.04 which is patched prior to upgrade.

The problem is the upgrade fails during the package installation from the Zimbra Repositories I get the following errors during upgrade:

Unpacking zimbra-spamassassin-rules (1.0.0-1zimbra8.7b1.14.04) ...
dpkg: error processing archive /var/cache/apt/archives/zimbra-spamassassin-rules_1.0.0-1zimbra8.7b1.14.04_all.deb (--unpack):
trying to overwrite '/opt/zimbra/data/spamassassin/rules/72_active.cf', which is also in package zimbra-mta 8.6.0.GA.1153.UBUNTU14.64
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)

Unpacking zimbra-perl-mail-spamassassin (3.4.1-1zimbra8.7b1.14.04) ...
dpkg: error processing archive /var/cache/apt/archives/zimbra-perl-mail-spamassassin_3.4.1-1zimbra8.7b1.14.04_all.deb (--unpack):
trying to overwrite '/opt/zimbra/data/spamassassin/localrules/v340.pre', which is also in package zimbra-mta 8.6.0.GA.1153.UBUNTU14.64
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)

Unpacking zimbra-osl (1.0.9-1zimbra8.7b1.14.04) ...
dpkg: error processing archive /var/cache/apt/archives/zimbra-osl_1.0.9-1zimbra8.7b1.14.04_all.deb (--unpack):
trying to overwrite '/opt/zimbra/docs/open_source_licenses.txt', which is also in package zimbra-core 8.6.0.GA.1153.UBUNTU14.64
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)


I cannot recover from this error because any attempt to re-run the installation if you fix these issues, LDAP is not running because all packages get uninstalled, and during the installation of the new packages, the system breaks. My upgrade strategy now is to export all the mailboxes and then import them into a new system.


Olivier
Posts: 1
Joined: Sat Oct 15, 2016 12:05 am

Re: Upgrade from 8.6 to 8.7 issues

Postby Olivier » Sat Oct 15, 2016 12:10 am

I got the exact same issue. Anyway to make this work?
User avatar
Gren Elliot
Zimbra Employee
Zimbra Employee
Posts: 183
Joined: Tue Jun 10, 2014 4:45 am

Re: Upgrade from 8.6 to 8.7 issues

Postby Gren Elliot » Mon Oct 24, 2016 11:33 am

It looks like a bug has been raised for this - see https://bugzilla.zimbra.com/show_bug.cgi?id=106907
It doesn't look like that has been addressed yet though. Suggest you vote for it to increase its visibility.
User avatar
maxxer
Advanced member
Advanced member
Posts: 82
Joined: Fri Oct 04, 2013 2:12 am
Contact:

Re: Upgrade from 8.6 to 8.7 issues

Postby maxxer » Tue Jan 16, 2018 6:09 pm

I just had the very same issue when upgrading 8.6UBUNTU14 to 8.8.5!

Code: Select all

dpkg: error processing archive /var/cache/apt/archives/zimbra-osl_1.0.9-1zimbra8.7b1.14.04_all.deb (--unpack):
 trying to overwrite '/opt/zimbra/docs/open_source_licenses.txt', which is also in package zimbra-core 8.6.0.GA.1153.UBUNTU14.64

 dpkg: error processing archive /var/cache/apt/archives/zimbra-perl-mail-spamassassin_3.4.1-1zimbra8.7b2.14.04_all.deb (--unpack):
 trying to overwrite '/opt/zimbra/data/spamassassin/localrules/v340.pre', which is also in package zimbra-mta 8.6.0.GA.1153.UBUNTU14.64dpkg:

 error processing archive /var/cache/apt/archives/zimbra-spamassassin-rules_1.0.0-1zimbra8.7b1.14.04_all.deb (--unpack):
 trying to overwrite '/opt/zimbra/data/spamassassin/rules/72_active.cf', which is also in package zimbra-mta 8.6.0.GA.1153.UBUNTU14.64


The bug is closed, but apparently happening again!

Return to “General Zimbra Feedback”

Who is online

Users browsing this forum: No registered users and 2 guests