Page 2 of 3

The DNSBL AHBL (Abusive Hosts Blocking Lists) is no longer offer their service.

Posted: Thu Jan 08, 2015 10:16 am
by chertel
Then it does not seem to work, neither on the FOSS nor on the NETWORK editions (at least of Zimbra 8.0.7).

The DNSBL AHBL (Abusive Hosts Blocking Lists) is no longer offer their service.

Posted: Thu Jan 08, 2015 10:17 am
by chertel
Done, nothing happened:



~$ /opt/zimbra/libexec/zmsaupdate



zimbra~$ more /opt/zimbra/conf/spamassassin/50_scores.cf | grep AHBL

score DNS_FROM_AHBL_RHSBL 0 2.438 0 2.699 # n=0 n=2

The DNSBL AHBL (Abusive Hosts Blocking Lists) is no longer offer their service.

Posted: Thu Jan 08, 2015 10:38 am
by jorgedlcruz
I've changed the announcement, thank you for your info.

The DNSBL AHBL (Abusive Hosts Blocking Lists) is no longer offer their service.

Posted: Thu Jan 08, 2015 11:42 am
by chertel
Got it, the updates are not in /opt/zimbra/conf/spamassassin/50_scores.cf but in /opt/zimbra/conf/spamassassin/updates_spamassassin_org/50_scores.cf on our server:



./updates_spamassassin_org/50_scores.cf:# AHBL is closing down. disabling early. (Axb-2014-03-28)

./updates_spamassassin_org/50_scores.cf:#score DNS_FROM_AHBL_RHSBL 0 2.438 0 2.699 # n=0 n=2

The DNSBL AHBL (Abusive Hosts Blocking Lists) is no longer offer their service.

Posted: Thu Jan 08, 2015 11:55 am
by jorgedlcruz
Hi chertel,

So with an autoupdate is enough and AHBL is marked like commented.



Really great to know.



Best regards

The DNSBL AHBL (Abusive Hosts Blocking Lists) is no longer offer their service.

Posted: Thu Jan 08, 2015 11:58 am
by chertel

Yes. As long as autoupdate has been manually enabled (as it seems to be disabled by default, according to http://wiki.zimbra.com/wiki/SpamAssassin_Customizations#Automatic_rule_updates)


So just for completion:

AHBL will be automatically disabled by automatic rule updating (available since Zimbra 8.0.5) if automatic rule updating has been manually enabled by issuing the following commands as the Zimbra user:


zmlocalconfig -e antispam_enable_rule_updates=true
zmlocalconfig -e antispam_enable_restarts=true
zmamavisdctl restart
zmmtactl restart (on our servers, "restart" failed with postfix, so I used "reload" instead)
zmsaupdate


Correct? :)

So far, thank you very much for your help!


Best regards,
Christian Hertel


The DNSBL AHBL (Abusive Hosts Blocking Lists) is no longer offer their service.

Posted: Fri Jan 09, 2015 1:58 am
by ploeger
[mention:8081d13fd51d42c888a04ad0bba5f6a6:e9ed411860ed4f2ba0265705b8793d05] Please note, that from 8.5 on the spamassassin configuration moved (as noted here: http://wiki.zimbra.com/wiki/SpamAssassin_Customizations#ZCS_8.5_and_later), so your command should be



more /opt/zimbra/data/spamassassin/rules/50_scores.cf | grep AHBL

The DNSBL AHBL (Abusive Hosts Blocking Lists) is no longer offer their service.

Posted: Fri Jan 09, 2015 2:04 am
by jorgedlcruz
Good morning Dennis,

Good point, fixed.



Thank you



Best regards

The DNSBL AHBL (Abusive Hosts Blocking Lists) is no longer offer their service.

Posted: Wed Jan 14, 2015 3:10 pm
by tonster
There was a bug before 8.0.7 where it wasn't running properly, however that bug was fixed in 8.0.7 (bug 85462) so I would expect this to be working properly for 8.0.7 and later.

The DNSBL AHBL (Abusive Hosts Blocking Lists) is no longer offer their service.

Posted: Wed Jan 14, 2015 11:23 pm
by jorgedlcruz

Hi team and update,


If you have 8.0.6 or previous, we have a bug and you need to take a look here - https://bugzilla.zimbra.com/show_bug.cgi?id=85462


Best regards