Page 2 of 3

Re: Zimbra Collaboration 8.7.x and Ubuntu OS update corrupts/removes Zimbra installation

Posted: Tue Jan 31, 2017 7:59 am
by joebitcoinorg
OK. I got my server taken care of.
I feel that the most useful steps were:

making sure zimbra is off
renameing /opt/zimbra to /opt/zimbra-14lts
apt remove zimbra*
./install.sh -u

I know that it was recommended above that a full install wasn't necessary at this point (only ./install -s) but I did a full install anyway.
stop zimbra
move /opt/zimbra to /opt/zimbra-fresh
move /opt/zimbra-14lts /opt/zimbra

start zimbra

I may actually still need to move the new binaries into place but it seems to be working.

one of the problems I had when trying to remove zimbra by doing apt remove zimbra* was that it kept saying it couldn't find zimbramon. However the ./install.sh -u fixed that problem for me.

Thanks for the great email software!

Regards,
Joe Baker aka joebitcoinorg

Re: Zimbra Collaboration 8.7.x and Ubuntu OS update corrupts/removes Zimbra installation

Posted: Thu Feb 02, 2017 9:50 am
by alessandro.motta
Hi all,
does the new ZCS 8.7.2 fix this issue?

Best regards

Re: Zimbra Collaboration 8.7.x and Ubuntu OS update corrupts/removes Zimbra installation

Posted: Thu Feb 02, 2017 10:01 am
by jorgedlcruz
Hi Alexandro,
No, 8.7.2 doesn't have anything related to this fix yet.

We are still investigating

Best regards

Re: Zimbra Collaboration 8.7.x and Ubuntu OS update corrupts/removes Zimbra installation

Posted: Wed Feb 08, 2017 1:07 am
by davidkillingsworth
I have a side question. We have a few Ubuntu 14.04.5 LTS servers with Zimbra 8.6 (Release 8.6.0.GA.1153.UBUNTU14.64 UBUNTU14_64 FOSS edition, Patch 8.6.0_P6.)

I'm wondering if it is recommended to upgrade Ubuntu first and then Zimbra to 8.7, or if it is recommended to upgrade zimbra to 8.7 and stay on Ubuntu 14.04 for now?

Please advise.

Thanks,
David

Re: Zimbra Collaboration 8.7.x and Ubuntu OS update corrupts/removes Zimbra installation

Posted: Sun Feb 12, 2017 8:22 pm
by Martinwiertz
Hè Guys,

Any progress on this issue? After upgrading to 8.7.2 on Ubuntu14.045lts I saw this issue. Currently I don't patch Ubuntu and Zimbra because it might harm my configuration.

Please advice what to do. I think waiting is the only option does it not affect my install 8.7.2 on 14.04?

Re: Zimbra Collaboration 8.7.x and Ubuntu OS update corrupts/removes Zimbra installation

Posted: Fri Feb 24, 2017 9:40 am
by laurens
and hows all for the 8.7.3? I seems to run all okay on my local TEST servers when i go like described here viewtopic.php?p=274575#p274575

Re: Zimbra Collaboration 8.7.x and Ubuntu OS update corrupts/removes Zimbra installation

Posted: Fri Mar 10, 2017 2:19 am
by bhwong
This has been resolved with Zimbra 8.7.4?

Re: Zimbra Collaboration 8.7.x and Ubuntu OS update corrupts/removes Zimbra installation

Posted: Tue Apr 04, 2017 7:36 am
by racerock
No still not fixed in 8.75 ...
we are now up to 8.76 although no specific mention in release notes under FIXED ISSUES in 8.7.4,5 or 6
https://wiki.zimbra.com/wiki/Zimbra_Rel ... .7.4#fixed
https://wiki.zimbra.com/wiki/Zimbra_Rel ... .7.5#fixed
Note no actual section of fixed for 8.7.6

I really don't know where they are going with this one in the past we have found a way but sadly any of the fixes I have found don't work for me ...I have recovered my virtual so many times ....... I have narrowed it down to(I think) to LDAP getting broken but .... Still waiting

I am like a lot of others all my servers are on Ubuntu 14.04 having already upgraded to a zcs 8.7.1 > version (So we are trying the migration with a version of zZmbra that has an installer of the same version under 16.04 version of Ubuntu)
When I upgrade the ubuntu to 16.04 then re run the "upgrade" using the 16.04 version of the same installer ....I can try all manner of "documented fixes" here on this forum I have varying degree of success but no working solution.....the most common issue I have is errors in LDAP

I LIKE SO MANY OTHERS ARE STILL WAITING .... STILL TRYING OTHERS SOLUTIONS .... BUT .....Any news any one ?

Re: Zimbra Collaboration 8.7.x and Ubuntu OS update corrupts/removes Zimbra installation

Posted: Mon Jun 05, 2017 11:47 am
by bulletxt
racerock wrote:No still not fixed in 8.75 ...
we are now up to 8.76 although no specific mention in release notes under FIXED ISSUES in 8.7.4,5 or 6
https://wiki.zimbra.com/wiki/Zimbra_Rel ... .7.4#fixed
https://wiki.zimbra.com/wiki/Zimbra_Rel ... .7.5#fixed
Note no actual section of fixed for 8.7.6

I really don't know where they are going with this one in the past we have found a way but sadly any of the fixes I have found don't work for me ...I have recovered my virtual so many times ....... I have narrowed it down to(I think) to LDAP getting broken but .... Still waiting

I am like a lot of others all my servers are on Ubuntu 14.04 having already upgraded to a zcs 8.7.1 > version (So we are trying the migration with a version of zZmbra that has an installer of the same version under 16.04 version of Ubuntu)
Whe n I upgrade the ubuntu to 16.04 then re run the "upgrade" using the 16.04 version of the same installer ....I can try all manner of "documented fixes" here on this forum I have varying degree of success but no working solution.....the most common issue I have is errors in LDAP

I LIKE SO MANY OTHERS ARE STILL WAITING .... STILL TRYING OTHERS SOLUTIONS .... BUT .....Any news any one ?



Follow this if for example you are on ubuntu 12.04 with a working Zimbra 8.7.1 installed:

- Before upgrading the OS to 14.04 or 16.04, make a copy of /opt/zimbra/conf/localconfig.xml and place it somewhere safe.
- After upgrading OS, inside zimbra extracted installation folder open util/utilfunction.s . Go at line 799 (at least on 8.7.1) and change the whole IF command (where you see major/minor version checks) and replace it simply with: if false; then
- be sure you have the packages installed on 14.04 (they may be different for 16.04) apt-get install libnet-ldap-perl libperl5.18 libxml-simple-perl libtie-ixhash-perl libdata-uuid-perl libsocket-linux-perl
- now finally do ./install.sh -s (avoid dnscache if you're not using it)
- if everything went fine (it did? you're almost there!!) , get your copied localconfig.xml (first step) and place it in /opt/zimbra/conf/ overwriting the current broken one
- you can finally do ./install without getting errors........

have a nice day

Re: Zimbra Collaboration 8.7.x and Ubuntu OS update corrupts/removes Zimbra installation

Posted: Tue Jun 06, 2017 4:53 am
by bhwong
To avoid this issue, is it better to upgrade Ubuntu to the latest version with Zimbra 8.6 before upgrading Zimbra to 8.7.x?