CVS Build Troubles

Ask questions about your setup or get help installing ZCS server (ZD section below).
andreychek
Advanced member
Advanced member
Posts: 155
Joined: Fri Sep 12, 2014 9:58 pm

CVS Build Troubles

Postby andreychek » Wed Nov 30, 2005 4:18 pm

Howdy,
I'm hoping to create a generic build script that anyone can use to build from CVS (which handles grabbing all the dependencies, etc etc).
It's coming along really well, except I ran into a snag during my own build. I gave it a few days in case it was just a CVS problem, but still no joy.
Basically, after downloading the dependencies, I go into the ZimbraBuild dir, run 'make', and I get the following error:


# make

(cd /root/zimbra-cvs/main/ZimbraBuild/../ZimbraServer; /usr/bin/ant

-Dplat.tag=UNKNOWN

-Dzimbra.buildinfo.version=3.0.0_M3_101.UNKNOWN

-Dzimbra.buildinfo.release=20051130170512 -Dzimbra.buildinfo.date=20051130170512

-Dzimbra.buildinfo.host=zimbra.rwcwarranty.com dev-dist ; )

Buildfile: build.xml
build-init:
compile:

[javac] Compiling 322 source files to /root/zimbra-cvs/main/ZimbraServer/build/classes

[javac] /root/zimbra-cvs/main/ZimbraServer/src/java/com/zimbra/cs/object/handler/NANPHandler.java:49: cannot find symbol

[javac] symbol : constructor ObjectHandler()

[javac] location: class com.zimbra.cs.object.ObjectHandler

[javac] public class NANPHandler extends ObjectHandler {

[javac] ^

[javac] /root/zimbra-cvs/main/ZimbraServer/src/java/com/zimbra/cs/object/handler/RegexHandler.java:48: cannot find symbol

[javac] symbol : constructor ObjectHandler()

[javac] location: class com.zimbra.cs.object.ObjectHandler

[javac] public class RegexHandler extends ObjectHandler {

[javac] ^

[javac] /root/zimbra-cvs/main/ZimbraServer/src/java/com/zimbra/cs/object/handler/TrackingHandler.java:58: cannot find symbol

[javac] symbol : constructor ObjectHandler()

[javac] location: class com.zimbra.cs.object.ObjectHandler

[javac] public class TrackingHandler extends ObjectHandler {

[javac] ^

[javac] /root/zimbra-cvs/main/ZimbraServer/src/java/com/zimbra/cs/object/handler/URLHandler.java:49: cannot find symbol

[javac] symbol : constructor ObjectHandler()

[javac] location: class com.zimbra.cs.object.ObjectHandler

[javac] public class URLHandler extends ObjectHandler {

[javac] ^

[javac] Note: /root/zimbra-cvs/main/ZimbraServer/src/java/com/zimbra/cs/service/FeedManager.java uses or overrides a deprecated API.

[javac] Note: Recompile with -Xlint:deprecation for details.

[javac] Note: Some input files use unchecked or unsafe operations.

[javac] Note: Recompile with -Xlint:unchecked for details.

[javac] 4 errors
BUILD FAILED

/root/zimbra-cvs/main/ZimbraServer/build.xml:249: Compile failed; see the compiler error output for details.


The Zimbra Network Edition is currently installed on the machine, and I have JAVA_HOME set to "/opt/zimbra/jdk1.5.0_05/".
I can see the classes it's complaining about:
main/ZimbraServer/build/classes/com/zimbra/cs/object/ObjectHandler.class

main/ZimbraServer/src/java/com/zimbra/cs/object/ObjectHandler.java
I'm running this on CentOS 4.2, which is why is why plat.tag is set to "UNKNOWN".
I solved some other problems by symlinking main/ZimbraBuild/defs/RHEL.def to main/ZimbraBuild/defs/UNKNOWN.def.
Is there something not being set correctly due to the distro I'm on that's preventing that from compiling correctly? Maybe I screwed something else up? :-)
Any thoughts would be great.
As soon as the script works I'll gladly post it on here :-)
Thanks,

-Eric


14319KevinH
Ambassador
Ambassador
Posts: 4558
Joined: Fri Sep 12, 2014 9:52 pm

CVS Build Troubles

Postby 14319KevinH » Wed Nov 30, 2005 7:48 pm

Seems you found a problem with our CVS tree. Deletes aren't working. If you just delete this directory:
/root/zimbra-cvs/main/ZimbraServer/src/java/com/zimbra/cs/object/handler/
it should compile. Let us know if you hit anyother problems.
marcmac
Elite member
Elite member
Posts: 2091
Joined: Fri Sep 12, 2014 9:53 pm

CVS Build Troubles

Postby marcmac » Wed Nov 30, 2005 8:09 pm

Our cvs synchronizer was down, too - so I've fixed the tree, and It's coming back up to date.
andreychek
Advanced member
Advanced member
Posts: 155
Joined: Fri Sep 12, 2014 9:58 pm

CVS Build Troubles

Postby andreychek » Wed Nov 30, 2005 11:32 pm

[quote user="marcmac"]Our cvs synchronizer was down, too - so I've fixed the tree, and It's coming back up to date.[/QUOTE]

Aha!
Yes, that made a big difference.
Doing a 'cvs update' produces all sorts of changes, deletions, and the like. Much more what I'd expect that what I previously was seeing :-)
Now, it still doesn't compile, but it's a completely different error, and I'm sure it's just related to the snapshot I have ATM, I'll try again tomorrow.
Thanks,

-Eric
marcmac
Elite member
Elite member
Posts: 2091
Joined: Fri Sep 12, 2014 9:53 pm

CVS Build Troubles

Postby marcmac » Wed Nov 30, 2005 11:39 pm

What's the error? I don't know if our tree is up to date or not, yet, but it _usually_ builds...
andreychek
Advanced member
Advanced member
Posts: 155
Joined: Fri Sep 12, 2014 9:58 pm

CVS Build Troubles

Postby andreychek » Thu Dec 01, 2005 12:15 am

[quote user="marcmac"]What's the error? I don't know if our tree is up to date or not, yet, but it _usually_ builds...[/QUOTE]

Ya know... I just did another 'cvs update', it pulled down a few more updates, and the problem went away.
Thanks!

-Eric
dijichi2
Elite member
Elite member
Posts: 1133
Joined: Fri Sep 12, 2014 10:00 pm

CVS Build Troubles

Postby dijichi2 » Thu Dec 01, 2005 3:19 pm

i'm building on debian from current cvs
bodged my way through all the compile stuff, now getting a build.xml error:
BUILD FAILED

/opt/zimbra/zimbra-cvs/ZimbraWebClient/build.xml:542: Could not create task or type of type: propertyfile.
any ideas?
marcmac
Elite member
Elite member
Posts: 2091
Joined: Fri Sep 12, 2014 9:53 pm

CVS Build Troubles

Postby marcmac » Thu Dec 01, 2005 3:24 pm

Which ant version are you using?
dijichi2
Elite member
Elite member
Posts: 1133
Joined: Fri Sep 12, 2014 10:00 pm

CVS Build Troubles

Postby dijichi2 » Thu Dec 01, 2005 3:26 pm

Apache Ant version 1.6.5 compiled on October 1 2005
14319KevinH
Ambassador
Ambassador
Posts: 4558
Joined: Fri Sep 12, 2014 9:52 pm

CVS Build Troubles

Postby 14319KevinH » Thu Dec 01, 2005 3:56 pm

[quote user="dijichi2"]Apache Ant version 1.6.5 compiled on October 1 2005[/QUOTE]
That looks good, just make sure that 'which ant' returns the right ant and that ANT_HOME is set to the ant 1.6.5 dir.

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 6 guests