Asterisk Wiki

Interested in talking about Mash-up's? This is the place.
moebis
Posts: 35
Joined: Fri Sep 12, 2014 10:01 pm

Asterisk Wiki

Postby moebis » Tue Jul 25, 2006 9:46 am

I've started a guide in the Asterisk wiki (trying to start some kind of support here), one of the things that make Ubuntu great is it's community. I'm sure some of you have gotten this to work, but no-one feels like documenting how they went about it. So I'm trying to get the ball rolling here:
http://wiki.zimbra.com/index.php?title=Asterisk_VOIP_Zimlet


moebis
Posts: 35
Joined: Fri Sep 12, 2014 10:01 pm

Asterisk Wiki

Postby moebis » Tue Jul 25, 2006 2:04 pm

I see some of the community now getting involved in the wiki, thanks Marc MacIntyre. BTW, even though the changes are minor (piping the config_template.xml and tomcat restart) it still doesn't fix the problem.
I upgraded to 3.2 M2 today, and tried the whole process again. No go still.... actually now it jumps the java process to 100% on the Zimbra server and slows everything down if I even try to use the Asterisk Zimlet.
Anyone out there got this to work yet? :eek:
8131crash
Posts: 6
Joined: Fri Sep 12, 2014 9:59 pm

Asterisk Wiki

Postby 8131crash » Tue Aug 01, 2006 5:22 pm

I'm having the same issue with Java jumping to 100%. I followed the wiki for creating the conifg and thought I pointed it to my asterisk machine but when I right click on the asterisk zimlet and select phone server it points to here http://192.168.1.254/?referrer=www.zimbra.com. ( the default in the config file). I don't see any attempts to connect to the asterisk box.
8131crash
Posts: 6
Joined: Fri Sep 12, 2014 9:59 pm

Asterisk Wiki

Postby 8131crash » Tue Aug 01, 2006 5:58 pm

I also noticed this although I'm not sure it has anything to do with my issues.
zmzimletctl ldapDeploy com_zimbra_asterisk.zip

[] INFO: Deploying Zimlet com_zimbra_asterisk in LDAP.

Error: Cannot create Zimlet com_zimbra_asterisk: [LDAP: error code 68 - Entry Already Exists]
zmzimletctl undeploy com_zimbra_asterisk.zip

[] INFO: Uninstalling Zimlet com_zimbra_asterisk.zip from LDAP.

[] INFO: Removing Zimlet com_zimbra_asterisk.zip from COS default

Error: Cannot delete Zimlet com_zimbra_asterisk.zip: [LDAP: error code 32 - No Such Object]
henrik_b
Posts: 21
Joined: Fri Sep 12, 2014 10:13 pm

Asterisk Wiki

Postby henrik_b » Wed Aug 02, 2006 4:00 am

[quote user="8131crash"]I'm having the same issue with Java jumping to 100%. I followed the wiki for creating the conifg and thought I pointed it to my asterisk machine but when I right click on the asterisk zimlet and select phone server it points to here http://192.168.1.254/?referrer=www.zimbra.com. ( the default in the config file). I don't see any attempts to connect to the asterisk box.[/QUOTE]
Had the same problem, but found the error finally. The process causing the CPU needing 100% seems to be tomcat. If you look in /opt/zimbra/tomcat/logs/catalina.out you'll see it alwas tries to bind ports to an IP, which is the one in the default config file of com_zimbra_asterisk.zip.

So it seems that using "zmzimletctl configure" to adjust the IP-settings is not working properly. If you change the IP in the .zip-file before deploying the zimlet its working. Probably a bug in zmzimletctl?
But its still not working completely. The phone I'm calling is ringing after using the zimlet, but my own phone keeps being quiet. How is it supposed to be informed of the call? Do I have to make any special rules in asterisks extensions.conf?
seanh
Posts: 4
Joined: Fri Sep 12, 2014 10:14 pm

Asterisk Wiki

Postby seanh » Thu Aug 03, 2006 2:24 pm

[quote user="henrik_b"]Had the same problem, but found the error finally. The process causing the CPU needing 100% seems to be tomcat. If you look in /opt/zimbra/tomcat/logs/catalina.out you'll see it alwas tries to bind ports to an IP, which is the one in the default config file of com_zimbra_asterisk.zip.

So it seems that using "zmzimletctl configure" to adjust the IP-settings is not working properly. If you change the IP in the .zip-file before deploying the zimlet its working. Probably a bug in zmzimletctl?
But its still not working completely. The phone I'm calling is ringing after using the zimlet, but my own phone keeps being quiet. How is it supposed to be informed of the call? Do I have to make any special rules in asterisks extensions.conf?[/QUOTE]
I get this same problem. Asterisk makes the call but my desk phone doesn't ring. The zimlet doesn't seem to originate the call correctly.
14319KevinH
Ambassador
Ambassador
Posts: 4558
Joined: Fri Sep 12, 2014 9:52 pm

Asterisk Wiki

Postby 14319KevinH » Thu Aug 10, 2006 10:14 pm

http://192.168.1.254" is our Zimbra asterisk server ;) You'll need to change the IP to bethe IP of your own asterisk server. See the Wiki for how to do that.
seanh
Posts: 4
Joined: Fri Sep 12, 2014 10:14 pm

Asterisk Wiki

Postby seanh » Fri Aug 11, 2006 11:45 am

To the best of my knowledge I've read every thread that talks about the Asterisk zimlet. When I run the command "zmzimletctl getConfigTemplate com_zimbra_asterisk.zip" the sipHost IP address is the correct IP address of my Asterisk server. When I dial a number from Zimbra the call is placed but as I said in my previous post it does not originate the call, it just dials the number with no connection to the extension of the user making the call. I've seen many problems with this zimlet including 100% processor utilization at times, which mine does too. The thread does not have a sucessful resolution to this problem.
Does anyone know how to get this zimlet to work correctly? How is the zimlet supposed to work? Does it actually originate a call or just dial both the number and the extension?
14319KevinH
Ambassador
Ambassador
Posts: 4558
Joined: Fri Sep 12, 2014 9:52 pm

Asterisk Wiki

Postby 14319KevinH » Fri Aug 11, 2006 9:34 pm

It will use the Asterisk bridge number(ext) to make two calls one to the first number and one to the second. The 2nd should ring after the first anwsers.
gmsmith
Outstanding Member
Outstanding Member
Posts: 432
Joined: Fri Sep 12, 2014 10:09 pm

Asterisk Wiki

Postby gmsmith » Fri Aug 11, 2006 9:43 pm

[quote user="seanh"]To the best of my knowledge I've read every thread that talks about the Asterisk zimlet. When I run the command "zmzimletctl getConfigTemplate com_zimbra_asterisk.zip" the sipHost IP address is the correct IP address of my Asterisk server. When I dial a number from Zimbra the call is placed but as I said in my previous post it does not originate the call, it just dials the number with no connection to the extension of the user making the call. I've seen many problems with this zimlet including 100% processor utilization at times, which mine does too. The thread does not have a sucessful resolution to this problem.
Does anyone know how to get this zimlet to work correctly? How is the zimlet supposed to work? Does it actually originate a call or just dial both the number and the extension?[/QUOTE]
*edit*
Well I spoke a little soon. So I can get it to make an outbound call, but I can't seem to get it to connect that to my desk line. I have my info as listed here. 8730 is my desk extension. I have **** my cell phone number intentionally for this post.
So if I click on the Zimlet, get a window that says: Call From: I can choose say my desk number
Call to: I enter any external number
The external number rings, but my desk phone never rings, so the line is dead air.
I must be missing something, it has been a long day battling SuSE, so forgive me :)

Picture 1.png


Return to “Zimlets”

Who is online

Users browsing this forum: No registered users and 4 guests