iSync Connector not performing full sync

Questions, comments, and problems with Zimbra on Apple desktops & general CalDAV / CardDAV questions.
jncolin
Posts: 4
Joined: Fri Sep 12, 2014 11:13 pm

iSync Connector not performing full sync

Postby jncolin » Wed Nov 21, 2007 5:27 am

Hi
I have ZCS 4.5.9, and iSync Connector 4.5.9_GA_1450 running on Leopard.

I keep having problems synchronizing iCal with ZCS; some events are sync'd, other not, in the same calendar. I tried many times to reset everything; reset iSync (from preferences/reset Sync history), force Connector to resync (in Connector prefpane), reinstall connector, remove all preferences... Nothing work. I'm always having only partial syncs; I checked the connector log, and find that missing events (not sync'd ones) do not appear in the log files.
I also noticed that if I make a change in iCal and do a Sync from the Connector, it gets pushed to ZCS; if I add or remove an event in ZCS, and I do a Sync, changes do not get pulled.
I really would like a very simple recipe on how to copy my iCal calendars to ZCS.
Thanks for your help
Jean-Noel Colin


sculi2000
Zimbra Alumni
Zimbra Alumni
Posts: 96
Joined: Fri Sep 12, 2014 10:17 pm

iSync Connector not performing full sync

Postby sculi2000 » Wed Nov 21, 2007 10:35 am

Hey there. Sorry to hear you're having some problems. Could you do the following for me?
1) Do a reset sync from the connector prefPane

2) Attach the logs
Thanks,
Scott


[quote user="jncolin"]Hi
I have ZCS 4.5.9, and iSync Connector 4.5.9_GA_1450 running on Leopard.

I keep having problems synchronizing iCal with ZCS; some events are sync'd, other not, in the same calendar. I tried many times to reset everything; reset iSync (from preferences/reset Sync history), force Connector to resync (in Connector prefpane), reinstall connector, remove all preferences... Nothing work. I'm always having only partial syncs; I checked the connector log, and find that missing events (not sync'd ones) do not appear in the log files.
I also noticed that if I make a change in iCal and do a Sync from the Connector, it gets pushed to ZCS; if I add or remove an event in ZCS, and I do a Sync, changes do not get pulled.
I really would like a very simple recipe on how to copy my iCal calendars to ZCS.
Thanks for your help
Jean-Noel Colin[/QUOTE]
emalakoff
Posts: 2
Joined: Fri Sep 12, 2014 11:13 pm

iSync Connector not performing full sync

Postby emalakoff » Thu Nov 22, 2007 10:08 pm

I am having the exact same issues. I have reset everything on my Mac and rebooted. It will not move all the information to the the web based calendar.
We are using a trial, and solving this is a big deal for us. Any advice would be helpful.
skyhorse
Posts: 3
Joined: Fri Sep 12, 2014 11:14 pm

iSync Connector not performing full sync

Postby skyhorse » Mon Nov 26, 2007 3:24 pm

I'm having the same problem.
Some events are synced some aren't. I have tried:
- removed Zimbra connector, including files from

Library/Zimbra/*
- remove all calendars from iCal, and deleted all files in Library/Calendars/*.calendar

Library/Calendars/Calendar Sync Changes

Library/Calendars/Calendar Cache
- forced re-sync in iSync by running:

/System/Library/Frameworks/SyncServices.framework/Versions/A/Resources/resetsync.pl full
- installed Zimbra connector 4.5.9
- run a manual Reset Sync Data with Pull data from Zimbra option


The syslog shows all items are retrieved from Zimbra. They just don't make it to Calendar in iCal.
I'm running leopard with all sw update so far. The only other different thing is the fact I had added automatically a calendar called 'calendar' in iCal that Mail uses for to-do lists (same name but different case as the Calendar Zimbra uses for syncing)
sculi2000
Zimbra Alumni
Zimbra Alumni
Posts: 96
Joined: Fri Sep 12, 2014 10:17 pm

iSync Connector not performing full sync

Postby sculi2000 » Mon Nov 26, 2007 4:11 pm

There seems to be two issues that we've been tracking. The first issue is that appts from iCal are not making it to the zimbra mailbox. This issue is being tracked by bug 21986. There is a workaround for this until the fix comes in a subsequent version.
1) Verify that there is a calendar folder in zimbra mailbox with same name as iCal calendar

2) Go to iSync Connector prefPane

3) Click 'Advanced'

4) Click 'Reset Sync Data' and choose "Pull all data..."
The subsequent sync should populate the mailbox with appts from iCal.
The second issue is that appts from the mailbox are not making it to iCal. What we've noticed so far is that there are exceptions being thrown in the system log from iCal. If you are having this problem, please check Console.app and see if iCal is reporting errors. Because these errors are occurring in the iCal application itself, it's not clear what we can do to fix it. We are looking into it however.
Thanks,
Scott
emalakoff
Posts: 2
Joined: Fri Sep 12, 2014 11:13 pm

iSync Connector not performing full sync

Postby emalakoff » Mon Nov 26, 2007 7:42 pm

One thing I have discovered is that the only previous appointments before I installed the isync connector that did not migrate to the web based ZCS site were one-time only appt. All my recurring appts. (like carpool or sports practices or birthdays) that I have set to recur weekly or annually did move over. Just one-time only Dr appt. or meetings did not.
My work around was to sync and then I manually went through and reentered the appt in ical. I do keep the auto sync tab on and all the new appt made going forward in ical do move over. So the bug is just moving previous one time entries placed iCal before syncing the first time do not move over.
Luckily, most of my mtg and appt were not to difficult to re-enter. I did take some time....
I would be nice to fix that.
skyhorse
Posts: 3
Joined: Fri Sep 12, 2014 11:14 pm

iSync Connector not performing full sync

Postby skyhorse » Tue Nov 27, 2007 4:50 am

I am experiencing the problem syncing from mailbox -> iCal
syslog shows some errors from iCal.
Right at the end of the sync, these are the messages:
26/11/2007 22:27:52 [0x0-0x4e04e].com.apple.systempreferences[570] [Mon Nov 26 22:27:52 200] about to accept calendar changes (575)

26/11/2007 22:27:53 [0x0-0x4e04e].com.apple.systempreferences[570] [Mon Nov 26 22:27:53 200] finished syncing (575)

26/11/2007 22:27:53 com.apple.syncservices.SyncServer[564] [Mon Nov 26 22:27:53 200] Mac OS X version is 1051 (582)

26/11/2007 22:27:53 com.apple.syncservices.SyncServer[564] [Mon Nov 26 22:27:53 200] [assert] error: 35

26/11/2007 22:27:53 com.apple.syncservices.SyncServer[564] [assert] where: "ZimbraHelper_main.mm", "ObtainLock", line: 2257

26/11/2007 22:27:53 com.apple.syncservices.SyncServer[564] (582)

26/11/2007 22:27:53 com.apple.syncservices.SyncServer[564] [Mon Nov 26 22:27:53 200] [assert] error: (null)

26/11/2007 22:27:53 com.apple.syncservices.SyncServer[564] [assert] where: "ZimbraHelper_main.mm", "main", line: 3953

26/11/2007 22:27:53 com.apple.syncservices.SyncServer[564] (582)

26/11/2007 22:30:10 com.apple.launchd[153] ([0x0-0x54054].dotmacsyncclient[585]) Exited with exit code: 113


After that, the following show up every few minutes (probably when iCal is syncing):
27/11/2007 10:40:56 iCal[987] Unexpected EOF, returning last token as fallback
a few times and then this:
27/11/2007 10:44:34 com.apple.launchd[153] ([0x0-0x91091].dotmacsyncclient[1191]) Exited with exit code: 113


Hope this helps.....
skyhorse
Posts: 3
Joined: Fri Sep 12, 2014 11:14 pm

iSync Connector not performing full sync

Postby skyhorse » Tue Nov 27, 2007 11:57 am

interestingly enough, it started syncing all appointments (at least the ones I knew were not being synced) again this afternoon...
The only thing I changed was remove the network settings file and create a blank new one by adding a new "location". I had to do this because I had the Missing Sync installed previously and this left hundreds of virtual network devices that I wanted to remove...
Maybe its a clue...
isam
Posts: 1
Joined: Fri Sep 12, 2014 11:14 pm

iSync Connector not performing full sync

Postby isam » Wed Nov 28, 2007 5:04 am

I had a problem that might be similar, I am using Zimbra iSync 4.5.1450 .. the problem I am having is that only the events with "attendants" are synced .. all other events in my iCal calendar didn't appear in Zimbra ..
Is this an issue in the Zimbra iSync connector ? or I am missing a configuration or something ?
griffon
Posts: 34
Joined: Fri Sep 12, 2014 10:32 pm

iSync Connector not performing full sync

Postby griffon » Fri Nov 30, 2007 1:47 pm

I have two users that have the same issue (4.9GA). Their calendars just stooped updating the other day. Doing a full resync doesn't correct it. I asked for logs and will post them as soon as I get them. I thought the isync was the 'one' zimbra feature that wasn't going haywire on us :P.

Return to “CalDAV / CardDAV / iSync”

Who is online

Users browsing this forum: No registered users and 4 guests