ZCB Beta 3 ... Calendar Syncing [SOLVED]

Are you using the Zimbra Connector for BlackBerry? Post your comments and questions here.
nlongmuir
Posts: 7
Joined: Fri Sep 12, 2014 11:24 pm

ZCB Beta 3 ... Calendar Syncing [SOLVED]

Postby nlongmuir » Wed Sep 10, 2008 8:41 am

All,
I thought I would share my experiences so as to prevent others from going through needless hand wrenching ...
I was having difficulty getting calendar syncing to work both ways ...
The problem was related to the way ZCO uses the MAPI/CDO libraries.
The ExchangeCDO install (.MSI) places by default the cdo.dll into "C:Program FilesExchangeMapi"
by copying the cdo.dll to "C:windowssystem32" and registering the dll via "regsvr32 c:windowssystem32cdo.dll" (and renaming the cdo.dll in the ExchangeMapi directory),calendar syncing both ways started working. :p
There were many errors in the logs re:
- [MAPI 1.0 - [MAPI_E_LOGON_FAILED(80040111)]]

- CDOCalendar::Initialize - Error in call m_spCalendarFolder = m_spCDOSession->GetDefaultFolder
In addition, look in the BES MAGT log for
- [30000] (09/09 21:04:06.125):{0xF5C} [ENV] CDO.DLL: C:WINDOWSsystem32cdo.dll, Version: 6.5.8039.0
this ensures the environment is correct.


16113Chewie71
Outstanding Member
Outstanding Member
Posts: 367
Joined: Fri Sep 12, 2014 10:17 pm

ZCB Beta 3 ... Calendar Syncing [SOLVED]

Postby 16113Chewie71 » Fri Sep 12, 2008 3:26 pm

I have one user with a similar problem to this and was going to try this except.... I don't have "C:Program FilesExchangeCDO" on my server (Windows 2003). It looks like it's already installed into C:windowssystem32....so maybe that's not the issue?
What log are you looking in to find the MAPI_E_LOGIN_FAILED errors?
Below is the info for CDO in the MAGT log file....so it seems like it's working for me, except for this one user.
Any thoughts?
Matt


[QUOTE][30000] (09/12 00:00:00.512):{0xCC0} [ENV] MAPI32.DLL: C:WINDOWSsystem32MAPI32.dll, Version: 1.0.2536.0
[30000] (09/12 00:00:00.512):{0xCC0} [ENV] CDO.DLL: C:WINDOWSsystem32CDO.dll, Version: 6.5.7974.0
[30000] (09/12 00:00:00.602):{0xCC0} [ENV] Failed to read 001e6602 reg value from the BlackBerry MAPI profile.
[30000] (09/12 00:00:00.602):{0xCC0} [ENV] Microsoft Management Console (MMC): C:WINDOWSsystem32mmc.exe, Version: 5.2.3790.3959
[30000] (09/12 00:00:00.602):{0xCC0} [ENV] BlackBerry Mailbox Agent 1 - BESX Version 4.1.6.11
[30000] (09/12 00:00:00.602):{0xCC0} [ENV] BES Service Name: BlackBerry Mailbox Agent
[30000] (09/12 00:00:00.612):{0xCC0} [ENV] BlackBerry Dispatcher: C:Program FilesResearch In MotionBlackBerry Enterprise ServerBlackBerryDispatcher.exe, Version: 4.1.6.10
[30000] (09/12 00:00:00.612):{0xCC0} [ENV] BlackBerry User Administration Service: NOT FOUND
[30000] (09/12 00:00:00.612):{0xCC0} [ENV] BlackBerry MDS Connection Service: C:Program FilesResearch In MotionBlackBerry Enterprise ServerMDSinmds.exe, Version: 4.1.6.26
[30000] (09/12 00:00:00.612):{0xCC0} [ENV] BlackBerry Database Consistency Service: C:Program FilesResearch In MotionBlackBerry Enterprise ServerMDSinDBConsistency.exe, Version: 4.1.6.11
[30000] (09/12 00:00:00.612):{0xCC0} [ENV] BlackBerry Policy Service: C:Program FilesResearch In MotionBlackBerry Enterprise ServerITAdminServer.exe, Version: 4.1.6.15
[30000] (09/12 00:00:00.612):{0xCC0} [ENV] BlackBerry Synchronization Service: C:Program FilesResearch In MotionBlackBerry Enterprise ServerSyncServerBlackBerrySyncServer.exe, Version: 4.1.6.9
[30000] (09/12 00:00:00.612):{0xCC0} [ENV] BlackBerry Router: C:Program FilesResearch In MotionBlackBerry Enterprise ServerBypassRouterBlackberryRouter.exe, Version: 4.1.6.10
[30000] (09/12 00:00:00.652):{0xCC0} [ENV] BlackBerry Controller: C:Program FilesResearch In MotionBlackBerry Enterprise ServerBlackBerryController.exe, Version: 4.1.6.11
[30000] (09/12 00:00:00.652):{0xCC0} [ENV] BlackBerry Alert: C:Program FilesResearch In MotionBlackBerry Enterprise ServerBESAlert.exe, Version: 4.1.6.9
[30000] (09/12 00:00:00.652):{0xCC0} [ENV] BlackBerry Attachment Service: C:Program FilesResearch In MotionBlackBerry Enterprise ServerAttachServerBBAttachServer.exe, Version: 4.1.6.6
[35015] (09/12 00:00:00.692):{0xCC0} [ENV] Total number of requests for connections: 112046
[35013] (09/12 00:00:00.692):{0xCC0} [ENV] Connection count high water mark since service was started: 7
[35014] (09/12 00:00:00.692):{0xCC0} [ENV] Number of waits for connections since service was started: 21
[35019] (09/12 00:00:00.692):{0xCC0} [ENV] [DB] Database Schema Version: 4.1.6
[30000] (09/12 00:00:00.702):{0xCC0} [ENV] [DB] Connection String = Server=sql.ucss.wiu.edu;Database=BESMgmt;Trusted_Connection=Yes
[30000] (09/12 00:00:00.702):{0xCC0} [ENV] [DB] DBMS Name = Microsoft SQL Server; DBMS Version = 09.00.3042; Provider Name = sqloledb.dll; Provider Friendly Name = Microsoft OLE DB Provider for SQL Server; OLE DB Version = 02.70; Provider Version = 08.10.3959
[41120] (09/12 00:00:00.702):{0xCC0} [CFG] Address Lookup is enabled
[41122] (09/12 00:00:00.702):{0xCC0} [CFG] LDAP search is disabled, LDAP PIM search is disabled, LDAP ALP search is disabled
[41123] (09/12 00:00:00.702):{0xCC0} [CFG] Using up to 10 external CDO Helpers in keep-alive mode
[41124] (09/12 00:00:00.702):{0xCC0} [CFG] AddOwnerApptID is disabled
[41125] (09/12 00:00:00.702):{0xCC0} [CFG] SetLocaleIDs is disabled
[30302] (09/12 00:00:00.702):{0xCC0} [CFG] OTAFM hard-delete server support is disabled, rescans are 0x00
[40532] (09/12 00:00:00.702):{0xCC0} [CFG] vCard conversion support has been enabled
[40892] (09/12 00:00:00.702):{0xCC0} [CFG] GlobalRescan config: messaging:O, calendar:O, pim:O
[30362] (09/12 00:00:00.702):{0xCC0} This agent will handle 18 user(s)[/QUOTE]
10339alee
Zimbra Alumni
Zimbra Alumni
Posts: 406
Joined: Fri Sep 12, 2014 10:31 pm

ZCB Beta 3 ... Calendar Syncing [SOLVED]

Postby 10339alee » Fri Sep 12, 2008 5:04 pm

[quote user="16113Chewie71"]I have one user with a similar problem to this and was going to try this except.... I don't have "C:Program FilesExchangeCDO" on my server (Windows 2003). It looks like it's already installed into C:windowssystem32....so maybe that's not the issue?
What log are you looking in to find the MAPI_E_LOGIN_FAILED errors?
Below is the info for CDO in the MAGT log file....so it seems like it's working for me, except for this one user.
Any thoughts?
Matt[/QUOTE]


If you don't have the ExchangeMapi folder in your program files, you probably installed an older package that sticks the dlls right into windowssystem32.
but what this means it that you probably aren't having the same problem as the other post since it seems that his problem was that the wrong version of CDO.DLL was registered.
there is a wealth of information in the BES agent logs but you can also look in the calhelper ZCB logs for some errors if there are issues with appts. we had a bug with users with LONG email addresses but that was fixed in the first patch of the BETA 3 release.
if you haven't already downloaded that release, you might want to do it and install it over what you already have.
--Tony
16113Chewie71
Outstanding Member
Outstanding Member
Posts: 367
Joined: Fri Sep 12, 2014 10:17 pm

ZCB Beta 3 ... Calendar Syncing [SOLVED]

Postby 16113Chewie71 » Mon Sep 15, 2008 11:00 am

Found these in the MAGT BES logs for the user having problems...

[QUOTE]

[40267] (09/15 00:12:41.887):{0xF00} {user@domain.edu} Starting calendar rescan
[40136] (09/15 00:12:41.887):{0xF00} CalICSAgent::GetDirectoryName synch directory retrieved from registry: C:Program FilesResearch In MotionBlackBerry Enterprise ServerAgentsICSSync for user@domain.edu

[10007] (09/15 00:12:41.887):{0xF00} CalICSSynchronizer::Initialize - OpenProperty failed: (0x80004002)
[20041] (09/15 00:12:41.887):{0xF00} CalICSAgent::Start Could not Initialize Synchronizer for user@domain.edu: (0x80004002)
[30020] (09/15 00:12:41.887):{0xF00} {user@domain.edu} MAPIMailbox:: DoICS ICS Start failed
[20280] (09/15 00:12:41.887):{0xF00} {user@domain.edu} DoICS() failed: ERR_FAIL
[40701] (09/15 00:12:41.997):{0xF00} {user@domain.edu} Calendar rescan completed

[/QUOTE]
and these...

[QUOTE][20675] (09/15 00:11:21.689):{0xEF0} {user@domain.com} Error creating OOF Rule in CreateOOFRule (OpenProperty failed) (0x80004002)
[40442] (09/15 00:11:21.689):{0xEF0} User settings: email=user@domain.com, routing=S40713521, service=BES, device=32CC1A05, calendar=1, MDS=1, userOTAFM=63, incradle=0, SMIME=0, sentItems=1, dir=user@domain.com, server=zimbra5.domain.com

[/QUOTE]
...is any of it related?
Matt
10339alee
Zimbra Alumni
Zimbra Alumni
Posts: 406
Joined: Fri Sep 12, 2014 10:31 pm

ZCB Beta 3 ... Calendar Syncing [SOLVED]

Postby 10339alee » Mon Sep 15, 2008 11:54 am

[quote user="16113Chewie71"]Found these in the MAGT BES logs for the user having problems...


and these...


...is any of it related?
Matt[/QUOTE]
No...unfortunately those aren't related to the issues that you are seeing. Although ZCB tries to look like Exchange to BES, there are some things that are different and BES is smart at trying some thing one way and then trying it another way if that first method is not support....that is why you see some errors in the logs. By no means are those actual errors though.
I think that we need to see ZCB logs outlining a sync from the server that should have an appt item in there or vice versa. Then we can see where the appt is getting dropped. There is also a BES application called CalHelper.exe that facilitates some calendar work so there should be ZCB logs for that process too...but mainly if the appts that are not syncing are meetings as opposed to calendar items with no attendees.
Another couple of things to keep in mind.
1) check your local failures folder off of your ZCB logs folder root. if there are problems converting those appts, then they will not show up on the device. if there were failures, there will be a report of it.
2) are you sure that you have calendar wireless sync enabled? i believe that there are settings on the BES and on the device that can enable it or disable it. by default, it should be on unless you have some group policy overriding that
3) you could potentially stop the BES controller and open up outlook and check the problematic account to see if the appts are in outlook but not the device. if they are viewable via Outlook but are not on the device, this is a BES problem. if they are not even in Outlook, this could be a ZCB problem. Note that opening Outlook on BES is painful if you have a lot of users so I wouldn't recommend this if you have more than 10-15 users.
--Tony
stegbth
Advanced member
Advanced member
Posts: 141
Joined: Fri Sep 12, 2014 11:48 pm
Location: Bavaria in Germany

ZCB Beta 3 ... Calendar Syncing [SOLVED]

Postby stegbth » Mon Sep 22, 2008 4:48 pm

hi,
i am also fighting with zcb beta3 i can sync contacts and email's fine. but when adding an appointment i get an email on the blackberry: naming Local "Failure Notice"

the cdo.dll is version 6.5.8039.0 and is moved and registered already to c:windowssystem32
my account names are "username@domain.tld", but the canonical adress is "firstname.lastename@domain.tld" many of my appointment are setup with the canonical adress. when using the account-names as attendant and originator it seems to work.
are there any ideas to work arround this?
many greetings

thomas
Release 8.6.0.GA.1153.UBUNTU14.64 FOSS edition, Patch 8.6.0_P6
10339alee
Zimbra Alumni
Zimbra Alumni
Posts: 406
Joined: Fri Sep 12, 2014 10:31 pm

ZCB Beta 3 ... Calendar Syncing [SOLVED]

Postby 10339alee » Tue Sep 23, 2008 6:54 pm

[quote user="stegbth"]hi,
i am also fighting with zcb beta3 i can sync contacts and email's fine. but when adding an appointment i get an email on the blackberry: naming Local "Failure Notice"

the cdo.dll is version 6.5.8039.0 and is moved and registered already to c:windowssystem32
my account names are "username@domain.tld", but the canonical adress is "firstname.lastename@domain.tld" many of my appointment are setup with the canonical adress. when using the account-names as attendant and originator it seems to work.
are there any ideas to work arround this?
many greetings

thomas[/QUOTE]
please enable ZCB logging, reproduce the problem and then send the logs to support. the problem is probably in there. also send the BES Agent logs too.
stegbth
Advanced member
Advanced member
Posts: 141
Joined: Fri Sep 12, 2014 11:48 pm
Location: Bavaria in Germany

ZCB Beta 3 ... Calendar Syncing [SOLVED]

Postby stegbth » Wed Sep 24, 2008 3:56 am

hello alee,
we found the error.

outlook2007 (it is a testversion) was informing, that it will expire on 30.nov. several time's after accepting twice (need to start outlook several times!!), outlook started without any notice.

after "resending Service Books" in BlackBerry Manager it worked for new calender entries.
what do zimbra mean by:

Previous calendar items do not appear in Calendar?
does items created in the past not get synced or items, where the appointment-time is in the past?

cause currently we have only new created appointments in the blackberry, lets see, how long "force calendar syncronisation" takes
what is then the sense of the following registry settings

MaxInitialAge
the logs are already since last week as case within the support system. but no reaction over 6 day's after requesting the logs. so currently my customer is pretty annoid about the zimbra-support and now about the "trivial" error :(
what would be very helpfull (also when reading throu this forum), there are several answer's about:

move this dll there, remove that dll, what version of this dll are, where on the system.

a list about all needed dll's (mapi.dll, mspst32.dll, cdo.dll and so on)

where and in what version they should reside and what version's are wrong
greetings

thomas
Release 8.6.0.GA.1153.UBUNTU14.64 FOSS edition, Patch 8.6.0_P6

Return to “Zimbra Connector for Blackberry”

Who is online

Users browsing this forum: No registered users and 1 guest