Can't save to configuration

Interested in talking about Mash-up's? This is the place.
Posts: 1
Joined: Thu Jul 14, 2016 8:21 am

Can't save to configuration

Postby claudia » Thu Jul 14, 2016 9:00 am


I created a component to extend zimbra admin functionality.

I am appending models definitions to ZaGlobalConfig.myXModel and ZaServer.myXModel to be able to set different configuration at Global and Server level.

Using myGlobalXFormModifier and myServerXFormModifier I am able to create views for my new component and I am able to see my input field, but when I am saving I have the following problems:

- at Global level, I receive the success message, but my input field remains empty after, so I don't think the save is done
- at Server level, I receive an error message

Message: invalid attr name: invalid attr name - unable to modify attributes: zimbraSEPanelUrl: attribute type undefined Error code: account.INVALID_ATTR_NAME Method: [unknown] Details:soap:Sender

even zimbraSEPanelUrl is registered to ZaServer.myXModel.items.

My questions are:
- can I check in some other way what is saved at Global level? How can I display all Configuration data? I already tried with zmprov gacf, but I think it returns only default configuration data, so only fields added on install.
- do you know some examples or some updated documentation which can help me, because I tried to follow, but didn't help to much.



Return to “Zimlets”

Who is online

Users browsing this forum: No registered users and 1 guest