Results 1 to 5 of 5

Thread: Canonical address for the From: address from Blackberry?

  1. #1
    Join Date
    Jan 2009
    Posts
    17
    Rep Power
    6

    Default Canonical address for the From: address from Blackberry?

    We're running Zimbra 5.0.10 w/ZCB Beta3 and BES 4.1.6.

    All of our users techincally have a "true" email address of the form xy1234@zimbrapro.domain.com and a desired public email address of the form "brian@domain.com".

    We've set a "Canonical address" for each of the Zimbra users to match their desired public email address and when they send email from the Zimbra web interface the email goes out with their desired public email address as the From: address.

    When they send email from their Blackberry though, the email goes out showing their true technical email address, not their their desired public email address.

    Other than that, everything else appears to be working fine.

    I believe this is a Zimbra issue, not a BES issue, since we had the same problem long ago with BES and MS Exchange. It turned out to be an Exchange configuration issue, not a BES issue. Now we're moving to Zimbra though and have to address the problem again.

    Any help would be greatly appreciated.

    Thanks,
    Brian

  2. #2
    Join Date
    Jan 2009
    Posts
    17
    Rep Power
    6

    Default

    We're still struggling with this issue...

    Before we switched over to Zimbra from MS Exchange, in Active Directory it was possible to create a second "SMTP" entry within a user's AD account (under the email addresses tab) then make that second SMTP entry the "default", which then shows in bold type.

    That email address would then be the "From:" address when that user sends email from their Blackberry.

    From what I understand, the equivalent in Zimbra is the "Canonical address" when provisioning new users in Zimbra. But, it doesn't appear to be utilized when sending email from the Blackberry.

    As a side note, we're also having the same problem with the Outlook Connector, so I presume the two issues are related (code wise) and possibly internal to how the ZCB and ZCO modules work?

    Other than the above, our transition from Exchange to Zimbra has gone very smooth.

    Any help would be greatly appreciated.

    Thanks,
    Brian

  3. #3
    Join Date
    Feb 2009
    Posts
    5
    Rep Power
    6

    Default

    We're still struggling with this, and is what is holding us back on a wide scale migration. Anybody with any ideas?

  4. #4
    Join Date
    Nov 2005
    Posts
    518
    Rep Power
    11

    Default

    What shows up in the logs (mailbox.log and zimbra.log) when someone sends a message from a Blackberry and the canonical address is not used?

    Has postconf local_header_rewrite_clients been modified?

  5. #5
    Join Date
    Jan 2009
    Posts
    17
    Rep Power
    6

    Default

    I'm a bit hesitant to post the actual logs without sanitizing them but I also don't want to accidentally change something that might be important. If you can send me your email address I can send the pertinent info to you directly. My email is brian at eng dot wayne dot edu

    And no, we didn't change postconf local_header_rewrite_clients directly but could it have been changed by the zimbra administrative gui?

    Thanks,
    Brian

Similar Threads

  1. Canonical Address
    By Bill Brock in forum Administrators
    Replies: 11
    Last Post: 07-18-2013, 07:57 AM
  2. [SOLVED] Outlook no longer updating
    By jeremy.pratt in forum Zimbra Connector for BlackBerry
    Replies: 10
    Last Post: 05-30-2008, 04:22 PM
  3. don't use canonical address in local domain
    By luiso2 in forum Administrators
    Replies: 0
    Last Post: 04-28-2008, 12:43 AM
  4. webmail not always using canonical address
    By jeffw in forum Installation
    Replies: 1
    Last Post: 11-21-2007, 09:06 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •