Results 1 to 2 of 2

Thread: [SOLVED] One Way Calendar Sync

  1. #1
    Join Date
    Oct 2008
    Posts
    24
    Rep Power
    7

    Default [SOLVED] One Way Calendar Sync

    Just did a full refresh to solve this problem, and while I don't get the same error message, I have the same result. Essentially, Zimbra updates for the calendar get to the blackberry, but not from the blackberry to Zimbra.

    Here is the critical log section:

    40700] (01/27 10:45:50.046):{0x1328} {david@something.org} Receiving packet from device, size=124, TransactionId=1078853842, Tag=5417, content type=CICAL, cmd=0x3
    [40000] (01/27 10:45:50.046):{0x1328} {david@something.org}-HandleAppointmentToSynchronize-Entering-Tag=5417
    [30193] (01/27 10:45:50.046):{0x1328} {david@something.org} Receiving calendar update from device, RefId=440517334, Tag=5417, TransactionId=1078853842
    [40000] (01/27 10:45:50.062):{0x1328} CDO helper 0f263480 is not in memory
    [40000] (01/27 10:45:50.062):{0x1328} Starting new CDO helper 0f263480
    [40574] (01/27 10:45:50.281):{0x142C} CDO helper 0f263480 started, PID 5824
    [20266] (01/27 10:45:50.671):{0x142C} {david@something.org} CDOCalendar::Initialize - CreateInstance (0x80040154) failed
    [40580] (01/27 10:45:50.671):{0x142C} CDO helper 0f263480 closing after CDO initialize failure
    [40000] (01/27 10:45:50.781):{0x142C} CalHelper failed 0f263480, ErrorCode = -11, Thread activity was Checking CDO object list
    [40577] (01/27 10:45:51.328):{0x142C} CDO helper 0f263480 stopped
    [40000] (01/27 10:46:00.671):{0x1328} {david@something.org} Retrying (2) CDO helper 0f263480 call in RunCalHelper
    I've read through everything I can find, both here and on just bes stuff, and can't find the solution. I even tried moving and re-registering the cdo.dll file in system32, but got the exact same error. Really struggling with this, any help is greatly appreciated!

  2. #2
    Join Date
    Oct 2008
    Posts
    24
    Rep Power
    7

    Default Update

    After unregistering both dlls, then re-registering only c:\windows\system32\cdo.dll (making sure to rename the one in ExchangeMapi), the CDO errors are now gone. I rebooted both boxes and I appear to be able to update from the blackberry now. Odd behavior in two instances:

    1. If I delete an appointment on the BBerry, it will reappear on the bberry within 30 seconds, then the appointment will delete from zimbra in another 30 seconds, then after a short period it will re-delete off of the bberry.

    2. It appears that sometimes I need to update something in zimbra for it to pick up changes in the bberry.

    David

Similar Threads

  1. Replies: 13
    Last Post: 11-20-2008, 12:42 PM
  2. Hangs on "Loading" screen
    By gbr in forum General Questions
    Replies: 16
    Last Post: 06-19-2008, 02:01 PM
  3. 4 MACs one calendar and contact Sync issue
    By 3tpro in forum CalDAV / CardDAV / iSync
    Replies: 0
    Last Post: 05-24-2008, 10:06 AM
  4. zdesktop issue report (2008-05-22 17:25:42): mail.NO_SUCH_MSG
    By John Marsden, FH Ba in forum Error Reports
    Replies: 0
    Last Post: 05-23-2008, 03:49 AM
  5. ZCS 4.5.4 Mobile - No Multiple Calendar Sync?
    By dlbewley in forum Zimbra Mobile
    Replies: 9
    Last Post: 07-08-2007, 10:13 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •