Just trying to setup my small company with blackberry support and the zimbra service.



We have a small windows server that we rent from godaddy, it came with plesk.



I've updated all the patches on the OS via windows update -Microsoft Windows Server 2003 Web Edition Service Pack 2



I installed Microsoft CDO 1.2.1



Then I installed 4.1 BB Server software. It prompted me to reboot, which I did.



Final step in the process said it tried to start the BB server, but failed. Had the following messages



BlackBerry Controller has failed to start due to The dependency service does not exist or has been marked for deletion. BlackBerry Router has failed to start due to The dependency service does not exist or has been marked for deletion. BlackBerry Dispatcher has failed to start due to The dependency service does not exist or has been marked for deletion. BlackBerry MDS Connection Service has successfully started. BlackBerry Policy Service has failed to start due to The dependency service does not exist or has been marked for deletion. BlackBerry Attachment Service has successfully started. BlackBerry Synchronization Service has failed to start due to The dependency service does not exist or has been marked for deletion.



I then installed the ZCS Connector for Blackberry and followed the guide as well.



Rebooted one more time and still nothing. BB Server just doesnt seem to start, so what am I missing? Sorry I'm so new to blackberry land I dont really know enough about it.



If I look at the services, I see the following started: BlackBerry MDS Connection Service, that is it, the rest say automatic, but are not started.



If I look in the event viewer, I see the following errors:

<2009-09-10 12:51:02.937 GMT-05:00>:[30]:<MDS-CS_POKYBB_MDS-CS_1>:<ERROR>:<LAYER = SCM, LifecycleException: Protocol handler initialization failed: java.net.BindException: Address already in use: JVM_Bind:8080> <2009-09-10 12:51:02.937 GMT-05:00>:[30]:<MDS-CS_POKYBB_MDS-CS_1>:<ERROR>:<LAYER = SCM, at org.apache.catalina.connector.Connector.initialize (Connector.java:1018)> <2009-09-10 12:51:02.937 GMT-05:00>:[30]:<MDS-CS_POKYBB_MDS-CS_1>:<ERROR>:<LAYER = SCM, at org.apache.catalina.startup.Embedded.start(Embedde d.java:826)> <2009-09-10 12:51:02.937 GMT-05:00>:[30]:<MDS-CS_POKYBB_MDS-CS_1>:<ERROR>:<LAYER = SCM, at net.rim.application.ipproxyservice.TomcatThread.st artTomcat(TomcatThread.java:807)> <2009-09-10 12:51:02.937 GMT-05:00>:[30]:<MDS-CS_POKYBB_MDS-CS_1>:<ERROR>:<LAYER = SCM, at net.rim.application.ipproxyservice.TomcatThread.ru n(TomcatThread.java:510)>



and



The BlackBerry Dispatcher service depends on the following nonexistent service: LanmanWorkstation


I appreciate any help or tips in getting this going, and let me know if you need any other log files or information to help troubleshoot.