Results 1 to 5 of 5

Thread: Blackberry documentation

  1. #1
    Join Date
    Aug 2012
    Posts
    110
    Rep Power
    3

    Default Blackberry documentation

    Hi,

    As Zimbra is not supported by BES and BES documentation is oriented for deployment with Exchange enviroments (or Lotus or Groupwise), I think that Zimbra documentation should really fill the existing gaps. For instance, if I try calling BES support, first thing they notice is that outlook is installed and the CDO is not the one they say it should be installed...both things are not in compliance with their documentation. So please, this is something I would really love to see "improve the BES documentation".

    I'm now stucked in a point where I just can't list the AD users in the BES web admin page. So I'm not being able to add any user...

    After talking with Zimbra support, I've been told that I didn't need an AD installed in my BES machine (which is a relieve...'cause having to have another DC just to sync with BES is nothing but anoying). Zimbra documentation kind of "assumes" that I know how to install a BES...the only place where I feel I can learn is by following BES guides for installation that are written for Exchange, not for Zimbra.

    Please Zimbra, improve this.

    BTW, if anyone reading this has ever faced this problem, please let me know what could I do to fix it.

    1) zcs ne 8.0.7
    2) 1 CentOS 6.5 with mailstore/ldap + 1 CentOS 6.5 with proxy/mta
    3) 1 Windows 2008 64 bits (updated) + 1 Outlook 2007 SP3
    4) besadmin created as asked in zimbra documeantation
    5) DoS precautions have been taken
    6) Comunication to port 7071 and 8443 in the mailstore is fine
    7) Outlook profiles created as said in zimbra documentation
    8) Everything in the BES server was installed following the exact order provided in the zimbra documentation (even the CDO and zimbra connector)
    9) BES is version 5.0.4 m7
    10) I'm using a local sql express 2008 db

    Regards,
    Sebas

  2. #2
    Join Date
    May 2014
    Location
    Madrid
    Posts
    202
    Rep Power
    1

    Default

    Hi pub_seba,
    Did you try to follow these steps that we wrote weeks ago?
    Zimbra: BES (Blackberry Enterprise Server) » Blog de Jorge de la Cruz

    I hope that you find the solution for the problem.

    Kind regards

  3. #3
    Join Date
    Aug 2012
    Posts
    110
    Rep Power
    3

    Default

    Hi Jorge!

    Although I saw that post, it follows the "install a DC" for having the BES connector working. I'm trying to avoid that at all costs. Do you know if there's any chance to make this work even without having to "dcpromo" the server just to work with Zimbra connector?

    Thanks!
    Sebas
    PD: Cuando volvamos a vernos en persona, también nos hablaremos en inglés

  4. #4
    Join Date
    Aug 2012
    Posts
    110
    Rep Power
    3

    Default

    So this very same monday, after re-opening the ticket, Lukesh Kothaaré from Zimbra Support spent like 4-5 hours working in this issue and finally fixing the problem. I can not thank enough the dedication and amazing work Lukesh did.

    It turns out that from version 5.0.4 (the last one of the 5x series by now), there's a small change that was the responsable for driving me crazy the whole weekend

    Long story short, if you are using 5.0.4 (m7 is the one i was using aswell), you have to make sure that this registry key is set to "0"

    \HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Research In Motion\BlackBerry Enterprise Server\Agents
    LDAPSearch - REG_DWORD - 0x00000000 (0)

    And this was why I wasn't able to actually scout Zimbra OpenLDAP!!!

    Please remember that I did not completly follow the Zimbra Documentation which I found incomplete and unpractical for BES connectors deployment. In this case:

    1) I re-adapted the existing BES server that was in place before Exchange -> Zimbra migration
    In order to do so, you'll have to uninstall the CDO-MAPI that it's installed as it's incompatible with the one Zimbra needs. And then I also had to change the BES Database information of the users for them to point to the dn that Zimbra uses so it looked like this after my changes under the BES web GUI under "component information" of the user:
    /o=ldapservername.domain.i.use/ou=First Administrative Group/cn=Configuration/cn=Servers/cn=ldapservername.domain.i.use/cn=Microsoft Private MDB
    In order to do that is as simple as executing UPDATE UserconfigSET ServerDN='o=correu.vallsnet.local/ou=First Administrative Group/cn=Configuration/cn=Servers/cn=correu.vallsnet.local/cn=Microsoft Private MDB'

    2) Installed english version (important no matter where you are) of a compatible outlook 2007 SP3

    3) Manually created the 2 blackberry MAPI profiles as needed

    4) Installed the proper CDO (the one Zimbra needs) as explained in ZimbraBESconnector admin guide

    5) Restarted the server and voilá!

    Just make sure that no DoS is going to mess things up. For me this is the only thing that actually worked:
    As zimbra user at the store server:
    $ zmprov mcf zimbraHttpDosFilterMaxRequestsPerSec 100
    $ zmprov mcf zimbraHttpDosFilterDelayMillis 20
    $ zmprov mcf zimbraHttpThrottleSafeIPs xx.xx.xxx.x (ip address of your bes server)

    There's pretty good documentation of what and how these 3 commands work, so I won't write it here.

    Also, make sure that you changed the proper registry key!!!

    Well, that's it, basically with this steps you won't have to create a new BES server and of course, you will not need to add a new DC to a domain just to make BES Zimbra connector work! As you are using already activated devices...no need for re-activate all of them nor wipping them for that matter. Worst case scenario, you will have to re-create some account but nothing in comparisson of redeploying a new BES, I mean, for 20 users it could be a solution but if we are talking hundreads...

    Hope this helps someone!
    Sebas

  5. #5
    Join Date
    May 2014
    Location
    Madrid
    Posts
    202
    Rep Power
    1

    Default

    Thank you so much for all the info Sebas, and thank you so much too to Lukesh, Support people in Zimbra rocks!

    I'm pretty sure that this post will help somebody.

    Kind regards !

Similar Threads

  1. API Documentation
    By tegyat in forum Developers
    Replies: 7
    Last Post: 01-31-2008, 09:56 AM
  2. ZCS v.5 Documentation
    By ezajko in forum Developers
    Replies: 2
    Last Post: 06-21-2007, 08:43 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •