Results 1 to 10 of 10

Thread: Calendar not sync'ing correctly

  1. #1
    Join Date
    May 2006
    Posts
    196
    Rep Power
    9

    Default Calendar not sync'ing correctly

    Hi,

    I just got a new windows profile and had to sync my Outlook again. This all worked fine for Mails and contacts.
    But "older" calendar entries (everything that was in the calendar before starting the new sync) do not appear in Outlook. If I add entries now, they are synced as usual.

    Any idea how I might get the old entries??

    Thanks

    Christian

  2. #2
    Join Date
    May 2006
    Posts
    196
    Rep Power
    9

    Default

    bump


    No idea form anyone??

  3. #3
    Join Date
    Jan 2007
    Posts
    66
    Rep Power
    8

    Default

    has your domain or anything changed network-wise? I can see that causing problems like this. Maybe Zimbra doesn't know you're the organizer of the appointments anymore and won't download them based on that.

    It seems you've stumped everyone with this one. Hopefully this helps, but it's pretty long after your original post. Has no one else had anything like this happen?

  4. #4
    Join Date
    May 2006
    Posts
    196
    Rep Power
    9

    Default

    This might be the right track.

    We changed our windows domain, that is the reason for my new profile.
    But I think that this should not affect Zimbra, as I did a new initial sync and the mail domain and the local dns domain did not change.

    Christian

  5. #5
    Join Date
    Jan 2007
    Posts
    66
    Rep Power
    8

    Default

    That probably actually is the problem though. When Zimbra makes an appointment in your calendar it puts in an 'organizer'. When you change the username at all(prefix, domain, etc.) it changes the organizer and Zimbra assumes that you did not create the appointment as your name is now different.

    Here's the bug link, so vote and it might get fixed: Bug 7129 - cannot move existing appt/message/etc. to another user's mailbox

    To check this go into Zimbra, download your ICS file ( http://<server>/service/home/<user>/calendar?fmt=ics ). Open the file in Notepad and do a search for your old and new email addresses. Likely what you'll find is that the old appointments have your old address associated with it.

    Good luck, you'll need it.

    I got some "support" on this issue awhile back, but it didn't help. As a result I just imported all my calendar entries to Outlook and then exported them to a new PST. I then ran the import wizard and put in my new email in the "change organizer..." box and then ran the import. The only problems I had were that I had to manually edit a bunch of the entries that weren't imported correctly.

  6. #6
    Join Date
    May 2006
    Posts
    196
    Rep Power
    9

    Default

    Hi,

    I just fixed it by edditing all appointments, not that many anyway.

    The intersting part is that nothing Zimbra related changed at all, only the windows domain and user, but I still login the same way to Zimbra as before. And no one else here has the same problem.

    Thanks

    Christian

  7. #7
    Join Date
    Jan 2007
    Posts
    66
    Rep Power
    8

    Default

    That change is exactly why the problem occurred though. When you change either of those things Zimbra doesn't do it's homework and check all places where it's put the username/domain/both to change it. Thus when you change any of these your old information persists in those appointments, making them invalid.

  8. #8
    Join Date
    May 2006
    Posts
    196
    Rep Power
    9

    Default

    Mhh, not nice.
    But thanks anyway.

    I have another problem that might have the same reason. Perhaps you can have a look here: http://www.zimbra.com/forums/outlook-connector/11259-syncing-2-outlooks-does-not-work-correctly.html

    Thanks

    Christian

  9. #9
    Join Date
    Feb 2006
    Location
    France (Haute-Savoie)
    Posts
    123
    Rep Power
    9

    Default

    I have the same problem, but without having changed the domain/username.

    A user tried to synchronize his Zimbra account onto his HP iPaq 6915, but it syncs only the appointments created after the first sync.

    Probable reason : my user synced before changing the date on his PDA, so I suppose that Zimbra Mobile had problem as the iPaq's date was far away from the actual date on the Zimbra server.

    Any idea ?

    Is there a CLI command that can do something like a "touch" onto all appointments of the calendar ?

    Another way could be to flush all cache information into Zimbra Mobile for this account, is there any way to do so ?

  10. #10
    Join Date
    Feb 2006
    Location
    France (Haute-Savoie)
    Posts
    123
    Rep Power
    9

    Default

    Sorry,

    I didn't see that I was in the Outlook connector's forum.
    We don't use Outlook, only the web client, but the error is quite identical.

Similar Threads

  1. Syncing Zimbra with Google Calendar
    By tubby_bartles in forum Administrators
    Replies: 39
    Last Post: 12-14-2009, 05:11 PM
  2. ZCS 4.5.4 Mobile - No Multiple Calendar Sync?
    By dlbewley in forum Zimbra Mobile
    Replies: 9
    Last Post: 07-08-2007, 09:13 PM
  3. Outlook/Zimbra Private Appointments Issue
    By Smurthey in forum Zimbra Connector for Outlook
    Replies: 0
    Last Post: 03-09-2007, 06:29 AM
  4. Calendar Use Case
    By enthenergy in forum Administrators
    Replies: 2
    Last Post: 12-01-2006, 05:16 PM
  5. M2 Experiences?
    By jordandeamattson in forum Users
    Replies: 17
    Last Post: 11-22-2005, 02:32 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •