Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19

Thread: Outlook calendar only syncs one way

  1. #11
    Join Date
    Mar 2008
    Location
    Sioux Falls
    Posts
    150
    Rep Power
    7

    Default

    Quote Originally Posted by centrex View Post
    Thanks for the tip.

    I did a repair and also a full remove/reinstall of Outlook and the user profiles but it did not help.
    I am having my user try this as well. Hope fully it gets fixed
    Eric J Lynner
    Dynamic Business Solutions

    “Computers are good at following instructions, but not at reading your mind.”
    – Donald Knuth

  2. #12
    Join Date
    Jul 2008
    Posts
    12
    Rep Power
    7

    Default Outlook 2003 1-way synchronization

    Likewise, we're also suffering from the same problem. Appointments created on the Zimbra server will sync with Outlook, but appointments created in Outlook will not sync with the Zimbra server.

    It's be really nice to get an updated Outlook connector, but I suspect this bug is quite far down the list. See list

    Outlook 2003 SP3
    Zimbra Server 5.0.8_GA_2458
    Zimbra Connector for Outlook 5.0.2662.8

  3. #13
    Join Date
    Sep 2006
    Posts
    1,334
    Rep Power
    11

    Default No syncing from Outlook to Zimbra

    I would like to see some logs for this. I think there's a good chance there is some bad data, and we try to sync to Zimbra, something is dying and causing the sync to fail. I'm not positive, but that is my best guess. Please do the following:

    1) Exit Outlook if it is running

    2) Enable ZCO logging (Enable logging and Http Logging boxes. No need for verbose logging).

    3) Make sure there is something to sync from Outlook to Zimbra, and do a sync.

    4) Shut down Outlook

    5) Post the logs

    This bug is not "at the bottom of the list" -- it's very important. We have done and are doing things to prevent it, and to rectify things if it does happen.

    Thanks

  4. #14
    Join Date
    Jul 2008
    Posts
    12
    Rep Power
    7

    Red face Outlook 2003 logs

    Hi fsiegel
    I'm really sorry - I didn't mean to cause offence. Zimbra's a big project & I know you guys are working hard on it.

    I've attached the 2 requested log files (with my email address edited) for you to take a look at. I do hope something can be gleamed from it.

    Many, many thanks.
    Attached Files Attached Files

  5. #15
    Join Date
    Sep 2006
    Posts
    1,334
    Rep Power
    11

    Default Outlook calendar only syncs one way

    No offense taken -- your statement was reasonable enough.

    I looked at the logs -- did you have anything that was supposed to sync up to the server? I saw no evidence of us recognizing any Outlook change at all. [Also, there were no syncs from the server to Outlook, but I only asked you to sync going up, so I assume that's ok.]

    So for this run where I got the logs, what did you do in Outlook that was supposed to sync to the server?

    Thanks

  6. #16
    Join Date
    Jul 2008
    Posts
    12
    Rep Power
    7

    Default Outlook ZCO logs

    I did two things that I'd hoped would have caused a sync:
    1. I moved a calendar appointment from one day to another.
    2. I also created a brand new appointment.

    I've attached new logs having redone the troubleshooting steps as follows :
    1. Created an appointment within the Outlook calendar.
    2. Created an appointment on the Zimbra server.
    Both appointments appear on the Outlook calendar, but only the Zimbra created one appears on the Zimbra server calendar.
    There are no entries within the Sync Issues folder within Outlook (Conflicts, Local Failures or Server Failures).

    Could the problem be that we're using our own form (created within Outlook 2003) to post & view our appointments? The form uses standard Outlook fields, but the layout of the form is different from the default IPM.Appointment form that comes as standard with Outlook.

    Do post back if more info's needed & many thanks again for your help.


    Outlook 2003 (11.8206.8172) SP3
    Zimbra Server 5.0.8_GA_2458
    Zimbra Connector for Outlook 5.0.2662.8
    Attached Files Attached Files
    Last edited by dodghz; 10-08-2008 at 04:21 AM. Reason: File attachment, further info

  7. #17
    Join Date
    Sep 2006
    Posts
    1,334
    Rep Power
    11

    Default Outlook only syncs one way

    Yeah -- the custom form is a problem -- we don't support them. I see no change records at all being generated -- it's as if you never did anything in Outlook. Is your custom form just for appointments? As a test, either remove the custom form and create an appt, or try to add something like a contact or a task, or something that you don't have any custom form for. I'm assuming that will work.

    Or even just reading an email message -- that will update the status from unread to read, and then that should show up in the Zimbra Web client. If that works, then we are syncing properly.

  8. #18
    Join Date
    Jul 2008
    Posts
    12
    Rep Power
    7

    Thumbs up Solved

    Eugh - It was the custom form that was causing the problem for us. So obvious, but I just never thought to test it.

    Our custom form is used for appointments (it's used to record mileage & expenses) & the calendar is exported to a database once per month for reporting purposes.

    I'll be able to do the same thing via the standard ipm.appointment form & its 'Description field'. The database can do a bit of parsing to separate out the required details from the Description field.

    Many thanks for the help. I'll go lie down now... maybe have a bit of a cry... then break open a celebratory beer.
    - - - - - - - - - - - - - - - - - - - -
    Outlook 2003 (11.8206.8172) SP3
    Zimbra Server 5.0.8_GA_2458
    Zimbra Connector for Outlook 5.0.2662.8

  9. #19
    Join Date
    Sep 2006
    Posts
    1,334
    Rep Power
    11

    Default Giterror

    I have seen a number of posts now, where people get the error:

    GITERROR! Failed to get OOM helper instance

    Usually, before that, the log error is:

    GITERROR! Could not create an instance of outlook, hr: 0x8002801d

    We have finally tracked down the reason for this.

    The error means that a type library is not registered. Before, we would tell people to repair or re-install Outlook. This never did any good.

    I have only seen this happen with Outlook 2003. Specifically, it happens when a machine had Outlook 2007 installed previously, it was uninstalled, and Outlook 2003 was then installed. What happens is that the 2007 uninstall leaves some registry entries around that cause this error to happen. I'm not completely certain if this was caused only by a trial version, or if any Office 2007 uninstall causes this. The fix is relatively simple:

    Control Panel-> Add or Remove Programs
    Click on Microsoft Office 2007 Primary Interop Assemblies Remove

    The GITError should go away.

    I have also posted this on the Zimbra Connector for BlackBerry forum.

Similar Threads

  1. Shared Calendar Attendees Disappear In Outlook
    By @dmin in forum Zimbra Connector for Outlook
    Replies: 2
    Last Post: 11-06-2007, 11:07 AM
  2. Outlook/Zimbra Private Appointments Issue
    By Smurthey in forum Zimbra Connector for Outlook
    Replies: 0
    Last Post: 03-09-2007, 07:29 AM
  3. Issues with Outlook Calendar Migration - ics
    By soxfan in forum Migration
    Replies: 2
    Last Post: 02-28-2007, 06:50 PM
  4. Outlook connector sync fails for shared calendar -- release 4.03GA
    By nyamada in forum Zimbra Connector for Outlook
    Replies: 13
    Last Post: 11-21-2006, 02:16 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •