Results 1 to 5 of 5

Thread: Office Customization Tool PRF file

  1. #1
    Join Date
    Nov 2007
    Posts
    23
    Rep Power
    8

    Default Office Customization Tool PRF file

    We're using ZCS Connector 5.0.1 with Outlook 2007 SP1. To customize an Office installation, you use the Office Customization Tool (OCT), started with the command, "setup /admin". The OCT has the ability to use an Outlook PRF text file, which defines the profile you want Outlook to use. The OCT assumes you created this PRF in an earlier version of Outlook or Exchange, and it doesn't describe the PRF file specification.

    Obviously, I'd like to point to our Zimbra profile with a PRF. Does anyone have a PRF file for Zimbra? If so, could you post it here, so everyone could see it?

    Thanks. Sande

  2. #2
    Join Date
    Nov 2007
    Posts
    23
    Rep Power
    8

    Default

    No postings, huh? I can't believe that no one else has ever created a PRF for Zimbra. It would solve so many ZCS Connector installation problems, especially for multiple users (different userprofiles) on a shared computer.

    It would also be useful for the quick delete/recreate you have to do to fix mail profile problems. About 80% of the installations I'm seeing are failing in some aspect, and the fix in every case is to recreate the mail profile, and let it create a new zimbra*.zdb cache.

    If anyone has a PRF file that's working, please let me see it. Sande

  3. #3
    Join Date
    Aug 2005
    Posts
    821
    Rep Power
    11

    Default

    Sounds like PRF's aren't being used by anyone yet. There are a couple things built in the ZCO connector that may help you:

    KEY: \\HKCU\Software\Zimbra\ZimbraServerName
    TYPE: REG_SZ
    DESCR: default server name when a new profile is created

    KEY: \\HKCU\Software\Zimbra\ZimbraServerPort
    TYPE: REG_DWORD
    DESCR: server port to connect to (ie, 80 or 443 decimal)

    KEY: \\HKCU\Software\Zimbra\ZimbraConnectionMethod
    TYPE: REG_DWORD
    DESCR: 1 for secure connection (SSL) 0 for clear (NO SSL)

    When a new profile is created, the values above are used as the defaults. The logged in users username is the default username. The goal is that when a profile is created by a script, if the the settings above are configured correctly, once the user launches outlook all they need to enter is their zimbra password.

    For 5.0 server/clients, we have an unsupported command line tool that can create the profiles for you (CreateZimbraProfile.exe). Would that help with what you're doing?
    Sam Khavari

    :: :: [ Zimbra ] :: :: [ Bugzilla ] :: :: [ Product Portal ] :: :: [ Wiki ] :: :: [ Downloads ] :: :: [ . ] ::

  4. #4
    Join Date
    Nov 2007
    Posts
    23
    Rep Power
    8

    Default

    Thanks for the fast response, sam. I tried those registry keys with ZCS Connector versions 5.0 and 5.0.1 and they did nothing. (Specifically, they were not used in the creation of new profiles, in my testing.) Are they fixed in 5.0.2?

    I would love to try CreateZimbraProfile.exe, even if it is unsupported. I'll try anything that will make profile creation less problematic. Sande

  5. #5
    Join Date
    Aug 2005
    Posts
    821
    Rep Power
    11

    Default

    1. configure the registry keys
    2. control panel -> mail ->show profiles -> add
    3. give the profile a name
    4. check "Manully configure server settings..."
    5. select 'other' then "Zimbra Collaboration Server"
    6. default values should appear.


    I've attached 'CreateZimbraProfile.exe' as a zip file to this post. For information about how to use it, see this:

    CreateZimbraProfile - Zimbra :: Wiki
    Attached Files Attached Files
    Sam Khavari

    :: :: [ Zimbra ] :: :: [ Bugzilla ] :: :: [ Product Portal ] :: :: [ Wiki ] :: :: [ Downloads ] :: :: [ . ] ::

Similar Threads

  1. centos 5 zimbra 4.5.6 no statistics
    By rutman286 in forum Installation
    Replies: 9
    Last Post: 08-14-2007, 10:30 AM
  2. Opensource backup Question.
    By nfear24 in forum Administrators
    Replies: 3
    Last Post: 04-01-2007, 12:47 AM
  3. Traslation SVN tree status
    By meikka in forum I18N/L10N - Translations
    Replies: 7
    Last Post: 02-13-2007, 11:13 AM
  4. M3 problem with shares
    By titangears in forum Users
    Replies: 4
    Last Post: 01-12-2006, 01:01 PM
  5. antispam not working?
    By moebis in forum Installation
    Replies: 16
    Last Post: 12-03-2005, 08:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •