Results 1 to 7 of 7

Thread: [SOLVED] Which do we Upgrade First, Zimbra, or the Connector?

  1. #1
    Join Date
    Oct 2007
    Posts
    10
    Rep Power
    8

    Default [SOLVED] Which do we Upgrade First, Zimbra, or the Connector?

    Hey folks,

    We have a dilemma, and need a sure-fire answer. We are upgrading our Zimbra Server within the next week or so, and from the upgrade documentation are unsure as to which to upgrade first to keep the users from having issues.

    Do we upgrade the Outlook Connectors, before or after we upgrade Zimbra?

    I have a quote below from my colleague. He posted it in the "Installation" forum, but I thought we might get a good response from the Outlook Connector thread as well.

    We are currently running 4.5.7_GA_1319.RHEL5_64 on CentOS 5.0 (64bit) and I want to do the upgrade to 5.02. We are currently running a BETA version of the Outlook Connector, 5.0.

    Thanks in advance for you thoughts on this...

    Kindest Regards,

    DarkDune

    Quote Originally Posted by systemgeek View Post
    I am currently running 4.5.7_GA_1319.RHEL5_64 on CentOS 5.0 (64bit) and I want to do the upgrade to 5.02. Reading the upgrade notes it states clearly that I cannot install the new connectors on machines connecting to the old (4.5.7) version of Zimbra. So I have to infer that I do the Zimbra upgrade to 5.02 and then I can upgrade the connectors latter?

    Is this correct? Will the older connectors for 4.5.7 work with 5.02 at least long enough for me to run around upgrading people?

    My client base is 90% Windows Vista and we are actually running a Beta version of the 5.0 connector because the 4.5.7 version did not support Vista. I have one user (the company president) running connector 4.5.7 because he is on WinXP. The rest of my users are running MACs and using MacMail, no zimbra connector.

    Thanks,
    Louis

  2. #2
    Join Date
    Apr 2007
    Location
    San Jose
    Posts
    406
    Rep Power
    8

    Default

    Quote Originally Posted by darkdune View Post
    Hey folks,

    We have a dilemma, and need a sure-fire answer. We are upgrading our Zimbra Server within the next week or so, and from the upgrade documentation are unsure as to which to upgrade first to keep the users from having issues.

    Do we upgrade the Outlook Connectors, before or after we upgrade Zimbra?

    I have a quote below from my colleague. He posted it in the "Installation" forum, but I thought we might get a good response from the Outlook Connector thread as well.

    We are currently running 4.5.7_GA_1319.RHEL5_64 on CentOS 5.0 (64bit) and I want to do the upgrade to 5.02. We are currently running a BETA version of the Outlook Connector, 5.0.

    Thanks in advance for you thoughts on this...

    Kindest Regards,

    DarkDune

    5.0.x connectors do not work with pre 5.0 servers. so you should probably upgrade the server first.

  3. #3
    Join Date
    Dec 2007
    Location
    California
    Posts
    105
    Rep Power
    7

    Default

    Quote Originally Posted by alee View Post
    5.0.x connectors do not work with pre 5.0 servers. so you should probably upgrade the server first.
    My understanding is that the servers are backwards compatible with all connectors, but the connectors are only backwards compatible with their own main releases (eg 5.02 connector will work will 5.01 server, but not 4.5 server).

  4. #4
    Join Date
    Apr 2007
    Location
    San Jose
    Posts
    406
    Rep Power
    8

    Default

    Quote Originally Posted by EnriqueI View Post
    My understanding is that the servers are backwards compatible with all connectors, but the connectors are only backwards compatible with their own main releases (eg 5.02 connector will work will 5.01 server, but not 4.5 server).
    in the case of 5.0.x connnectors..there were changes made so the connector will not even run if the server is less than 5.0

  5. #5
    Join Date
    Dec 2007
    Location
    California
    Posts
    105
    Rep Power
    7

    Default

    Quote Originally Posted by alee View Post
    in the case of 5.0.x connnectors..there were changes made so the connector will not even run if the server is less than 5.0
    Ok, that's what I thought... I seem to remember that I had a 5.02 connector running with a 5.01 server

  6. #6
    Join Date
    Sep 2007
    Posts
    37
    Rep Power
    8

    Default

    What about the case where you have a 4.5.x connector? Can that work alright for the functions that are in 4.5.x server when you upgrade to 5.0.x? I'm in a situation right now where I have an opportunity to upgrade the server but might face a few days until the workstations running the connector being upgraded.

    Thanks.

  7. #7
    Join Date
    Dec 2007
    Location
    California
    Posts
    105
    Rep Power
    7

    Default

    I'm sure I will be corrected if I am wrong, but I believe it will work.

Similar Threads

  1. /tmp filling
    By Nutz in forum Administrators
    Replies: 8
    Last Post: 02-22-2008, 02:00 AM
  2. zmperditionctl start asking for password
    By k7sle in forum Administrators
    Replies: 32
    Last Post: 02-20-2008, 11:13 AM
  3. zmtlsctl give LDAP error
    By sourcehound in forum Administrators
    Replies: 5
    Last Post: 03-11-2007, 04:48 PM
  4. zimbra-core missing
    By kinaole in forum Developers
    Replies: 1
    Last Post: 10-02-2006, 12:59 PM
  5. Unable to start tomcat
    By chanck in forum Administrators
    Replies: 11
    Last Post: 06-11-2006, 01:58 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •