Results 1 to 1 of 1

Thread: Calendar description charset sync problem

  1. #1
    Join Date
    May 2007
    Location
    Europe
    Posts
    48
    Rep Power
    10

    Default Calendar description charset sync problem

    Hi there!

    Our clients have calendar problems with Outlook 2007 in Zimbra NE 5.0.8 webUI.

    Ok right to the point. If I set up a new appointment with
    subject: test šđčćž ŠĐČƎ
    location: test šđčćž ŠĐČƎ
    description: test šđčćž ŠĐČƎ
    and sync to zimbra 5.0.8 NE, I can reopen appointment without problem.

    But the zimbra web client or ZCO mess up description "test šđčćž ŠĐČƎ"
    into "test ĹˇΔ‘ΔŤΔ‡Ĺľ Ĺ ΔΔŚΔ†Ĺ˝".


    The webclient SOAP response is:
    Code:
    Body: {
      GetMsgResponse: {
        _jsns: "urn:zimbraMail",
        m: [
          0: {
            d: 1216971852000,
            id: "5153-5152",
            inv: [
              0: {
                comp: [
                  0: {
                    alarm: [
                      0: {
                        action: "DISPLAY",
                        desc: [
                          0: {
                            _content: ""
                           }
                         ],
                        trigger: [
                          0: {
                            rel: [
                              0: {
                                m: 15,
                                neg: true,
                                related: "START"
                               }
                             ]
                           }
                         ]
                       }
                     ],
                    apptId: "5153",
                    calItemId: "5153",
                    class: "PUB",
                    compNum: 0,
                    d: 1216971852000,
                    desc: [
                      0: {
                        _content: "test ĹˇΔ‘ΔŤΔ‡Ĺľ Ĺ ΔΔŚΔ†Ĺ˝
    "
                       }
                     ],
                    e: [
                      0: {
                        d: "20080725T153000",
                        tz: "Central Europe Standard Time"
                       }
                     ],
                    fb: "B",
                    fba: "B",
                    fr: "test ĹˇΔ‘ΔŤΔ‡Ĺľ Ĺ ΔΔŚΔ†Ĺ˝",
                    isOrg: true,
                    loc: "test šđčćž ŠĐČƎ",
                    name: "test šđčćž ŠĐČƎ",
                    or: {
                      a: "admin@zimbra.ne",
                      url: "admin@zimbra.ne"
                     },
                    rsvp: false,
                    s: [
                      0: {
                        d: "20080725T133000",
                        tz: "Central Europe Standard Time"
                       }
                     ],
                    seq: 0,
                    status: "CONF",
                    transp: "O",
                    uid: 
    
    "040000008200E00074C5B7101A82E0080000000000536A033BEEC8010000000000000000100000001F23139F85390D44B34F10E6FE109A42
    
    ",
                    x_uid: 
    
    "040000008200E00074C5B7101A82E0080000000000536A033BEEC8010000000000000000100000001F23139F85390D44B34F10E6FE109A42
    
    "
                   }
                 ],
                replies: [
                  0: {}
                 ],
                type: "appt",
                tz: [
                  0: {
                    daylight: [
                      0: {
                        hour: 2,
                        min: 0,
                        mon: 3,
                        sec: 0,
                        week: -1,
                        wkday: 1
                       }
                     ],
                    dayoff: 120,
                    id: "Central Europe Standard Time",
                    standard: [
                      0: {
                        hour: 3,
                        min: 0,
                        mon: 10,
                        sec: 0,
                        week: -1,
                        wkday: 1
                       }
                     ],
                    stdoff: 60
                   }
                 ]
               }
             ],
            l: "10",
            mid: "<30469883.2591216971852051.JavaMail.root@portal>",
            mp: [
              0: {
                ct: "multipart/alternative",
                mp: [
                  0: {
                    ct: "text/plain",
                    part: "1",
                    s: 51
                   },
                  1: {
                    body: true,
                    content: "
    <HTML>
    <HEAD>
    
    
    <TITLE>test š&Auml;&lsquo;&Auml;Ť&Auml;&Dagger;Ĺľ Ĺ&nbsp;&Auml;&Auml;Ś&Auml;&dagger;Ĺ˝</TITLE>
    </HEAD>
    <BODY>
    <!-- Converted from text/rtf format -->
    
    <P dir="LTR"><SPAN lang="sl"><FONT face="Calibri">test š&Auml;&lsquo;&Auml;Ť&Auml;&Dagger;Ĺľ 
    
    Ĺ&nbsp;&Auml;&Auml;Ś&Auml;&dagger;Ĺ˝</FONT></SPAN></P>
    
    </BODY>
    </HTML>",
                    ct: "text/html",
                    part: "2",
                    s: 674
                   }
                 ],
                part: "TEXT",
                s: 2908
               }
             ],
            rev: 12027,
            s: 3434,
            su: "test šđčćž ŠĐČƎ"
           }
         ]
       }
     },
    Header: {
      context: {
        _jsns: "urn:zimbra",
        change: {
          token: 12027
         },
        sessionId: [
          0: {
            _content: "1230",
            id: "1230"
           }
         ]
       }
     },
    _jsns: "urn:zimbraSoap"
    If I reopen and save adding correct "test šđčćž ŠĐČƎ" after messed up line from webclient,
    Outlook will sync and show same description I just saved.
    Even if I open from another webclient, appointment will show same description.
    In attachment is log from Outlook07 saving this appointment.

    What is wrong? Is this a known problem and is it reported as bug?

    Regards
    Attached Files Attached Files

Similar Threads

  1. Replies: 13
    Last Post: 11-20-2008, 11:42 AM
  2. Hangs on "Loading" screen
    By gbr in forum General Questions
    Replies: 16
    Last Post: 06-19-2008, 01:01 PM
  3. 4 MACs one calendar and contact Sync issue
    By 3tpro in forum CalDAV / CardDAV / iSync
    Replies: 0
    Last Post: 05-24-2008, 09:06 AM
  4. zdesktop issue report (2008-05-22 17:25:42): mail.NO_SUCH_MSG
    By John Marsden, FH Ba in forum Error Reports
    Replies: 0
    Last Post: 05-23-2008, 02:49 AM
  5. [SOLVED] Upgraded to 5.0 OSS - Sendmail Problem
    By Chewie71 in forum Installation
    Replies: 11
    Last Post: 12-28-2007, 06:07 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •