Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: Outlook Connector and "Local Failure Notice"

  1. #1
    Join Date
    Dec 2006
    Location
    Minneapolis MN
    Posts
    777
    Rep Power
    9

    Default Outlook Connector and "Local Failure Notice"

    I have a user who is getting "Local Failure Notice" emails generated by the outlook connector, about 8-10 times a day

    The body of these emails has something like:

    id (56200) type(message) message(Convert() - mime to mapi conversion returned partial completion. hr = 263808)

    and there is a sync_message.mime attachment that contains the raw email.

    There are also several cases where they are seeing the raw email in the body of the message, including the full message headers, and because it's the raw email it can be very hard for them to read because HTML is not being converted to its pretty happy state.

    Has anyone seen this?

  2. #2
    Join Date
    Sep 2006
    Posts
    1,334
    Rep Power
    11

    Default

    In 5.0.10 we added the feature to create local failures instead of displaying bad MIME. There are some cases where the Outlook MIME converter can't handle the input. See bug 30282 for background.

    We then found that lots of local failure messages was somewhat annoying, so in 5.0.11, we fixed bug 32311. This will create just one local failure warning for these cases.

    The underlying cause, though, is a third party issue. Outlook can't handle the MIME.

  3. #3
    Join Date
    Apr 2008
    Location
    Milan
    Posts
    45
    Rep Power
    7

    Default

    Quote Originally Posted by fsiegel View Post
    The underlying cause, though, is a third party issue. Outlook can't handle the MIME.
    I'm running a domino server worldwide and zimbra as local mail server
    I've configured Lotus Notes access on imap on outlook
    and set an agent to forward all messages from domino to zimbra

    When I receive an invitation on domino I see:
    domino via imap
    invitation with lot of empty lines

    outlook same message forwarded from domino to zimbra
    X-Zimbra-ItemId: 52976
    X-Zimbra-FolderId: 2
    X-Zimbra-Tags:
    X-Zimbra-Flags: auv
    X-Zimbra-Received: 1227523886000
    X-Zimbra-Modified: 1227523886000
    X-Zimbra-Change: 113089
    X-Zimbra-Revision: 113089
    X-Zimbra-Conv: -52976
    Return-Path: alessio.tosi@okieurope.com
    Received: from posta.oki.it (LHLO posta.oki.it) (10.18.14.30) by posta.oki.it with LMTP; Mon, 24 Nov 2008 11:51:26 +0100 (CET)
    Received: from localhost (localhost [127.0.0.1])
    by posta.oki.it (Postfix) with ESMTP id 0749F540076
    for <atosi@oki.it>; Mon, 24 Nov 2008 11:51:26 +0100 (CET)
    X-Virus-Scanned: amavisd-new at oki-mail1.osi.lan
    X-Spam-Flag: NO
    X-Spam-Score: -3.463
    X-Spam-Level:
    X-Spam-Status: No, score=-3.463 tagged_above=-10 required=3 tests=[AWL=1.000,
    BAYES_00=-2.599, HTML_MESSAGE=0.001, MIME_QP_LONG_LINE=1.396,
    MPART_ALT_DIFF=0.739, RCVD_IN_DNSWL_MED=-4]


    and immediately after a local failure

    The meeting is then added automatically to my calendar but the user is not allowed to see the meeting details from the message

  4. #4
    Join Date
    Apr 2008
    Location
    Italy
    Posts
    33
    Rep Power
    7

    Default

    Hi all,

    I have a user who is getting "Local Failure Notice" emails generated by the outlook connector too.

    But after this Failure the user can't receive any e-mail until he doesn't restart the Client!

    Any idea /solution to avoid this?

    Thanks

    Elisa

  5. #5
    Join Date
    Sep 2006
    Posts
    1,334
    Rep Power
    11

    Default

    Please enable logging, try it again, and post the zco log for when this happens. Also, please send either a screen shot of the local failure message, or the .msg file.

  6. #6
    Join Date
    Apr 2008
    Location
    Italy
    Posts
    33
    Rep Power
    7

    Default

    Hi Fsiegel,

    This is the log:

    Local Failures were detected. No action is required.
    This e-mail was generated for technical support purposes.

    Sync Type: Delta Sync

    Sync Token (before request): 11800

    Sync Token (most current): 11801

    Store: Zimbra - xxxx@example.com

    Computer Name: xxxx

    Version: 5.0.2817.11

    Mime to mapi conversion:
    Warning 0: Convert() - mime to mapi conversion returned partial completion.
    hr = 263808 Body of this item maybe corrupted.


    I have attached the raw message.

    Thanks

    Elisa
    Attached Files Attached Files

  7. #7
    Join Date
    Sep 2006
    Posts
    1,334
    Rep Power
    11

    Default

    Hi Elisa. Well -- you sent me the local failure message and the MIME, not the log. That was helpful, but I still may need the actual zco log, which you get by running ZCOLogCtrl, and enabling ZCO logging (and http logging).

    Anyway, I tried injecting your mime directly into my Outlook in a local server. With Outlook 2007, this works fine, and there is no local failure. With Outlook 2003, there is a local failure, which means that Outlook 2003 can't handle the MIME, and there is really nothing we can do about that. But after that error, I was able to receive subsequent emails -- I had no other problems.

    I am interested in why this user cannot receive subsequent emails after this local failure. So please enable ZCO logging and http logging, and post the logs. [There is a wiki about enabling logging. You just run ZCOLogCtrl (in same directory as our dlls), and check the appropriate boxes).

    Or you can upgrade to Outlook 2007, and this problem wiill probably go away.

  8. #8
    Join Date
    Dec 2006
    Location
    Minneapolis MN
    Posts
    777
    Rep Power
    9

    Default

    For all who may find this thread in the future, Microsoft has a hotfix for this issue:

    Description of the Outlook 2003 hotfix package&#58; April 22, 2008

    This issue is exhibited when a message is sent to "undisclosed recipients ;" with Outlook 2003 on Vista.

  9. #9
    Join Date
    Jan 2011
    Posts
    4
    Rep Power
    4

    Default

    Our client have same problem with Outlook 2007:
    > -----Original Message-----
    > From: ...
    > Sent: Нет
    > To: ...
    > Subject: Local Failure Notice
    > Importance: High
    >
    > This
    > e-mail was generated for technical support purposes.
    >
    > Sync Type:
    > Delta Sync
    >
    > Sync Token (before request): 17850
    >
    > Sync Token
    > (most current): 17850
    >
    > Store: Zimbra - ...
    > Computer Name: TS
    >
    > ZCO Version: 6.0.6058.8
    >
    > Server Version:
    > 6.0.9_GA_2686
    >
    > Error IDs:
    > id (9447) type(message)

  10. #10
    Join Date
    Sep 2006
    Posts
    1,334
    Rep Power
    11

    Default

    There should be some attachments along with the message that would provide more information.

Similar Threads

  1. Installation zimbra Initializing ldap...failed. (28416)
    By farrukh.nadeem in forum Installation
    Replies: 10
    Last Post: 08-14-2009, 07:52 AM
  2. Zimbra Outlook Connector License Failure
    By playnada in forum Zimbra Connector for Outlook
    Replies: 6
    Last Post: 01-12-2009, 03:31 PM
  3. Replies: 8
    Last Post: 10-19-2008, 10:52 AM
  4. Replies: 4
    Last Post: 08-04-2008, 07:17 PM
  5. Outlook Global Address book failure
    By rojs in forum Zimbra Connector for Outlook
    Replies: 2
    Last Post: 03-30-2007, 03:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •