Results 1 to 4 of 4

Thread: ZCO against which Zimbra server: compatibility?

Hybrid View

  1. #1
    Join Date
    Nov 2008
    Posts
    4
    Rep Power
    6

    Default ZCO against which Zimbra server: compatibility?

    Is there a compatibility matrix for the ZCO and the Zimbra Network Edition server?

    For example, can/should we update the ZCO independent of the server?

    We're running ZNE 5.0.13_GA_2791.

    So, must we use the ZCO downloadable from the server over https:7071? Or can they update to a newer version of ZCO? E.g. the one available at:

    http://files.zimbra.com/downloads/5.....0.2990.16.msi


    (We'll update to ZNE 5.0.16 soon, and I guess we could update to the ZCO from that version...)

    The general question is: are the ZCO and the ZNE server considered independent?


    Thanks!

  2. #2
    Join Date
    Sep 2006
    Posts
    1,334
    Rep Power
    11

    Default

    They're not independent. We generally say that you should upgrade your server first, and then ZCO. We want older ZCOs to work with newer servers. A lot of times, you can get away with upgrading ZCO first (having a later ZCO version than the server), but we don't recommend it. In certain versions (5.0.7 for one), some things would break if you updated ZCO first. But lately, you can probably get away with it.

    But if you want the party line -- upgrade the server first.

  3. #3
    Join Date
    Jan 2007
    Location
    Minnesota
    Posts
    719
    Rep Power
    9

    Default

    I thought the party line used to be the reverse (with the exception of 5.0.7).

    5.0.16 server stores calendar items without blobs. Doesn't that require you to update ZCOs to 5.0.16 first?

  4. #4
    Join Date
    Sep 2006
    Posts
    1,334
    Rep Power
    11

    Default

    Generally we say to update the server first. Here's an old post on that:

    http://www.zimbra.com/forums/zimbra-...-versions.html

    As far as the blob thing goes in 5.0.16, the server guys put in some backward compatibility for that, so it should work either way. If it doesn't then it's a bug.

Similar Threads

  1. /tmp filling
    By Nutz in forum Administrators
    Replies: 8
    Last Post: 02-22-2008, 01:00 AM
  2. Big Fubar on 5 FOSS GA Upgrade
    By uxbod in forum Administrators
    Replies: 24
    Last Post: 01-21-2008, 02:37 AM
  3. Major Issue - 5.0RC2 NE to 5.0GA NE failed
    By DougWare in forum Installation
    Replies: 7
    Last Post: 01-06-2008, 08:56 PM
  4. Replies: 31
    Last Post: 12-15-2007, 08:05 PM
  5. Replies: 8
    Last Post: 02-27-2007, 03:10 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •