Results 1 to 4 of 4

Thread: Activesync only works in one direction

Hybrid View

  1. #1
    Join Date
    Apr 2006
    Posts
    17
    Rep Power
    9

    Default Activesync only works in one direction

    On an XP box with Activesync 4.1, Outlook 2003 SP2+all current patches, Win Mobile 2003, for all intents and purposes you can only sync the calendar out from Zimbra, not in from PDA. It's interesting, in that it will sync a single appointment or change from the PDA, but if there has been more than one change/add/delete on the pda, the remaining items will come back unresolved from Activesync w/ error 80180E01. This is with Outlook closed. If you sync with Outlook open, and are unfortunate enough that Activesync actually works, you get the new items on your calendar, but Outlook crashes the next time it tries to sync with Zimbra. Reopening outlook results in continuous crashes of Outlook upon the sync with Zimbra. The only solution is to delete the MAPI profile and start over, which leads you back to the top of this email, and back down the same destructive path. I have done a hard reset on the PDA, and tested on multiple xp boxes (including a clean XP install) with the same result, so I know it's not something special with my machines. I tried to use the sysinternals debug logger, but I don't get any messages. Any help or suggestions would be greatly appreciated.

  2. #2
    Join Date
    Apr 2006
    Posts
    12
    Rep Power
    9

    Default ActiveSync in Beta

    ActiveSync Windows Mobile 5 support for Zimbra is in beta. If you obtain the official document on Windows Mobile 5 support from Zimbra they detail the limited functionality.

    Im not aware of when the GA release for WM5 is out, but im looking forward to it.

  3. #3
    Join Date
    Apr 2006
    Posts
    17
    Rep Power
    9

    Default Fixed (I think)

    We have it working for the most part, although it took a bit of work and an update. I'm not sure which of the following was the ultimate solution, but our end result was to:

    1. Enter all the appointments into Zimbra manually, and hard reset the PDA
    2. Upgrade from 3.1.0 to 3.1.1, and install the latest OL Connector
    3. Reopen Outlook and log in to Zimbra. Send/Receive.
    4. Attach PDA and sync (all syncs properly.)
    5. Make sure that Outlook is open when doing any new syncs, and all seems to work.

    If you try to sync with Outlook closed and have made changes on the PDA, you still get unresolved items (if there has been more than one item changed on the PDA.) Opening Outlook, then syncing syncs all items, an no longer kills Outlook. I can only assume that one of the fixes in 3.1.1 resolved the crashing issue. All appears to be fine now. I'm not sure that the purge of the PDA is required, or the entry of the appts in Zimbra, as the primary original problem was the unresolved items. I am just including this info because these are the steps we followed.

    FYI, we have no problems syncing Palm devices - they work great! The only glitch is in Category names on the Palm. The sync actually creates tags in Zimbra for every category on the Palm. If the Palm has a category name with a "/" in it, Hotsync errors out and says that the name is invalid. Changing the category name fixes the problem. I am not sure if this is a Hotsync issue or a Zimbra issue, but thought I'd let everyone know.

  4. #4
    Join Date
    Aug 2005
    Posts
    821
    Rep Power
    11

    Default

    '/' is an invalid character for a tag name. the connector will prevent hotsync from applying a category with a '/' in it.
    Sam Khavari

    :: :: [ Zimbra ] :: :: [ Bugzilla ] :: :: [ Product Portal ] :: :: [ Wiki ] :: :: [ Downloads ] :: :: [ . ] ::

Similar Threads

  1. Sync with Palm Treo 700w with ActiveSync
    By jonnyRo in forum Zimbra Mobile
    Replies: 5
    Last Post: 01-05-2007, 04:39 PM
  2. Replies: 6
    Last Post: 11-18-2006, 12:42 PM
  3. ActiveSync Scheduling Error
    By bted in forum Zimbra Mobile
    Replies: 3
    Last Post: 11-09-2006, 09:00 PM
  4. Activesync w/ Outlook Connector Kills Outlook
    By jnetman1 in forum Administrators
    Replies: 4
    Last Post: 04-27-2006, 12:58 PM
  5. Works on 80, but not 8080
    By murtada in forum Administrators
    Replies: 4
    Last Post: 02-04-2006, 12:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •