Results 1 to 10 of 10

Thread: [SOLVED] Zimbra 6.0.1 GA integration with Outlook 2007

  1. #1
    Join Date
    Oct 2009
    Posts
    15
    Rep Power
    6

    Default [SOLVED] Zimbra 6.0.1 GA integration with Outlook 2007

    Hello,

    I am testing a network edition of Zimbra system + ZCO plugin. I plan to purchase it (instead of expensive MS Exchange) and hope
    that it will satisfy the needs of my organization. Although the web interface of Zimbra is awesome
    most of my colleagues will continue using Outlook 2007.

    I have a few questions/problems with Zimbra & Outlook 2007 integration -

    1. How can I create a global address book available in read only mode to all and editable by a very limited group of people?

    2. When I try to assign a task to someone Outlook throws the following error -
    "You don't have appropriate permission to perform this operation".

    3. Free/Busy information is not available in the scheduling pane of the Outlook Calendar.

    If you could help me with the above problems I will be very grateful.

    Igal.

  2. #2
    Join Date
    Sep 2006
    Posts
    1,334
    Rep Power
    11

    Default

    1) I would think GAL permissions is a server thing. We don't do anything with GAL permissions in ZCO.

    2) How are you assigning the task? I know Task Requests are not yet supported (bug 11497). But you get a different error message than the one you specify when you try to do a new Task Request.

    3) This is supposed to work. I'll look into this.

  3. #3
    Join Date
    Sep 2006
    Posts
    1,334
    Rep Power
    11

    Default

    What does it say in Search Locayion when you go into Outlook and do:

    Tools->Options
    Then hit Calendar Options button
    Then hit Free/Busy Options button?

  4. #4
    Join Date
    Sep 2009
    Posts
    24
    Rep Power
    6

    Default

    I am also having the same issue with Zimbra 6.0.1 and Outlook 2007 on Windows XP and Windows Vista. My free/busy search URL is as follows.

    http://zimbrahost/service/pubc/freeb...name%@%server%

    Can you provide some feedback on this.

  5. #5
    Join Date
    Sep 2006
    Posts
    1,334
    Rep Power
    11

    Default

    Can you take the freebusy URL, paste it in a browser, and download the file? If so, does it look correct?

    If that's ok, what is the value for Read URLin the registry key:

    HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\O utlook\Options\Calendar\Internet Free/Busy

    If that's ok, is it possible you had another freebusy provider installed? What is the value for SMTP in the registry key:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\12.0\ Outlook\SchedulingInformation\FreeBusySupport

  6. #6
    Join Date
    Oct 2009
    Posts
    15
    Rep Power
    6

    Default [solved]

    Hi,

    The problem has been solved. The reason for the problem was that I enabled encrypted connection and had a self signed SSL certificate.

    Thanks!

  7. #7
    Join Date
    Sep 2006
    Posts
    1,334
    Rep Power
    11

    Default

    That's it? Doesn't look like it has any info in there at all

  8. #8
    Join Date
    Sep 2009
    Posts
    24
    Rep Power
    6

    Default

    This is not the case for me. Am not using SSL and am still not able to see free/busy data.

    Downloaded Free/Busy the file looks fine.

    Read URLin the registry key: http://server/service/pubcal/freebusy.ifb?acct=%name%@%server% <--- replace actual hostname here with server not to expose host.

    value for SMTP in the registry key: {DCEDFCBF-C7D1-4B81-A20F-7524D306135E}

  9. #9
    Join Date
    Sep 2006
    Posts
    1,334
    Rep Power
    11

    Default

    {DCEDFCBF-C7D1-4B81-A20F-7524D306135E} is your value for SMTP for the registry key:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\12.0\ Outlook\SchedulingInformation\FreeBusySupport ??

    Did you have the "Microsoft Outlook Connector" installed at one point, or do you have it installed now? Then it's using that freebusy provider, and that's why you can't see your info.

    Try replacing that SMTP value with

    {0006F049-0000-0000-C000-000000000046}

  10. #10
    Join Date
    Sep 2009
    Posts
    24
    Rep Power
    6

    Default

    Setting the SMTP value to {0006F049-0000-0000-C000-000000000046} fixes the problem.

    Thank you

Similar Threads

  1. Zimbra + Funambol Sync4j Code
    By KevinH in forum Mobility
    Replies: 563
    Last Post: 01-16-2010, 02:20 AM
  2. Big Fubar on 5 FOSS GA Upgrade
    By uxbod in forum Administrators
    Replies: 24
    Last Post: 01-21-2008, 03:37 AM
  3. Major Issue - 5.0RC2 NE to 5.0GA NE failed
    By DougWare in forum Installation
    Replies: 7
    Last Post: 01-06-2008, 09:56 PM
  4. Replies: 22
    Last Post: 12-02-2007, 05:05 PM
  5. [SOLVED] Simple backup question...
    By dameron in forum Administrators
    Replies: 3
    Last Post: 08-25-2007, 10:36 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •