Page 53 of 61 FirstFirst ... 3435152535455 ... LastLast
Results 521 to 530 of 601

Thread: Outlook sync client

  1. #521
    Join Date
    Aug 2008
    Location
    St Pete FL USA
    Posts
    392
    Rep Power
    7

    Default

    That did fix it, yes. I'm going to update the wiki, as it's counterintuitive to assume that you should do something that's going to stomp databases while the system's running, IMHO.
    Jay R. Ashworth - ZCS 6.0.9CE/CentOS5 - St Pete FL US - Music - Blog - Photography - IANAL - IAAMA
    Try to Ask Questions The Smart Way -- you'll get better answers.

    Put your product and version in your profile/signature - All opinions strictly my own, even though I have an employer these days.
    If you [SOLVE] something, please tell everyone how for the archives
    And, please... read what people write, and answer the questions they asked, not the ones they didn't.

  2. #522
    Join Date
    May 2009
    Posts
    134
    Rep Power
    6

    Default Zimbra Connector and PostgreSQL or MySQL

    Hello, all. We're having very good success using Zimbra 5.0.18 and Funambol 8.0.1 to sync our BlackBerries. However, as part of our upgrade to Funambol 8.0.2, we decided to move the database to PostgreSQL on an internal server protected with SSL. We were delighted to finally figure out how to make that work until it came time to install the Zimbra Connector. The installation went flawlessly but the Zimbra connector did not appear in the Funambol administrator.

    We then spied a thread which said the Zimbra Connector only supported Hypersonic, MySQL, and Oracle so we moved the database to MySQL. Unfortunately, the same thing - the Zimbra Connector does not appear in the administration utility.

    Once we reverted to a local Hypersonic database (which we do not want to do as this device is on our DMZ), the Zimbra Connector configuration appeared.

    How must one configure the Zimbra Connector in order to use PostgreSQL or MySQL? Thanks - John
    www.spiritualoutreach.com
    Making Christianity intelligible to secular society

  3. #523
    Join Date
    Oct 2007
    Location
    South Africa
    Posts
    22
    Rep Power
    8

    Default

    Hi guys,

    Im running Funambol 8.0.2, Zimbra 6.0.1, CentOS 5.3
    Im using latest ZimbraConnector_0.6.02

    I have configured using instructions from
    Open Source Mobile Calendar and Contact Synchronization - Zimbra :: Wiki

    and followed the advice regarding Java versions in this post.


    As soon as I delete the cal, event etc events from foundation I start seeing these errors. Is this something critical and how do I fix it?

    13 Nov 2009 13:31 [DEBUG] Unable to load 'com.funambol.framework.engine.transformer.DataTra nsformerManagerBeanInfo' from remote server: http://zimbramail.dcdata.co.za:8080/...anagerBeanInfo
    13 Nov 2009 13:31 [DEBUG] Loading org.netbeans.beaninfo.DataTransformerManagerBeanIn fo, (true)
    13 Nov 2009 13:31 [DEBUG] Loading from: http://zimbramail.dcdata.co.za:8080/...anagerBeanInfo
    13 Nov 2009 13:31 [DEBUG] Unable to load 'org.netbeans.beaninfo.DataTransformerManagerBeanI nfo' from remote server: http://zimbramail.dcdata.co.za:8080/...anagerBeanInfo
    13 Nov 2009 13:31 [DEBUG] Loading java.util.HashMapBeanInfo, (true)
    13 Nov 2009 13:31 [DEBUG] Loading from: http://zimbramail.dcdata.co.za:8080/...ashMapBeanInfo
    13 Nov 2009 13:31 [DEBUG] Unable to load 'java.util.HashMapBeanInfo' from remote server: http://zimbramail.dcdata.co.za:8080/...ashMapBeanInfo
    13 Nov 2009 13:31 [DEBUG] Loading org.netbeans.beaninfo.HashMapBeanInfo, (true)
    13 Nov 2009 13:31 [DEBUG] Loading from: http://zimbramail.dcdata.co.za:8080/...ashMapBeanInfo
    13 Nov 2009 13:31 [DEBUG] Unable to load 'org.netbeans.beaninfo.HashMapBeanInfo' from remote server: http://zimbramail.dcdata.co.za:8080/...ashMapBeanInfo
    13 Nov 2009 13:31 [DEBUG] Loading java.util.AbstractMapBeanInfo, (true)
    13 Nov 2009 13:31 [DEBUG] Loading from: http://zimbramail.dcdata.co.za:8080/...actMapBeanInfo
    13 Nov 2009 13:31 [DEBUG] Unable to load 'java.util.AbstractMapBeanInfo' from remote server: http://zimbramail.dcdata.co.za:8080/...actMapBeanInfo
    13 Nov 2009 13:31 [DEBUG] Loading org.netbeans.beaninfo.AbstractMapBeanInfo, (true)
    13 Nov 2009 13:31 [DEBUG] Loading from: http://zimbramail.dcdata.co.za:8080/...actMapBeanInfo
    13 Nov 2009 13:31 [DEBUG] Unable to load 'org.netbeans.beaninfo.AbstractMapBeanInfo' from remote server: http://zimbramail.dcdata.co.za:8080/...actMapBeanInfo
    13 Nov 2009 13:31 [INFO] SyncSource correctly deleted

  4. #524
    Join Date
    May 2009
    Posts
    134
    Rep Power
    6

    Default

    Hello, all. In reference to my previous post, has anyone gotten the Zimbra connector in any version to use an external database (PostgreSQL, MySQL) rather than the internal HyperSonic database? Thanks - John
    www.spiritualoutreach.com
    Making Christianity intelligible to secular society

  5. #525
    Join Date
    Aug 2007
    Posts
    6
    Rep Power
    8

    Default .

    My apologies if this has been answered. I searched the thread and web using Google and saw no mentions of my error.

    I am having trouble getting this synced using Zimbra 5.0.19 and Funambol Outlook Connector 8.0.5. I downloaded the ZimbraConnector.s4j linked earlier in the thread. I followed the instructions here: Open Source Mobile Calendar and Contact Synchronization - Zimbra :: Wiki

    I've triple checked my settings and am totally clueless at this point. I posted a log at the bottom from an attempt to sync just the contacts.

    The error I get is "Can't recognize remote name. Correct remote name in Sync Options." The remote name in the settings matches the names created in the FunambolAdmin under the ZimbraConnector.
    Code:
    2009-12-03 15:28:52 GMT -6:00 - # Funambol Outlook Sync Client v. 8.0.5 - LOG file
    
    15:28:52 GMT -6:00 [DEBUG] - Starting the Sync process...
    15:28:52 GMT -6:00 [DEBUG] - Set a lower priority to the process
    15:28:52 GMT -6:00 [DEBUG] - Set listeners
    15:28:52 GMT -6:00 [DEBUG] - Creating SyncSources...
    15:28:52 GMT -6:00 [DEBUG] - Creating the sync-mutex ("fol-SyncInProgress-1259875732")
    15:28:52 GMT -6:00 [DEBUG] - Start SyncClient::Sync() with 1 sources
    15:28:52 GMT -6:00 [INFO] - 
     ************************** BEGIN of Synchronization session **************************
    15:28:52 GMT -6:00 [DEBUG] - Synchronization URL: http://funambol:8080/funambol/ds
    15:28:52 GMT -6:00 [INFO] - Preparing synchronization of contact...
    15:28:52 GMT -6:00 [DEBUG] - Checking devinfo...
    15:28:52 GMT -6:00 [DEBUG] - devinfo hash: MpE5oyCshECqt5aOKUtEZA==
    15:28:52 GMT -6:00 [DEBUG] - devinfo changed, retransmit
    15:28:52 GMT -6:00 [DEBUG] - Server capabilities are invalid (Server URL changed)
    15:28:52 GMT -6:00 [DEBUG] - Initialization message:
    15:28:52 GMT -6:00 [DEBUG] - User Agent = Funambol Outlook Sync Client v. 8.0.5
    15:28:52 GMT -6:00 [DEBUG] - Initialization sent.
    15:28:52 GMT -6:00 [DEBUG] - <?xml version="1.0" encoding="UTF-8"?>
    <SyncML>
    <SyncHdr><VerDTD>1.2</VerDTD>
    <VerProto>SyncML/1.2</VerProto>
    <SessionID>1259875732</SessionID>
    <MsgID>1</MsgID>
    <Target><LocURI>http://funambol:8080/funambol/ds</LocURI>
    </Target>
    <Source><LocURI>fol-RDZCQ1I0SzE6YW9nZGVu</LocURI>
    </Source>
    <Cred><Meta><Format xmlns="syncml:metinf">b64</Format>
    <Type xmlns="syncml:metinf">syncml:auth-basic</Type>
    </Meta>
    <Data>YW9nZGVuOkJvb2dhMTIz</Data>
    </Cred>
    <Meta><MaxMsgSize xmlns="syncml:metinf">250000</MaxMsgSize>
    </Meta>
    </SyncHdr>
    <SyncBody><Alert><CmdID>1</CmdID>
    <Data>200</Data>
    <Item><Target><LocURI>card</LocURI>
    </Target>
    <Source><LocURI>contact</LocURI>
    </Source>
    <Meta><Anchor xmlns="syncml:metinf"><Last>0</Last>
    <Next>1259875732</Next>
    </Anchor>
    </Meta>
    </Item>
    </Alert>
    <Get><CmdID>2</CmdID>
    <Meta><Type xmlns="syncml:metinf">application/vnd.syncml-devinf+xml</Type>
    </Meta>
    <Item><Target><LocURI>./devinf12</LocURI>
    </Target>
    </Item>
    </Get>
    <Put><CmdID>3</CmdID>
    <Meta><Type xmlns="syncml:metinf">application/vnd.syncml-devinf+xml</Type>
    </Meta>
    <Item><Source><LocURI>./devinf12</LocURI>
    </Source>
    <Data><DevInf xmlns="syncml:devinf"><VerDTD>1.2</VerDTD>
    <Man>Funambol</Man>
    <Mod>Funambol Outlook Sync Client</Mod>
    <SwV>8.0.5</SwV>
    <DevID>fol-RDZCQ1I0SzE6YW9nZGVu</DevID>
    <DevTyp>workstation</DevTyp>
    <UTC/><SupportLargeObjs/><SupportNumberOfChanges/><DataStore><SourceRef>appointment</SourceRef>
    <Rx-Pref><CTType>text/x-s4j-sife</CTType>
    <VerCT>1.1</VerCT>
    </Rx-Pref>
    <Rx><CTType>text/x-s4j-sife</CTType>
    <VerCT>1.0</VerCT>
    </Rx>
    <Rx><CTType>text/x-vcalendar</CTType>
    <VerCT>1.0</VerCT>
    </Rx>
    <Tx-Pref><CTType>text/x-s4j-sife</CTType>
    <VerCT>1.1</VerCT>
    </Tx-Pref>
    <Tx><CTType>text/x-s4j-sife</CTType>
    <VerCT>1.0</VerCT>
    </Tx>
    <Tx><CTType>text/x-vcalendar</CTType>
    <VerCT>1.0</VerCT>
    </Tx>
    <SyncCap><SyncType>2</SyncType>
    <SyncType>1</SyncType>
    <SyncType>5</SyncType>
    <SyncType>3</SyncType>
    <SyncType>6</SyncType>
    <SyncType>4</SyncType>
    </SyncCap>
    </DataStore>
    <DataStore><SourceRef>contact</SourceRef>
    <Rx-Pref><CTType>text/x-vcard</CTType>
    <VerCT>2.1</VerCT>
    </Rx-Pref>
    <Rx><CTType>text/x-s4j-sifc</CTType>
    <VerCT>1.0</VerCT>
    </Rx>
    <Rx><CTType>text/x-vcard</CTType>
    <VerCT>2.1</VerCT>
    </Rx>
    <Tx-Pref><CTType>text/x-vcard</CTType>
    <VerCT>2.1</VerCT>
    </Tx-Pref>
    <Tx><CTType>text/x-s4j-sifc</CTType>
    <VerCT>1.0</VerCT>
    </Tx>
    <Tx><CTType>text/x-vcard</CTType>
    <VerCT>2.1</VerCT>
    </Tx>
    <SyncCap><SyncType>2</SyncType>
    <SyncType>1</SyncType>
    <SyncType>5</SyncType>
    <SyncType>3</SyncType>
    <SyncType>6</SyncType>
    <SyncType>4</SyncType>
    </SyncCap>
    </DataStore>
    <DataStore><SourceRef>note</SourceRef>
    <Rx-Pref><CTType>text/x-s4j-sifn</CTType>
    <VerCT>1.0</VerCT>
    </Rx-Pref>
    <Rx><CTType>text/x-s4j-sifn</CTType>
    <VerCT>1.0</VerCT>
    </Rx>
    <Rx><CTType>text/x-vnote</CTType>
    <VerCT>1.1</VerCT>
    </Rx>
    <Tx-Pref><CTType>text/x-s4j-sifn</CTType>
    <VerCT>1.0</VerCT>
    </Tx-Pref>
    <Tx><CTType>text/x-s4j-sifn</CTType>
    <VerCT>1.0</VerCT>
    </Tx>
    <Tx><CTType>text/x-vnote</CTType>
    <VerCT>1.1</VerCT>
    </Tx>
    <SyncCap><SyncType>2</SyncType>
    <SyncType>1</SyncType>
    <SyncType>5</SyncType>
    <SyncType>3</SyncType>
    <SyncType>6</SyncType>
    <SyncType>4</SyncType>
    </SyncCap>
    </DataStore>
    <DataStore><SourceRef>task</SourceRef>
    <Rx-Pref><CTType>text/x-s4j-sift</CTType>
    <VerCT>1.0</VerCT>
    </Rx-Pref>
    <Rx><CTType>text/x-s4j-sift</CTType>
    <VerCT>1.0</VerCT>
    </Rx>
    <Rx><CTType>text/x-vcalendar</CTType>
    <VerCT>1.0</VerCT>
    </Rx>
    <Tx-Pref><CTType>text/x-s4j-sift</CTType>
    <VerCT>1.0</VerCT>
    </Tx-Pref>
    <Tx><CTType>text/x-s4j-sift</CTType>
    <VerCT>1.0</VerCT>
    </Tx>
    <Tx><CTType>text/x-vcalendar</CTType>
    <VerCT>1.0</VerCT>
    </Tx>
    <SyncCap><SyncType>2</SyncType>
    <SyncType>1</SyncType>
    <SyncType>5</SyncType>
    <SyncType>3</SyncType>
    <SyncType>6</SyncType>
    <SyncType>4</SyncType>
    </SyncCap>
    </DataStore>
    </DevInf>
    </Data>
    </Item>
    </Put>
    <Final/></SyncBody>
    </SyncML>
    15:28:52 GMT -6:00 [DEBUG] - Connecting to funambol:8080
    15:28:52 GMT -6:00 [DEBUG] - Requesting resource /funambol/ds
    15:28:52 GMT -6:00 [DEBUG] - Sending data of size 3856...
    15:28:53 GMT -6:00 [DEBUG] - Message sent
    15:28:53 GMT -6:00 [DEBUG] - Finished sending data of size 3856.
    15:28:53 GMT -6:00 [DEBUG] - Data sent successfully to server. Server responds OK
    15:28:53 GMT -6:00 [DEBUG] - Header: HTTP/1.1 200 OK
    
    Server: Apache-Coyote/1.1
    
    Set-Cookie:
    
    X-funambol-ds-server: DS Server v.8.0.1
    
    Accept-Encoding: gzip,deflate
    
    Content-Type: application/vnd.syncml+xml
    
    Content-Length: 1742
    
    Date: Thu, 03 Dec 2009 21:28:53 GMT
    
    
    
    
    15:28:53 GMT -6:00 [DEBUG] - Reading response...
    15:28:53 GMT -6:00 [DEBUG] - Content-length: 1742
    15:28:53 GMT -6:00 [DEBUG] - Receiving data of size 1742...
    15:28:53 GMT -6:00 [DEBUG] - Finished receiving data of size 1742.
    15:28:53 GMT -6:00 [DEBUG] - Response read:
    <?xml version="1.0" encoding="UTF-8"?>
    <SyncML>
    <SyncHdr>
    <VerDTD>1.2</VerDTD>
    <VerProto>SyncML/1.2</VerProto>
    <SessionID>1259875732</SessionID>
    <MsgID>1</MsgID>
    <Target>
    <LocURI>fol-RDZCQ1I0SzE6YW9nZGVu</LocURI>
    </Target>
    <Source>
    <LocURI>http://funambol:8080/funambol/ds</LocURI>
    </Source>
    <RespURI>http://funambol:8080/funambol/ds;jsessionid=7458CBC6D31E07E64EA43BD14E8AA1F2</RespURI>
    </SyncHdr>
    <SyncBody>
    <Status>
    <CmdID>1</CmdID>
    <MsgRef>1</MsgRef>
    <CmdRef>0</CmdRef>
    <Cmd>SyncHdr</Cmd>
    <TargetRef>http://funambol:8080/funambol/ds</TargetRef>
    <SourceRef>fol-RDZCQ1I0SzE6YW9nZGVu</SourceRef>
    <Data>212</Data>
    </Status>
    <Status>
    <CmdID>2</CmdID>
    <MsgRef>1</MsgRef>
    <CmdRef>1</CmdRef>
    <Cmd>Alert</Cmd>
    <TargetRef>card</TargetRef>
    <SourceRef>contact</SourceRef>
    <Data>404</Data>
    </Status>
    <Status>
    <CmdID>3</CmdID>
    <MsgRef>1</MsgRef>
    <CmdRef>2</CmdRef>
    <Cmd>Get</Cmd>
    <TargetRef>./devinf12</TargetRef>
    <Data>200</Data>
    </Status>
    <Status>
    <CmdID>4</CmdID>
    <MsgRef>1</MsgRef>
    <CmdRef>3</CmdRef>
    <Cmd>Put</Cmd>
    <SourceRef>./devinf12</SourceRef>
    <Data>200</Data>
    </Status>
    <Results>
    <CmdID>5</CmdID>
    <MsgRef>1</MsgRef>
    <CmdRef>2</CmdRef>
    <Meta>
    <Type xmlns='syncml:metinf'>application/vnd.syncml-devinf+xml</Type>
    </Meta>
    <Item>
    <Source>
    <LocURI>./devinf12</LocURI>
    </Source>
    <Data>
    <DevInf xmlns="syncml:devinf">
    <VerDTD>1.2</VerDTD>
    <Man>Funambol</Man>
    <Mod>DS Server</Mod>
    <OEM>-</OEM>
    <FwV>-</FwV>
    <SwV>8.0.1</SwV>
    <HwV>-</HwV>
    <DevID>funambol</DevID>
    <DevTyp>server</DevTyp>
    <UTC/>
    <SupportLargeObjs/>
    <SupportNumberOfChanges/>
    <Ext>
    <XNam>X-funambol-smartslow</XNam>
    </Ext>
    </DevInf>
    </Data>
    </Item>
    </Results>
    <Final/>
    </SyncBody>
    </SyncML>
    
    15:28:53 GMT -6:00 [ERROR] - AlertStatus from server 404
    15:28:53 GMT -6:00 [DEBUG] - Error occurred in sync: code 3 = AlertStatus from server 404
    15:28:53 GMT -6:00 [ERROR] - Error in preparing sync: AlertStatus from server 404
    15:28:53 GMT -6:00 [INFO] - 
    ============================================================
    ================   SYNCHRONIZATION REPORT   ================
    ============================================================
    
    SYNCHRONIZATION COMPLETED WITH ERRORS
    -------------------------------------
    Last error message = "AlertStatus from server 404"
    Last error code    = 404
    
    Contacts:
    ---------
        Sync failed: AlertStatus from server 404 (code = 404)
    
                | on Client | on Server
        --------|-----------|----------
        New     |    0/   0 |    0/   0 
        Updated |    0/   0 |    0/   0 
        Deleted |    0/   0 |    0/   0 
    
    
    
    15:28:53 GMT -6:00 [DEBUG] - Saving configuration to winRegistry
    15:28:53 GMT -6:00 [DEBUG] - Writing configuration settings to the management tree
    15:28:53 GMT -6:00 [DEBUG] - Releasing sync-mutex...
    15:28:53 GMT -6:00 [DEBUG] - Sync-mutex released - closing handle.
    15:28:53 GMT -6:00 [DEBUG] - Delete SyncSources...
    15:28:53 GMT -6:00 [INFO] - Syncronization process completed with errors (code = 404).
    15:28:54 GMT -6:00 [DEBUG] - Current Timezone = (UTC-06:00) Central Time (US & Canada)
    15:28:54 GMT -6:00 [DEBUG] - Reading configuration settings from the management tree
    15:28:54 GMT -6:00 [DEBUG] - Scheduled task not found.
    15:28:55 GMT -6:00 [DEBUG] - Current Timezone = (UTC-06:00) Central Time (US & Canada)
    15:28:55 GMT -6:00 [DEBUG] - Reading configuration settings from the management tree

  6. #526
    Join Date
    May 2009
    Posts
    134
    Rep Power
    6

    Default

    I haven't a clue but what is a 404 error?
    www.spiritualoutreach.com
    Making Christianity intelligible to secular society

  7. #527
    Join Date
    Aug 2007
    Posts
    6
    Rep Power
    8

    Default

    I wish I knew. The only other mention of a 404 I was able to find relating to Funambol was a post on another forum with no replies. I'm assuming it's a typical HTML 404. I just don't understand why it's not finding my data sources I set up following the guide.
    Last edited by fogogg; 12-04-2009 at 08:24 AM.

  8. #528
    Join Date
    May 2009
    Posts
    134
    Rep Power
    6

    Default

    Is there any chance that is actually a web server error reflecting through? What is an http 404 error? Would it shed any light on what you are seeing? just a mad, clutching at straws thought - John
    www.spiritualoutreach.com
    Making Christianity intelligible to secular society

  9. #529
    Join Date
    Aug 2007
    Posts
    6
    Rep Power
    8

    Default

    A 404 is a file not found. My guess is it's just telling me that it can't find scard or card or whatever name I stick in the "Remote Name" field. The problem is that I can open up the FunambolAdmin and look at both card and scard that I set up in the ZimbraConnector contacts section.

    What I DON'T know is why it can't or won't find those. No doubt it's something ridiculously simple.

  10. #530
    Join Date
    Nov 2009
    Posts
    4
    Rep Power
    5

    Default Alarm / Reminder not synced

    I'm using Funambol 8.0.2 - Connector 0.6.02 - Zimbra 6.0.3GA1915 and the reminder / alarm hasn't been syncing between device (tryed it on Iphone, Nokia and Blackberry) and zimbra.

    Running at debug mode, it looks like it is there:

    Code:
    <xprop name='REMINDER'>  <xparam name='ACTIVE'  value='true'/> <xparam name='MINUTES' value='15'/>   <xparam name='TIME' value='20091210T054500Z'/>  <xparam name='OPTIONS' value='0'/>  <xparam name='INTERVAL' value='0'/> <xparam name='REPEATCOUNT' value='0'/> </xprop>

    Anyone has similar problems with that using those sw versions? Does previous versions work properly with alarms?

Similar Threads

  1. Replies: 12
    Last Post: 08-25-2010, 03:37 AM
  2. Outlook Connector and Xerox Docushare Outlook Client
    By Gerry in forum Zimbra Connector for Outlook
    Replies: 0
    Last Post: 03-17-2009, 09:53 PM
  3. Calendar sync issue of Zimbra with Outlook
    By rajivnair in forum Zimbra Connector for Outlook
    Replies: 3
    Last Post: 04-14-2008, 09:16 PM
  4. Sync delays in outlook connector
    By jonnyRo in forum Zimbra Connector for Outlook
    Replies: 3
    Last Post: 06-23-2006, 09:23 AM
  5. Migration Client causing Outlook Problems
    By jonfehringer in forum Administrators
    Replies: 4
    Last Post: 10-04-2005, 11:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •