Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: User with shared folder rights can't access them

  1. #1
    Join Date
    Aug 2006
    Posts
    19
    Rep Power
    9

    Default User with shared folder rights can't access them

    Running zimbra-4.0.0_GA_303.RHEL4-20060829135206 and ZimbraOlkConnector-4.0.0_GA_297_4.0.211.msi.

    I have a user with rights to another user's contacts and calendar. We've have lots of problem with the sync to the other person's contacts.

    I've re-created her outlook profile a few times in an effort to get the sync right. Now, with the current profile, the file choice File/Open Other User's Mailbox is greyed out; so I can't even start a sync to the other box. What should I do?

    I supposed I could completely remove the Connector and Outlook and reinstall, but it does seem like a lot of work...

  2. #2
    Join Date
    Aug 2005
    Posts
    821
    Rep Power
    11

    Default

    It looks like our sharing add-in isn't running. In outlook, look in tools->options->other->advanced->com add-ins. It should show Zimbra Sharing Addin and it should be checked. If it is not checked, check it. If it is disabled go to help->about->disabled items and enable it.
    Sam Khavari

    :: :: [ Zimbra ] :: :: [ Bugzilla ] :: :: [ Product Portal ] :: :: [ Wiki ] :: :: [ Downloads ] :: :: [ . ] ::

  3. #3
    Join Date
    Aug 2006
    Posts
    19
    Rep Power
    9

    Default Thanks!

    That was it. The COM addin wasn't checked off.

    Now the user is syncing.

  4. #4
    Join Date
    Oct 2006
    Posts
    103
    Rep Power
    9

    Default

    I'm having the same issue with Open User's Folder being greyed out. I checked Disabled Items AND the COM addin. Nothing regarding Zimbra is listed at all. So there is nothing to enable for either. Syncing seems to be working with my email folders, etc, but I can't open shared folders or calendar items. Ideas?

  5. #5
    Join Date
    Aug 2005
    Posts
    821
    Rep Power
    11

    Default

    from your description it looks like the sharingAddin is not available somehow

    what version of the connector do you have (click the support link in control panel->add/remove programs to get the version number).
    Sam Khavari

    :: :: [ Zimbra ] :: :: [ Bugzilla ] :: :: [ Product Portal ] :: :: [ Wiki ] :: :: [ Downloads ] :: :: [ . ] ::

  6. #6
    Join Date
    Oct 2006
    Posts
    103
    Rep Power
    9

    Default

    When I click on the Click here for support information, I get:
    Publish: Zimbra, Inc.
    Version: 4.0.273.0

    But the install file name is called ZimbraOlkConnector-4.0.3_GA_405_4.0.273.msi.

  7. #7
    Join Date
    Aug 2005
    Posts
    821
    Rep Power
    11

    Default

    you have the right version.

    Can you check the registry to see if the sharing add-in is registered? It would be here:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Outlo ok\Addins\SharingAddin.Addin

    What is the value of the LoadBehavior key?
    Sam Khavari

    :: :: [ Zimbra ] :: :: [ Bugzilla ] :: :: [ Product Portal ] :: :: [ Wiki ] :: :: [ Downloads ] :: :: [ . ] ::

  8. #8
    Join Date
    Oct 2006
    Posts
    103
    Rep Power
    9

    Default

    LoadBehavior = 3 (both decimal and dword)

    Edit:

    *CORRECTION*
    The PC that was having the problem had LoadBehavior = 2. Changed it to 3 (to match mine that is working) and all is working now with one MINOR glitch. I shared a single folder with the user, and they can view EVERYTHING of mine. All my email, contacts, folders, etc. Surely thats not by design. One caveat though, he is an admin. Does that matter and thus the reason he can view everything I have?
    Last edited by jareep; 10-30-2006 at 10:47 AM.

  9. #9
    Join Date
    Aug 2005
    Posts
    821
    Rep Power
    11

    Default

    currently, admins have full access to all mailbox content irrespective of what has been explicitly shared. there is a bug for this in bugzilla.
    Sam Khavari

    :: :: [ Zimbra ] :: :: [ Bugzilla ] :: :: [ Product Portal ] :: :: [ Wiki ] :: :: [ Downloads ] :: :: [ . ] ::

  10. #10
    Join Date
    Aug 2006
    Location
    Essex, UK
    Posts
    250
    Rep Power
    9

    Default

    Just to add to this Guys.

    The fix above worked for me too, it changed the entry on the menu from 'Other Users Folder' to 'Other Users Mailbox' and it is no longer greyed out.

    Strange thing is, one of my Users using Office 2003 Professional did not have this error, only me using Office 2003 SBE.

    I will post this on the Bug report too, which number is it by the way?.

Similar Threads

  1. Replies: 21
    Last Post: 02-04-2010, 09:06 AM
  2. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 12:42 AM
  3. Post instsallation problems
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 10:38 AM
  4. Services stopped working
    By lilwong in forum Administrators
    Replies: 4
    Last Post: 08-15-2006, 09:19 AM
  5. Fedora Core 3, Clean Install - Not working!
    By pcjackson in forum Installation
    Replies: 17
    Last Post: 03-05-2006, 06:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •