This is the message:
Send test e-mail message: Outlook cannot connect to your outgoing (SMTP) e-mail server. If you continue to receive this message, contact your server administrator or Internet service provider (ISP).

Here are some logs:
With defaults:
2011.03.27 13:57:40 SMTP (smtp.theonlinebusiness.com): Port: 25, Secure: no, SPA: no
2011.03.27 13:57:40 SMTP (smtp.theonlinebusiness.com): Finding host
2011.03.27 13:58:01 SMTP (smtp.theonlinebusiness.com): Disconnected from host

Using SSL on incoming gives this error:
Log onto incoming mail server (POP3): Outlook cannot connect to your incoming (POP3) e-mail server. If you continue to receive this message, contact your server administrator or Internet service provider (ISP).
2011.03.27 14:02:30 POP3 (pop.theonlinebusiness.com): Port: 995, Secure: SSL, SPA: no
2011.03.27 14:02:30 POP3 (pop.theonlinebusiness.com): Finding host
2011.03.27 14:02:30 POP3 (pop.theonlinebusiness.com): Connecting to host
2011.03.27 14:02:31 POP3 (pop.theonlinebusiness.com): Disconnected from host

2011.03.27 14:02:17 SMTP (smtp.theonlinebusiness.com): Port: 465, Secure: SSL, SPA: no
2011.03.27 14:02:17 SMTP (smtp.theonlinebusiness.com): Finding host
2011.03.27 14:02:17 SMTP (smtp.theonlinebusiness.com): Connecting to host
2011.03.27 14:02:19 SMTP (smtp.theonlinebusiness.com): Disconnecting from host
2011.03.27 14:02:19 SMTP (smtp.theonlinebusiness.com): Disconnected from host

Using only on outgoing on 465, SSL
2011.03.27 14:01:03 SMTP (smtp.theonlinebusiness.com): Port: 465, Secure: SSL, SPA: no
2011.03.27 14:01:03 SMTP (smtp.theonlinebusiness.com): Finding host
2011.03.27 14:01:03 SMTP (smtp.theonlinebusiness.com): Connecting to host
2011.03.27 14:01:24 SMTP (smtp.theonlinebusiness.com): Disconnected from host

Using only on outgoing on 465, TLS
2011.03.27 13:51:23 SMTP (smtp.theonlinebusiness.com): Port: 465, Secure: TLS, SPA: no
2011.03.27 13:51:23 SMTP (smtp.theonlinebusiness.com): Finding host
2011.03.27 13:51:23 SMTP (smtp.theonlinebusiness.com): Connecting to host
2011.03.27 13:51:44 SMTP (smtp.theonlinebusiness.com): Disconnected from host

Earthlink needs smtpauth rather than just smpt
2011.03.27 13:38:43 SMTP (smtpauth.theonlinebusiness.com): Port: 465, Secure: TLS, SPA: yes
2011.03.27 13:38:43 SMTP (smtpauth.theonlinebusiness.com): Finding host
2011.03.27 13:38:43 SMTP (smtpauth.theonlinebusiness.com): Connecting to host
2011.03.27 13:39:04 SMTP (smtpauth.theonlinebusiness.com): Disconnected from host

Help or a direction would be appreciated!