Our IT department is trying to move to newer laptops, and that includes Windows 7 64-bit. Until now I'd been running Windows XP 32-bit. We're still on ZCS 5.0.26, with the 5.0.24 version of the ZCO. I was able to install Outlook and the ZCO, and re-connect to two calendars that I had access to, but there's a third that allows a connection, but won't display any "appointments" no matter what I do. It's a calendar that displays who has time off and is out of the office on what days, controlled by our HR department.

I've tried checking the registry, I tried:
Code:
regsvr32 /u /s SharingAddin.dll
regsvr32 /s SharingAddin.dll
I have also gone so far as to uninstall Outlook, uninstall the ZCO, reinstall Outlook, re-apply all patches and updates, and reinstall the ZCO. That didn't help. I revoked my rights from the calendar and restored them, and that didn't do anything either. The only "hint" I'm getting is in the Zimbra Send/Receive Progress - Synchronizing fails with "Unknown failure".

Any ideas? Other than upgrade to ZCS 6 or 7, which is in our plans, but wasn't going to happen just yet....