I will be filing a bug request on the support portal - I am posting this info because I found no issue like this on the web.

In the past few weeks, users mailboxes have been very frequently filling up. I sent my techs around to check that the users (ones with mailboxes filling up) had auto archive setup. They verified and forced each computer to archive. No change, mailboxes still full. We went and looked at the archive settings on the folder level. When you check the inbox folder, it has been set to "do not archive" we then set it to use the default archive settings (or any other setting). Press apply, go back to the properties and it is set back to "do not archive"!. I have tried everything on the outlook client to make it work -

FIX: Uninstall Zimbra connector for outlook version 7.1.4 and installed Older Zimbra connector. I went to 7.0.1. Now I can archive again.

Outlook 2007 SP 3
Zimbra professional (server) 7.1.4

Major bug will be filed. We have 325 users on our system and it will fill up all of their quotas fast.