After upgrade from 4.0.5_NE_RHEL4 to 4.5.1_NE_RHEL4 and upgrading
ZCO similarly, I get this message when trying to open Outlook.

"Microsoft Office Outlook: Unable to open your default e-mail folders."

The help message offered says:

"This error can occur if you attempt to run Outlook from a Terminal Server session when the OST file is in use by the console session. To access this instance of Outlook, exit the current Terminal Server session and start a new session by using the following Run command (click Start, then click Run):
mstsc.exe /CONSOLE
You must be an administrator on the computer that is accessing the console session. You cannot access a console session running on Microsoft Windows 2000 Server or Microsoft Windows XP Home edition. But you can from a computer running Microsoft Windows Server 2003 or Microsoft Windows XP Professional.
For more information about using Outlook and Terminal Server, see Knowledge Base article 826488."

Well, that's not what's happening. I'm using it on a local workstation (albeit with a roaming profile) running Windows XP SP2.

I have tried what usually worked when there were ZCO problems in the past: delete the profile, delete the .zdb file in Local Settings, and try to start Outlook again. For good measure I also removed the zdb files from my roaming profile. In the past this would force a new profile to be created, new zdb file to be synced up, etc. This solution results in no change this time, however; I get exactly the same message.

ZCO was working properly before upgrade.

I've used DebugView and the only message it gives is:

[2492] First time patch on vtbl 0x360B4488

Anybody got any thoughts? My suspicion is that it's something weird in the new support for roaming profiles.