We are deploying Dynamics AX and have a hit a hurdle with its integration with Outlook, specifically, with the Outlook Setup Wizard in the CRM section of Dynamics AX.

This setup wizard works OK with a standalone Outlook profile; ie: a POP3 or IMAP profile but it "crashes" with the Outlook-Zimbra profile. It doesn't make any difference whether Outlook is open or not when the setup wizard is run.

The error message displayed is "Could not communicate with Microsoft Office Outlook client". The AX client displays a debug window with the function (written in AX's language X++) and from what I can determine, AX is attempting to determine the user details (ie: user name, full name, email address and entryID) from the Outlook profile.

Looking at the two profiles, in the standalone Outlook profile, these details are all configured locally, while in an Outlook-Zimbra profile, only the server name and user name are entered and the other details are retrieved from the server. Whether this is relevant or not I don't know.

Any assistance with this issue would be appreciated.

Server version is Release 4.5.5_GA_838.RHEL4_20070503171738 CentOS4 NETWORK edition

Tested with the Outlook connector from versions v.4.5.4 and v4.5.5.

As per the "Tips on how to report errors with the ZCS Outlook Connector", I ran DebugView and then ran the AX Outlook Setup Wizard - DebugView logged the following:
[1004] Addin::ctor
[1004] Addin::FinalConstruct
[1004] First time patch on vtbl 0x360B4488
[1004] Addin::FinalRelease